Jump to content

Can't save edited audio files in MP3 Format


Recommended Posts

I installed WavePad from official download site of NCH Software recently. I wanted to test if it work like it did previously before buying master's edition.

I opened a my favorite MP3 Song and edited it as I expected.

Then I tried to save my edited Audio File in MP3 Format.

When I choose "Save" from dialog box, WavePad shows a dialog box telling "Download install-on-demand - mp3el3.".

But I can see the file "mp3el3.exe" alrady exists in "C:\Program Files (x86)\NCH Software\WavePad".

Why it still requires this file?????

After few seconds, it changes like "Running install-on-demand - mp3el3."

Then, WavePad becomes not responding.

I am getting message "WavePad Sound Editor is not responding".

 

Then, I am getting message "An install-on-demand component could not be installed automatically. Please run it from the URL below then try again. http://www.nch.com.a...ents/mp3el3.exe" and WavePad opens the following page:

http://www.nch.com.a...ents/mp3el3.exe

I can't believe why this component "COULD NOT BE INSTALLED" even I have very good 4G High-Speed Router Network Connection.

 

Then after I downloading MP3 Encoder (mp3el3.exe), and choose "Open" from the Download Complete dialog of IDM, I can see mp3el3.exe process is running in Task Manager.

 

After the process leaves itself automatically after few seconds, I tried to save my edited file again in MP3 Format.

 

I am still getting dialog box "Download install-on-demand - mp3el3.".

 

Such thing never happened before when I am using WavePad five months ago in same computer.

And I didn't download ANY component to save files in MP3 Format before in WavePad.

It did it correctly without any problem before.

 

My System Information:

Operating System: Windows 7 Ultimate 64 bit - Service Pack 1

CPU: Intel Core i5 - 6600K 3.2GHz

8GM DDR4 RAM

Asus Strix GeForce GTX 970 4GB

 

Please help me to make WavePad save Audio Files in MP3 Format again like it did before.

Link to post
Share on other sites

Hi,

 

Try the following,

 

1. From WavePad, select the Options menu > Audio tab > "Audio working folder" section, check mark the "Use this specified folder" box and copy the folder path.

 

C:\Users\YourUserName\AppData\Roaming\NCH Software\WavePad.

 

2. Paste the path on your windows folder explorer, this will open the Cache content files.

 

3. Delete all files within this folder.

 

4. Close WavePad and re open it again.

 

5. Re load the file and test.

 

You can also contact the NCH support at supportnch@nchsoftware.com

 

Regards,

Link to post
Share on other sites

I tried doing above, and also tried copying "mp3el3.exe" to the Audio Working Folder but with no success...... :( :( :(

What can be the cause of this problem? Is the Service Pack 1 I installed causes this problem?

 

NOTE: I can save edited files in .WAV Format without any problem.

Link to post
Share on other sites
  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...