Jump to content

Audio gets distorted


Recommended Posts



I'm trying to export a video + an audio track (mp3) from VideoPad version 4.40, but I figured out that my audio is being distorted after it is imported as an Audio Cip. Whenever I play the audio file on the "Clip Preview" it gets distorted, you will hear a cricket like sound (yes, I mean the insect). If I play the original mp3 file with an external player (ie: VLC and Windows Media Player), then it sound as it should.


In order to show you what I mean, I exported the original mp3 file by using VideoPad as follows:

1) Right clicked on the imported mp3

2) Chose "Save Audio Clip as New File"


A .wav file was produced and the problem is there. Here the links to my audios

  1. Original file
  2. Exported audio file

The first four tones are normal. Just hear each time that I pushed the pedal of my yamaha organ.


Is this a bug? Or perhaps a problem with my setup? I even tried converting the mp3 file to wav using WavePad and Audacity; in both cases the wav file was ok. So, I think this is either a problem with the import on VIdeoPad or with some codec that it is using.




Link to comment
Share on other sites

Hi Zhang


I played both files on Windows 10 and Windows 7 and three different PCs, the wav file sounds different. It happens as I pushed the pedal of my Yamaha Electone. I even join a video with the audio and I can hear it.


Unfortunately, I don't have any other playback device on my laptop, so, I can't do that test. I will upload a processed video with the audio track to youtube and see if there is a difference there.


Best regards


Link to comment
Share on other sites

Hi Sam


I did the same thing on a different computer, but this time, I worked with a wav file instead of an mp3 one. Here is what I did:

1) On VideoPad, I imported my wav file:


2) Then I hit play on the "Clip Preview" window. At this point I could hear the noise.

3) Then I clicked on the imported wav file and click on: "Save Audio Clip as New File".

4) I opened the file and could hear the noise.


Thanks to a post on another forum, I figured out that you can see if two files are identical in Audacity:

1) Open Audacity

2) Import both wav files

3) Select the first file and do: Effect > Invert

4) Select both files and do: Tracks > Mix and Render


If both files are equal, then you should get an empty track. In my case, I got that noise, that I was hearing, while pushing the pedals.


Here the isolated noise that the software generates:



Up-to the 6 second, you will hear it.


The possible cause is that my original wav file has this settings:

Bit rate : 1 411.2 Kbps

Sampling rate : 44.1 KHz


But the software change it by:

Bit rate : 1 536 Kbps

Sampling rate : 48.0 KHz


Is there any way of telling VideoPad not to change the original audio track? Or at least not trying to increase its sampling and bit rate?


Best regards


Link to comment
Share on other sites

Hi Josef,


Since VP converted the sample rate therefore new samples are inserted. So it is normal that you can find extra samples when you compare to the original.


We've noticed the artifact now and started investigate two problems:

  1. Why VideoPad have to convert the sample rate?
  2. Why artifacts are introduced while converting sample rate?

I'll get back here once we solve these problems.


Thank you,

Link to comment
Share on other sites



You can find the noise in WavePad when you zoom in vertically. But they didn't look like having a problem though.


You must have a better eye/ear than I do, for no matter how extreme WP zooms in via the slider at the right-bottom corner there is absolutely nothing to be heard or seen here. It's a flat line.

Link to comment
Share on other sites


  1. We've found no reason to force convert sample rate. We are working on remove the conversion and keep the original sample rate whenever possible.
  2. We've also found a bug in the sound filter that converts sample rate.

The fixes will be applied to the next release.


Thanks again for reporting issues,

Link to comment
Share on other sites

Wouldn't think the WP version would make a difference. A sound is a sound. And two players, at full volume, are silent. Here's what WP version 5.33 displays.




Hi borate


Amplify the sound in audacity and you will see that in deed there is something there. It is the same as the original melody, but at a lower volume and a different tone. Somehow when the sound gets imported, VideoPad resamples the audio and copied the melody a second time, but with that low volume. I compared both audios: the original and the exported one and the difference will be noticed whenever the instrument's pedal gets pushed. It is like an extra vibration.


Best reagards


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...