Jump to content

Screen Recordings Lag/Drop Frames


Recommended Posts

I November 2015 I purchased a new Debut license to install on my laptop. The recordings were laggy and the program constantly froze when I stopped recording, bringing up the 'Not Responding' warning. It would freeze up the computer to where I had to shut it down because I couldn't even bring up the Task Manager to 'End Task' on Debut. I figured the laptop just couldn't handle the program and bought a new 'High Performance' laptop. Unfortunately, I have the same results of poor, jerky recordings on the new laptop but it hasn't frozen up yet. (Have only had the new laptop for 3 days.)

 

So, I tried to install Debut on my desktop and couldn't because it had already been installed on 2 different machines. I had to buy another license to install it on my desktop (which was specially built for heavy loads) and the recordings are still dropping frames and laggy. I have it set up to record for 30 minutes, then stop and start a new recording. Once it reaches the 30 minute mark it "Stops Responding" and freezes up the computer to the point where I can't even End Task in Task Manager because everything is frozen. I then have to shut off the computer.

 

I've used an older version of Debut on my desktop and never had this issue. And since I've had these problems on 3 different machines I am certain there is something very wrong with this latest version. I've written to tech support twice and the only responses I've gotten completely ignored my question and instead offered this: "If you still need support, or if there is additional information you can provide, please let us know so we can provide you with assistance as soon as possible."

 

What does one have to do to get help with this kind of issue? I feel I've wasted $80.00 on a program that I can't use and no one is willing to help me get this straightened out. If I uninstall/reinstall, that will be viewed as installing on two machines and I won't be able to try it again should that fail. I'm completely fed up.

 

Anyone have any similar experiences or suggestions as to what I might do to remedy this situation? I'd appreciate the help.

Link to post
Share on other sites

Thank-you. I have replied and hope to find an answer.

 

Edited: I received a pop-up asking me how I like Debut. I was able to send a bug report. It then directed me to the latest update, version 2.26. I was able to install that update but the lagging recordings and freeze-ups are still happening on both the laptop and my desktop.

Link to post
Share on other sites

I am very familiar with buggy Debut versions (can't help wondering if the sole purpose of new versions is to introduce new bugs, as I don't see any other differences, not in the functions I use, anyway) - but I don't have any solutions. One version, newly installed, totally froze the system every time I opened it, yet months later I tried it again and it was OK. I have the exe files for a lot of versions since 2011 but NCH/Debut's licences are the most restrictive I've come across...

 

It's such a nice program, when it works :P

Link to post
Share on other sites
  • 2 weeks later...

After several attempts to remedy this problem working with NCH Tech support, the only thing that worked was uninstalling the latest version of Debut and going back to the version I've used for years without any problems (version 1.68). I hope NCH will address and fix the bugs in this program.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...