Jump to content

Recommended Posts

Anyone having an issue getting Mixpad to recognize their audio interface since upgrading to OS El Capitan? I'm using the M-Audio Fast Track Pro. All was great until I updated the OS to El Capitan. Trying to track down if it is an M-Audio driver issue or a Mixpad issue.

Link to post
Share on other sites

Hi kneimond,

I suspect the issue is mainly to do with the upgrade to El Capitan. The latest core audio drivers for the fasttrack don't mention support for El Capitan and the latency issue you describe is very likely to be driver related.

 

When you change the latency settings on the fasttrack are you getting any changes at all?

Regards,

Ben

Link to post
Share on other sites

Hi Kevin,

Ok so in the context of audio hardware, latency actually refers to the internal buffer size that the audio hardware uses to record/playback music. The smaller you make that number the smaller the buffer size is and the smaller the latency.

 

The lower the latency, the more processing your computer has to do because it has to swap buffers more often which is computationally expensive. If your computer is unable to keep up with swapping these buffers often enough you will start to experience issues like audio looping and skipping and jerky playback and recording.

 

A higher latency is easier for your computer to handle, but it comes at the cost of adding a time lag to your playback. What this means is that when you are playing your track and you make some changes to something like the volume or pan or an effect, you will not hear those changes until the next buffer swap.

 

If I recall correctly, the maximum latency setting on the fast track is only around 250ms or something like that. So even with it set to the maximum you are unlikely to experience many serious problems. Really low latency is most important for live performance products like DJ programs.

 

As a note, it doesn't matter what your latency settings are in regard to having correctly sync'd recording and playback. That should work regardless.

 

So we know we're on the same page here, can you describe the latency problem you are having?

Regards,

Ben

Link to post
Share on other sites

Hi Ben,

 

Lets say I have a drum track playing a standard 4 beat per measure with the kick drum on the 1, 2, 3, and 4. If I then record a separate bass track and mirror the kick (one note on the 1, 2, 3, and 4), it all sounds great to the ears while I am playing. However, when I go back and listen to it and view it on the screen, the bass track is about a half beat behind the kick drum.

 

I should note that prior to updating my OS to El Capitan, I did not have this gap.

 

Thanks, Kevin

Link to post
Share on other sites

Hi kneimond,

Ok it sounds like you're facing a few issues here. The out-of-sync recording should *never* happen with the fast-track and it convinces me that it has a driver compatibility issue with El Capitan.

 

However, there is a work around which may help in this instance. In the "General" tab of the Options dialog, there is a field called "Offset Recordings". You can enter a millisecond value here which will automatically apply an offset to your recordings to get them to correctly sync with your other tracks. If the latency is consistent then you might be able to get a decent result by figuring out how far to offset - it could take a bit of experimentation.

 

As for upgrading to El Capitan, you are only one of many people I have heard complaining about unexpected breakages after the update. My laptop runs Mac, and after I upgraded to El Capitan I have noticed a *massive* decrease in speed :(

 

Regards,

Ben

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...