Jump to content

Sync problems with inventoria


Recommended Posts

Sorry if this is a simple thing but new to this and having a nightmare.


Running Inventoria for my inventory (!)


And express invoice for my invoicing (Good huh!)


But the two will not sync. I have the IP addresses all set up okay and tested all good but when i try an retrieve locations and update inventory from express invoice i get cannot connect http://1.1 404 error.


I am running a MAC and desperately need help!!!!

Link to comment
Share on other sites

Here's what I do using PC & V4.32 it may be similar in mac.

In Inventoria go to 'Options' and select 'Web Access' and place a check mark next to 'Allow access to Inventoria on the

local network & click OK.


Now go to Express invoice,

Options, 'Inventoria, place a check mark next to -

'Allow express invoice invoicing software to synchronize with inventoria'.


Have you created an 'Access authentication code? if not create one example -

1234 make sure your IP address/ Port Number 1097 and the location name is all here, i.e. Main Warehouse. keep this page open.


You can check your locations by going into Inventoria, and look at your stock locations make sure these have the same name i.e. or the default name 'Main Warehouse'


go to Inventoria-options and then 'Other'

place a check mark next to 'Allow express invoice to synchronize with Inventoria'

and type in the authentication number you created in Express invoice i.e. 1234. click OK & OK again.

Now go back to Express invoice and 'Retrieve Locations and then 'Update Now'.

I hope this helps you out

Link to comment
Share on other sites

  • 2 weeks later...

I am having this issue also...for the 2nd time :( I have everything set up properly and it will be working fine, then all of a sudden one day when trying to "update" I get this window that says

"Synchronization Error - Server failed to respond to connection attempt.

This will only happen sometimes for the first couple days, then it is every time and will not update/sync. The 1st time this happened it was suggested to me to run a drive cleaner program, which I did and (although it corrupted my audio files) it did seem to fix the sync problem; for about 4 weeks, then it started again and here I am unable to function properly.

I am running on windows 7, if that makes a difference.

Link to comment
Share on other sites

  • 3 months later...

Hi xpert trailer, we are having that same issue but all the time!! Quantities don't seem to be syncing at all between the two programs (we are using express accounts and inventoria). This is really frustrating and we are about to get rid of this software and start again with something else!! But before we do, just thought i would ask if you were able to resolve the issue? Any advice?

Thanks a lot

Link to comment
Share on other sites

I'm sorry to hear you are having the same problems. Ours is VERY consistently not working and getting worse even, every day. Now Inventoria locks up for 20-30 sec every time we do anything on it. We recently purchased QuickBooks with the hopes that it will be a more functional program. It's taking some time to get files converted/transferred properly though. Good luck with your endeavor.

Link to comment
Share on other sites

Hi, xpert trailer this issue will be better handled by NCH software support team so you can get the proper solution, you may report your issue through this link http://www.nch.com.au/support/supportcontact.html

Please check if you are able to use the Web access feature on both programs and include your answer on the support request you submit, this will help to address the issue faster.

Link to comment
Share on other sites

  • 1 month later...

Hi HCE and xpert trailer,

I don’t know if this is the cause of your problems, but I have found a bug in Inventoria that could cause some of the issues that you are experiencing. Inventoria has a memory leak that will use up all the free nonpaged memory pool. When the nonpaged pool is exhausted you will experience major delay as xpert has experienced and EI and Inventoria sync will fail because Inventoria will time out. I have reported this bug, and even told them where to find the bug (I am actually a C++/Assembler Programmer). The bug has to do with the way Inventoria monitors changes to the data files. The following is part of the bug report I sent to support:


Inventoria is making multiple calls to IRP_MJ_DIRECTORY_CONTROL within a matter of a second. RP_MJ_DIRECTORY_CONTROL is being called with “NotifyChangeDirectory” which Microsoft defines as “Indicates a request for notification of changes to the directory. Usually, instead of satisfying this request immediately, the file system driver holds the IRP in a private queue. When a change occurs to the directory, the file system driver performs the notification, and dequeues and completes the IRP.” Inventoria only needs to make a SINGLE request for each directory, if nothing is happening in any of the directories at the time of the IRP_MJ_DIRECTORY_CONTROL, the IRP is placed in a private queue and waits for a change event in one of the directories. Now since these IRP_MJ_DIRECTORY_CONTROL operation is being generated at a astronomical rate, if IRP’s were being place on the private queue without fulfilling the previous IRP for the same directory this would start to fill the private queue fast, and what kind of memory would this private queue used, NONPAGED MEMORY. This is exactly what appears to be happening.


So what does this mean to you, HCE and xpert? The first problem is Inventoria will cause your computer to take forever to do even the simplest task. The second, with multiple IRPs being placed on the private queue, it may be possible to have multiple IRPs fired of at once when a directory is changed, this could result in unusual behaviour like maybe no sync when it should be syncing.


There is one workaround that could solve the slow response times and that is to completely shut down Inventoria. I have about a thousand items in my database and I lose about 61k of nonpage pool a second, with 8 Gb of memory I have to restart at minimum once a day (I run out of memory after a day and a half). This workaround does not solve the possibility of multiple IRP firing on directory changes. that will require a code fix.



Link to comment
Share on other sites

  • 4 months later...

Thanks xpert trailer and Gunner! What you say about the program doesn't sound very promising, but hopefully that doesn't become more of an issue for us... would be great if nch responded with an update to fix the bug!?

We eventually managed to solve our issue! So for anyone else with the same problem... I noticed that MsMpEng.exe was hogging CPU usage when I hit the update button, for Express Accounts to to update with Inventoria, until the program gave "not responding" and "Synchronization Error - Server failed to respond to connection attempt". MsMpEng.exe is associated with Windows Defender, therefore, to solve the problem I added both expressaccounts.exe and inventoria.exe as exclusions under windows defender settings. So far, so good!


Link to comment
Share on other sites

  • 3 months later...

I am having the same exact problem and I email NCH and they say they never heard of such a thing. (Read above then) I am currently receiving the Synchronization Error HTTP/1.1 404 Not found even though the NCH software says system configured correctly - CAN ANYONE HELP ???


My email to them:

I am still having problems with this...... I finally had both programs running smoothly for a year or two then started seeing crash problems following Yosemite upgrade then El Capitan computer crash's where every single invoice. Upgraded both E.I. and inventoria. Now E.I. will not update quantities in inventoria once an invoice is created, it updates the stock in E.I. but no communication with inventory.


communication is working between inventoria and E.I. because I can go to E.I. / preferences / inventory / update now and that works just doesn't update back to inventory


Mac version 10.11.3

Inventoria 3.69


Express Invoice 4.45

Link to comment
Share on other sites

  • 5 months later...

Hi HCE and skiman1,




As Inventoria eats up non-paged memory, every other program will have less memory to work with; if left running Inventoria will hang Windows. Windows need non-paged memory to swap memory, switch task, etc, once the non-paged memory is gone so is Windows. As Windows starts to run out of memory, Windows will start swapping memory to disk and that will slow things down! There is a new version of Inventoria but the bug seems to remain.



My discussion is about the Windows versions of the software and not MAC, sorry I can't help.



Link to comment
Share on other sites

  • 2 years later...

I guess I never posted the fix to this, at least the one I found.


on iOS:   GO / go to folder / ~/Library / application support folder / NCH software folder / express invoice folder / shared folder / sync items folder


Delete everything in there! I have to do this EVERY TIME I run invoices and I leave the window open while I do invoices because if there is any stock discrepancies it starts to create files in this folder. 


Honestly I will not renew NCH any more - looking for another program now because these two programs should work seamlessly not all the extra work I need to do EVERY SINGLE TIME I run invoices 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...