Jump to content

Recommended Posts

Adjust transition duration by clicking the clip that contains the transition. Now click the TRANSITION icon or click the small blue square at the right-top of the clip on the timeline.

Then click the "transition properties" button at the bottom of the effects screen and set the time. Click on OK. Of course, the clip itself must be long enough to accommodate the specified transition length.

 

Try using the CROSSfade transition.

Link to post
Share on other sites

Thanks for the quick reply

But this doesn't work.

 

I had all the transitions on each jpeg clip set to 1.5 seconds. Then when I inserted an additional picture, a message popped up saying the transition of surrounding clips was being shortened. Each clip is 3 seconds long.

 

Is there a fixed length of the entire project the program is trying to maintain? This project is less than 20 minutes long.

Link to post
Share on other sites

I can invoke that prompt, which then affects only the immediately surrounding transitions, as you noted.

 

Seems that this results from the clip being too short to accommodate the transition, which hints that the

clip should be lengthened or the transition shortened.

 

In essence VP is doing that for you by shortening the transition, while not changing overall project length.

Link to post
Share on other sites

Each clip is 3 seconds long -- including this one that I added last -- with a fade transition of 1.5 seconds. I tried making this particular clip 6 seconds long with no change. Max transition is .60 seconds either way, but only with this one clip. All the others are unchanged...

 

This also happened on another project when transitioning (flip) from one video clip to another. In that project there are two transitions, but one will not allow me to go longer than .25 seconds.

Link to post
Share on other sites

Hi

I can't get this to happen. (VP 3.79) I have placed several 3 second jpg images onto the timeline with manually added FADE transitions of 1.5 seconds between them. They played as expected. Go into Storyboard mode and check what you have.

 

g98ukofacp.jpg

 

The FADE is divided between clips but I do notice that the final FADE is not showing the orange band (of 1.5 seconds) although it plays. Normally I find you can extend the duration of the transitions until they actually touch. (Note the final transition bar is blank [not orange] and is 1.5 seconds duration and entirely within the last clip....it's not divided.)

 

Nat

Link to post
Share on other sites

Hi

 

Tried..... and it works exactly the same with VP 3.81. The only difference I can see in storyboard mode is that the orange transition bar of 1.5 seconds is now visible, but that is not the problem you seem to be having.

The clips also look and play the same in timeline mode. Adding another 3 second clip to end makes the previous 1.5 second fade divide across the join as normal. So no apparent problem with this version.

 

However..if, for example your 2 clips are each 3 seconds long and you add a 4 second fade to clip 1, (i.e. between them) all will be fine and each clip will get a 2 second fade (2 sec OUT and 2 sec IN) . But this will leave only a 1 second portion on clip 2 for any further transition.

 

If you now add a third 3 second clip and try to add a 4 second fade to the end of clip 2 you will get the message you did regarding shortening the transition as you can't put 2 seconds of the transition into the 1 second space left of clip 2. (In previous 2.xx versions you could divide the transition unequally between clips but not now...the transition is divided equally between the clips.)

 

Borate's observation is correct so check your default values.

 

(Note: You should be able to use a transition of up to 6 seconds duration between two 3 second clips. (totally filling the space of the clips...so not a third clip) and a maximum of 3 seconds duration between any number of 3 seconds clips.

 

It's unfortunate that the transition duration box doesn't appear before you apply the effect and what you add takes on the default value. Previously you could set the duration before adding, now you have to reset it afterwards.

 

Nat

Link to post
Share on other sites
  • 2 weeks later...

Thanks for all the suggestions. There are some very helpful people here, although the problem persists.

I have found a somewhat tedious work-around, though.

For a 1.5 second fade transition, I've created a .75 blank clip with a .75 fade and overlayed it on track two midway through the fade on track one. This makes the apparent fadeout of the previous picture less smooth, but the fade-in to the next looks OK. I then add pictures to track two until the problem pops up again (5 or 6 pictures). Then I switch to track one using the same procedure.

Clunky and imperfect, but better than nothing.

 

Disappointed but appeciative.

Link to post
Share on other sites

Hi Palazzo

 

I can't see why you need to do that. Version 3.81 works OK.

 

For your 1.5 seconds fade....

Put your 3 second clip on the time line (Track1) and follow it by clip 2 ...... (which must be more than 1.5 seconds long)

Click the transition square at the end of clip1 and select Fade.

Set the duration of the transition to 3 seconds.

 

(As I mentioned in my earlier post, you may have to re-click the square on clip 1 a second time once you have put in a fade in order to re-set the duration to 3 seconds if it's not the default value as the duration box doesn't appear the first time around :( )

 

When you now play the two clips in sequence you will have a fade-out to black from clip1 of 1.5 seconds, and a fade-in from black to clip 2 for 1.5 seconds.

 

Isn't this what you want?

 

Doesn't this happen???

 

Nat

Link to post
Share on other sites

Right you are, Nationalsolo.

 

You are correct -- assuming there are no infinitessimally small clips left over on the track from previous editing. They were hiding behind the clips on track one.

 

I discovered this after my last post. Removing these appears to have solved the problem.

 

To find these unwanted tiny clips move the clips which you do want (which will not respond to lengthening the transition) to track two. These tiny clips show up as a vertical line on track one. carefuly clicking on and deleting each line will allow you then to move your desired clips from track two back to track one and all your transitions will work properly.

 

Glad to have solved this.

 

Thanks to everyone for your suggestions.

 

I hope this helps someone else.

Link to post
Share on other sites

Hi Palazzo,

 

It seems you've created those tiny clips unintentionally.

 

I'm wondering what kind of editing steps you've gone through.

 

If we know how this happens we may be able to improve the work flow to avoid it.

 

Best regards.

Link to post
Share on other sites

Hi Palazzo

 

Glad you solved it. :) Obviously it was the tiny clip bits which caused your transitions to behave incorrectly. If it happens again you should simply switch into Storyboard mode when even the smallest of clips will show up as a "slide" with the duration printed beneath. Just click and delete them.

Oddly you can enter a VERY short duration manually e.g. 0.001 seconds in this mode and still see the clip on an very expanded zoomed in normal timeline, so you could still delete them there. However, you won't see them play but they will mess up a transition.

 

Nat

Link to post
Share on other sites

Hi Sam

 

Using 3.81 I have tried to create as short a clip as possible using normal videopad editing steps by placing two clips onto the time line and then zooming in fully to the join. Zooming in was done by using the mouse scroll wheel as it goes further than the zoom slider.

 

VP will step frame by frame in large leaps (0.04 secs) across the join at this zoom level but one can move the cursor bar by much smaller increments by dragging it. I tried splitting off small increments by moving the cursor bar left from the join into clip 1 by manually dragging left.

Two manual increments of dragging the cursor line to the left were needed before a split could be made. One increment did not allow a split. Switching into storyboard mode at this point showed that the segment was 0.002 seconds in duration as shown under the "frame" in that mode. The segment was also easily seen in timeline mode at the mouse wheel zoom level used.

 

I then set up a sequence of a 7 sec clip - a 0.002 second clip - a different 7 sec clip

The tiny segment was not noticed on playing the three clips.

 

At maximum mouse wheel zoom the small segment was easily visible in timeline mode and I am sure Palazzo whould have had no difficulty in selecting it and deleting it.

.

However,... zooming out from here using the - button on the zoom bar reduced the tiny clip to a thick blue bar BEFORE the zoom slider showed any movement from maximum. (Took about 6 clicks)

This means that Palazzo would not have been able to see the tiny clips using the zoom slider if he did not have a mouse button to increase the zoom past the slider limit. At maximum slider position they would not have been visible in timeline mode except as blue lines. However he would still have been able to find and delete the offending clips from the storyboard mode even when so short.

 

I don't think it's a problem myself but why he had such small clips left during editing I can't say. I hope he replies to your post.

 

Nat

Link to post
Share on other sites

Hi Nat,

 

Zooming in was done by using the mouse scroll wheel as it goes further than the zoom slider.

 

Do you mean the zoom slider on the left of the scroll bar? I can't get this to happen.

 

 

VP will step frame by frame in large leaps (0.04 sec) across the join at this zoom level but one can move the cursor bar by much smaller increments by dragging it.

 

VideoPad generates a frame for every 0.04 sec (25 fps) while editing. We allow the cursor be moved in between frames because conceptually the time line is continuous(each step is 0.001 sec). i.e. The frame position will change if the frame rate is changed(when export), but the operation(split, insert etc.) position on the timeline will not change.

 

 

Two manual increments of dragging the cursor line to the left were needed before a split could be made. One increment did not allow a split.

 

From my testing, I can split the clip again on right side by moving the cursor by one tick(0.001 sec). But I have to move the cursor to the left side by two ticks(0.002 sec) to split the clip again. In theory we should be able to split the clip on any tick. So this is a bug.

 

 

However,... zooming out from here using the - button on the zoom bar reduced the tiny clip to a thick blue bar BEFORE the zoom slider showed any movement from maximum. (Took about 6 clicks)

 

It really looks like your mouse wheel and the zoom slider are out of sync. Is it always like that?

 

 

Thanks a lot for the report.

Link to post
Share on other sites

Hi Sam

 

"Do you mean the zoom slider on the left of the scroll bar? I can't get this to happen."

 

Yes...I can zoom with the mouse wheel until the slider reaches the extreme RH end where it stops but I can continue to zoom in further with the wheel.

If I choose to click the + for move the slider then it will move to the right right in steps until it reaches the end where it stops but I can continue to zoom by clicking the + another 5-6 times. Seems the slider bar is too short. :)

How would I "resync" it...and, yes, it's always been like that.

 

(Note: I don't normally zoom in so much,Mainly just enough to reveal and isolate sound peaks when I need to match sound tracks. In this case it was Lou's post that intrigued me and I wanted to see what size his clip bits were and why he couldn't find them on the timeline. As I discovered, at maximum slider position, obtained by using the slider; no use of the mouse or + button clicks, they only appeared as a blue line)

 

"VideoPad generates a frame for every 0.04 sec (25 fps) while editing. We allow the cursor be moved in between frames because conceptually the time line is continuous(each step is 0.001 sec). i.e. The frame position will change if the frame rate is changed(when export), but the operation (split, insert etc.) position on the timeline will not change. "

 

Having used VP a great deal I was already aware of the 25fps the program uses during editing as I sometimes shoot at 60fps and wondered where the extra frames went to. and although I mentioned in my post that I could shorten a clip to 0.001 sec duration by entering the value when in storyboard mode, the shortest I could get in my test above by splitting was 0.002 sec.

But, as you point out though, this was to the left of the join. Following your post I can confirm that to the right of the join it will split at 0.001 seconds. It's all academic anyway I think and if it's a bug I don't think it's a very important one. :)

I'm more interested to find out how Lou generated them during normal editing.

 

Nat

Link to post
Share on other sites

Hi Nat,

 

I'm more interested to find out how Lou generated them during normal editing.

 

Totally agree.

 

I have no idea about the mouse wheel issue at the moment. Lets keep an eye on it and please let me know if you find anything suspicious.

 

Best regards.

Link to post
Share on other sites

These tiny clips were created by placing the curser between clips (in the timeline view), then choosing the "Place on sequence at cursor" option.

 

Since my placement wasn't 100% accurate, a tiny slice was shaved off the existing clip.

 

I've since changed the way I add clips in the middle of a sequence. Now I move the subsequent clip to another track and insert the new clip, then reposition the subsequent clip.

 

I'm learning a lot just be reading your posts!

Link to post
Share on other sites

Thanks for the reply.

 

I can see the problem here is that there is no way to move the time line cursor to the join exactly.

 

We are developing some new features may help to solve this problem:

  1. A way to navigate the cursor between boundary(start/end) of the clips.
  2. Cursor snapping to clip boundary, which can be toggled on/off.

Best regards.

Link to post
Share on other sites

Hi

 

"A way to navigate the cursor between boundary(start/end) of the clips."

 

Select the clip in question on the time line and hover the mouse over it....the Start and End timeline positions and other info for the clip will be visible in a small white box. Enter the required position into the "Current position" box under the sequence preview window and.. PING!.. the cursor line will go there.

 

(Note: You will need to remember the value for a second or two as the reference box disappears when you select the "Current position" box)

 

In storyboard mode the values appear on the timebar above the frames and can be entered in the same way but without losing sight of them..

 

Nat

Link to post
Share on other sites

Hi Nat,

 

I'm thinking like this: Similar to the fast forward/backward button makes the cursor stopping at the end/start of the sequence. We add another pair of buttons that make the cursor stopping at the next/previous boundary.

 

Best regards.

 

Sam

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...