Jump to content

Text overlay not using my fonts


Recommended Posts

Using VideoPad Professional v 3.14 (Windows).


I'm having a little trouble getting VideoPad to recognize the font I want to use for text overlays. This worked in v2.x but all I'm getting now is plain old Arial TTF instead of Whitney Book (an OTF font).


Is there a trick to installing fonts so that VideoPad will recognize them?

Link to comment
Share on other sites



In version 3.12 not all the fonts seem to be recognised although the drop down list shows all the fonts listed that are held in the Windows fonts folder.

In the cases where the listed font doesn't seem to come up in VP, an Arial type font is used instead.

To check that this IS the case with your version of VP, add some text then click the text "Image" in the media list followed by the "T".

Open your Windows font folder and check that the list of fonts you have installed matches the drop down VP list .

The default font is Arial.

If you now select another font from the VP list the preview should change to that font...

I say "should" as some don't. If you think that nothing has changed, open the font from the windows folder and check it from the demo window.


e.g. Academy engraved is not recognised Accord Heavy Bold ditto etc.... It may be the way the Windows font is actually contructed that prevents VP using it...hence the Arial default for some types.


If your Windows font file doesn't have Whitney Book font then VP won't show in the list you simply need to download it into your Windows font folder and try again.(You may have to register to the site to do this)

The nearest font that you probably will have (it does load in VP as well) is Copperplate Gothic Light. It's fairly similar with lower case capitals.


I think it's a case of try it and see.



Link to comment
Share on other sites

Many thanks. The font is installed in Windows and is available in other apps, and used to work in VideoPad v2.x. So, I tried changing the font to something else, saving, and changing it back. I got the first change to stick (Stencil, because why not?) but it went back to Arial instead of Whitney.


Possibly VideoPad isn't recognizing OTF fonts, only TrueType? Off to find a font converter tool (possibly the only thing NCH Software doens't make?)

Link to comment
Share on other sites

  • 4 months later...


Did anyone ever find a solution to this? I too have a problem with VP professional v3.29 defaulting to Arial for several of my installed TTFs. I particularly want to use the Sassoon Primary Infant TTF for the sake of consistency in presentations, and while Sassoon functions perfectly in all other applications, VP will not recognise it, even though it is selectable from the font list. There are workarounds involving imported images carrying the text, but this problem rather defeats the object of buying VideoPad.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...