Jump to content


Recommended Posts

When I am recording, the music sounds fine, but when I play it back, there a static crackling sound which parallels the volume of the music.  I find no way to reduce the recording level of SoundTap.  Any respectable sound recording program should have that feature.  Sometimes, I try lowering the volume of the source I am recording, but I just recorded from a source where I saw no way to reduce its volume.  I think I wasted my money registering this program when it hasn't the basic control of recording levels.

Link to post
Share on other sites
  • 1 year later...
  • Replies 61
  • Created
  • Last Reply

Top Posters In This Topic

Hi I'm having the same issues here. MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports) Mac OS Majave  10.14.3 16GB of ram


Has there been a fix that I don't know about?


I would like a refund if this issue has no been resolved as it used to work fine on my old Mac, and have recently purchased an upgrade to the latest software version to run on my new Mac.


Thankfully paid through PayPal!

Link to post
Share on other sites
  • 2 months later...

I'm having the same problem.  I’m currently running version 6.03 of SoundTap.

I carefully listen to the original source music while the recording is being made and there is no pop.  When I play back the file it's there.  SoundTap is set to save the audio file as a WAV file.

I tried re-recording the same music from the same source and the pop noise happens again, but at a different time within a song.

1. What were you recording at the time?
Music from Amazon Music.  I've tried other sources (Spotify) and got the same problem.

2. If you know the technical details that would be great. ie. bitrate, mp3/aac
Unknown.  The Amazon quality setting is set to HIGH.

3. Were you doing other work on your computer at the same time? It should be fine to do so, but it could help me track down the problem.
No.  No other work was being done.  Just listening to the music being recorded.  No system sounds either - all turned off.

4. What kind of soundcard are you using?
Onboard sound card.  HP Envy desktop Z9M79AV with Realtek High Definition Audio.  Driver version

5. Have you changed any settings on your soundcard. eg. Have you changed the default playback format in the Speakers/Headphones Properties dialog? If so, what are the settings?
Everything set to default settings.  Format 24-bit, 48000 Hz.  All enhancements turned off.  

6. Does this problem occur every time you record?

7. Does the problem exist after a reboot?

8. Can you save a small snippet of the recording you made so that I can analyze it and track down the issue? If so, I'll contact you via email.
Yes.  I opened a support ticket and attempted to upload a sample file via FTP.  I'm not sure the sample uploaded correctly.  I used a couple of different FTP applications and I received a server error - unable to display directory.

Link to post
Share on other sites

I kept working at it and I think I may have found the problem…

If you noticed in my previous post, the ‘Device Properties’ were set to 24-bit, 48,000 Hz.  SoundTap saves audio files at 16-bit 44,100 Hz.  In my case I saved them in WAV formart.  I changed by ‘Device Properties’ output to match the file settings of SoundTap.

  • For my Windows 10 computer the setting are under 'Manage Audio Devices' > select your playback device and click 'Properties' > click the tab 'Advanced'.  Now change the 'Default Format to 16 bit, 44100 Hz (CD Quality).

I’ve recorded over an hour of audio and the problem has not happened again.

I assume - I’m guessing here - when SoundTap saves the audio file, it has to down-convert my file to the lower bitrate.  That’s when the pop sound is created.

This is similar to shortening the length of an audio file (make a 70 second file 60 seconds).  The more you "crunch" the file, the better chances of getting pops just like what we were experiencing.

I hope this helps someone.

Link to post
Share on other sites
  • 2 months later...

Finally found the answer to this problem thanks to Joseph58

it took a while to find the location of the 'Manage Audio Devices' and even longer to realize how to change the setting but all excellent now.

I'm surprise that the NCH experts didn't suggest this much earlier.

Thanks again to Joseph



Link to post
Share on other sites
  • 4 weeks later...

Maybe you should change the format or adjust the sound quality by adjusting the bit rate, sampling rate, etc.

If that doesn't work, maybe swithcing to another audio capture called TunesKit Audio Capture? It is able to  record the audio in 6 different formats without quality degradation, so it might solve the problem. At least, I haven't heard strange noises in its recordings during my last 2 months usage.

Hope it helps.

Link to post
Share on other sites
  • 4 weeks later...

Hi All: I have also been experiencing this problem for some time. I just realized that there is a newer version of Soundtap, version 6.03, which appears to solve the problem. The application file is dated Mar. 01, 2019. I was using an older version from Apr. 12, 2018. I have used the 6.03 version for several hours straight and have not encountered the problem. In the past on my system the problem would have easily manifested itself in the first 5 or 10 minutes max. I am running the program on Windows 10. Try it and Good luck!

Link to post
Share on other sites
  • 1 month later...

Hi there, I have been getting the same problems on my play back as all the others., but still seems like we're all being fobbed off or asked to buy more back up products. I've recently bought the new version of Soundtap and believe me it's a lot worse. Why should we pay extra when NCH can't get it right in the first place.

Unhappy user.


Link to post
Share on other sites
  • 11 months later...

Message for Joseph58

Joseph you are my man. I have read several messages on this forum, some dating back more than 5 years and this is the first time I have heard of a solution. I'll try your thing immediately.
I do not understand the slowness of the company NCH in fixing the problem.

p.s. Let me tell you another problem about Soundtap; I bought an update for my SoundTap software today and am very disappointed. My old version (3.04) was better because when I recorded several songs in a row the software would stop at the end of the song and restart a new file automatically at the beginning of the next song but with my new version (6.15) the software stops at the end of the song but does not start again at the beginning of the next song.

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...