Jump to content

Aspect ratio changed, black bars added


Recommended Posts

Hi, I'm trying to make a 720x480 video using what should be 720x480 clips. However, when I imported the clips into VideoPad, the program changed the image and made it skinnier (I think to a 4:3 format) and also added black bars on the sides. I've tried seeing if the crop option would work to get rid of these bars, but the bars don't even show up under the crop effect. The zoom effect doesn't help either as using it would lose more of the video than I wish to. Adjusting the aspect ratio of the output file seems to have no effect on removing the bars either. Originally I was making a video with the same source on Windows Movie Maker (which did not have this issue) and I downloaded VideoPad after it kept freezing on me. I just want to be able to make my video in the format intended.

Link to post
Share on other sites

Hi

 

The aspect ratio of your raw clip is 1 : 1.5 (720/480) whilst VPs aspect ratio is 1 : 1.77 for the full screen. This is for normal digital camera output of 1920 x 1080 or 1280 x 720 etc i.e. 16:9

This means that in order to "fit" your 720 x 480 pixel images to the screen area AND keep the image ratio of 1:1.5 correct it has to leave black bars on each side once the height has been made to fit. (To have the aspect ratio to fit across the screen your images would have to be 852 pixels wide, which, of course is not the case)

 

The VP image you have when you add your 720 x 480 clips will always be 1 : 1.77 and have the difference filled in on each side.

Any manipulation you do like cropping will affect your raw image and not VP screen size, so the black bars will remain (cropping them in fact will just make them larger as all you are doing is narrowing your already narrow image.)

 

The only way around this for the whole of your film (but with a down side) is to ...

 

Go into storyboard mode Left click your first clip to select it.

Click the Effects button and select the crop option. Don't crop anything for the moment.

On the left you will see your frame (without the borders) click the 16:9 option.

Your image will be cropped to this ration (1 : 1.77)

Now, the downside, you will have lost some of your image either at the top or bottom, so grab the red frame and move it up or down to include as much of the clip as you feel is important.

The clip will now play in the complete VP window although you will have lost some of it at top or bottom or both. There will be no distortion to the remainder.

Treat the remainder of the clips in the same way.

 

If you want the WHOLE frame you will have to put up with the black bands on either side.

 

Nat

Link to post
Share on other sites
  • 6 months later...

In my case I am using 2.41 to edit a 800 x 600 that has the bars added. I use crop to remove them. VP's preview plays the video full screen, without the bars. However when I try save the movie, (to a new name, same .avi format) in the new file bars are either still there or have been put back. In either case it is very frustrating. HELP.

Link to post
Share on other sites

Interesting post. When I am using a 4:3 image, and want to end up with a 16:9 full screen from it, I just open up crop to the 16:9 setting and pull the image out so that the image fills the crop box on the sides. Yes, you will loose a portion of the top and bottom of the image, but when doing this to an originally 4:3 image, there is no way to avoid it and still get rid of the black bars in the export

 

You can use all of a still image (not video) in an image editor (stretch all of the 4:3 image to 16:9) but it distorts the image sometimes badly.

 

If you are forced to shoot with a 4:3 only camera that you want to stretch to 16:9 in editing, just frame the shot so that the important element in the shot will remain after cropping.

Link to post
Share on other sites

Hi BobbyA

 

Do as both Dougie and myself have suggested. With 2.41 its actually easier. Put you 800 x 600 video on the sequence line and select the crop effect.

Click the 16:9 aspect ratio button and then drag the red rectangle that appears in the Crop preview pane and place it where your image/video has the most important detail. Repeat for all your clips. Preview your video to check it is OK. There will be NO black bars.

 

Save your video using one of the 16:9 settings e.g HD720 or HD1080 or widescreen. (AR = 1:1.777)

There will be no black bars on the result which will play 16:9

 

If you are using version 3.041 open the CROP effect by either by clicking the yellow star on the clip in question and then clicking the little down arrow by the box top left of the "Video effects" window Now select Crop from the list and click the grey bar.labelled Crop. You will now be able to click the 16:9 "Force aspect ratio" option which will be present.

 

DON'T click the Effects down arrow tab on the toolbar and select "Crop" from the list as you won't get any size options. (Which I think is a bug)

 

Click 16:9 and size the rectangle with the orange squares on the rectagle. The AR remains 16:9 and you can position the rectangle where you want. Save as above.

 

Nat

Link to post
Share on other sites

Nat said, "DON'T click the Effects down arrow tab on the toolbar and select "Crop" from the list as you won't get any size options. (Which I think is a bug)"

 

I agree...some kind of a bug. You'd think that doing this would initiate the very same processes as choosing it from the effects box, but it seems to skip some part of the process...weird!

Link to post
Share on other sites

Thank you for the suggestions.

I have a halloween effect video clip that I bought instead of shot, so reshooting is not a good option.

The running speed of the clip was shortened in VP. But so far I have been unable to save without the bar, if the goofy program will play the cropped clip full screen in it's previews, without the widescreen bars effect, why won't it WSIWG for the saved copy ? The video clips intended use is to play on an older 4:3 LCD TV posing as a painting. I don't want to play it in 16:9 with or without bars. I can now even load the original unedited clip into VP and it will remember the crop and preveiw play without the bars. The only work around I have found so far is using ALC's video player, I can tell it to stretch the video aspect ratios and reduce the bars to about 1/2" inch on either edge of the 20" screen. VP is adding bars to the top and bottom of the saved video, it really doesn't seem to have cropped the saved copy. I am telling VP to save the file as 640 x 480 NTSC TV resolution. Should not be this difficult...

Link to post
Share on other sites

HI

 

I think that what is happening now is that you have saved the 800 x 600 video (which plays in its raw state in the 16:9 VP screen with black bars) as a cropped 16:9 version that has no bars but lost top and bottom i.e it is now a normal 16:9 video. This will play OK in VP and would play correctly on a modern widescreen TV but you are (it seems) playing it on an older 4:3 TV. This would normally fill the screen (top to bottom) but crop the sides when the height is made to fit, as it is now too wide for the old type screen. Your video player however should (may) have controls that will allow you to see the whole 16:9 frame on an older TV but only by having bars at the top and bottom now since the width is made to fit but the height is now insufficient. Some can even be set to stretch the image to fit in either direction.

 

As I understand it (and I may be wrong....probably am :mellow: ) the output AR from VP is 16:9 but the image AR can be set by the user. This image is always placed in a 16:9 frame. Any AR other than 16:9 will have bars...........still.........might be wrong :unsure:

 

Nat

Link to post
Share on other sites

That makes sense, thank you.

Too bad VP can't save to 4:3, seems a bit of a short coming considering the amount of hardware still out there, such as video projectors which are likely to be around longer than the TVs. Especially considering, and i don't think I'm going to far out on a limb here, no one likes the black bars. Thanks again for your helpful insights.

Link to post
Share on other sites
  • 1 month later...

Its not resolved in 3.12 but it works nice in 2.40 because i can use crop effect that tells me frame dimensions instead of percentage which is pointless in new version.When i use crop in 3.12 it just adds black bars on top and on sides which is very very bad !!! Old method should be bring back so we could see frame size in pixels.

Link to post
Share on other sites

Hi 2blackbar

 

As I mentioned earlier in this post, if you crop to a ratio that is NOT 16:9 (the VP screen format) then you will get the black bars when previewed and output.

 

If your image or footage is, for example 4:3 (e.g. 800 x 600) then you will have black bars to either side in your preview and output video.These are the areas that show as chequered grey and white in the thumbnails.

 

Cropping this image or footage to 16:9 makes the image fit the VP screen and there will be NO bars but you will lose the top and bottom of the image.

VP will NOT distort the image to fit 16:9.

 

You access the 16:9 crop option by selecting the clip to crop and then clicking the Effects tab on the toolbar.

 

Note: DON'T click the small down arrow as there is a bug going this way to the effects list where the aspect ratios options are missing..

 

In the Video Effects window click the Add Effect tab and then select Crop from the list.

Now you will have the option to select an aspect ratio.

If you want FULL FRAME with NO BLACK BORDERS select 16:9

You can then resize and move the orange rectangle to select the best part of your frame.

 

Note: The rectangle must be completely within the image and not include any chequered area or you will still have bars .

 

Perhaps this was where you were going wrong?

 

Nat

Link to post
Share on other sites

I think devs got it all wrong with aspect ratio and cropping, now you cant crop to anything else besides 16:9 or 4:3 but in videopad 2.40 you can do it.

If in videopad 3.12 you can make file with other aspect ratio than 16:9 or 4:3 then youre magician.

I want aspect of 2:35 or 2:20, or 2:40 not just 16:9 and 4:3 so i cant use videopad 3.12 at all, if i crop with videopad 2.40 then i can crop to desired frame size of 1920x864 cause i can see the numbers of frame size but in 3.12 i have no clue whats the size im just moving some rectangle randomly by eye , theres some scale numbers that mean 0 to me, id like to see frame size.I never use effect by clickin on top menu, i always use star on clip.

Version 3.12 is big failure, why do i need so many damn thumbnails?! everywhere thumbnails , even under video for no reason, i guess to slowdown cpu ?! wow. I dont need thumbnails anywhere besides timeline, please remove all thumbnails that eat memory and they do eat memory even if some stats show otherwise.

I dont know but it looks like they hired new dev and hes turning everything upside down which is very bad.

I know having keyframes during effects is very nice but not at that price, now crop is crap, it used to work really nice and i could see desired frame size then i took that frame size and typed it in rendering window and it was all fine but now, its some transparency area that gets turned into black borders when you crop... noooooo.

By the way when im using crop in 3.12 and i want to use keyframing to move frame up/ down a couple of times then i get dropped frames on every keyframe and its all ruined very jittery movement through entire crop effect, i think keyframing need tweaks so it would not produce double frames( the same frame displayed twice or more) and dropped frames.It is problem with native effects, there must be some bug somewhere that creates frame drops and duplicates because when i use virtualdub motion plugin to move my video up/down then framedropping and cloning doesnt happen at all.

 

I discovered that when i render in 29.97fps instead of real 23.976 fps of my clip then it drops less frames when using many keyframes during crop effect so maybe that will help devs fix this issue

Link to post
Share on other sites

I think devs got it all wrong with aspect ratio and cropping, now you cant crop to anything else besides 16:9 or 4:3 but in videopad 2.40 you can do it.

 

Doesn't seem that way here. There are three buttons in the effect|CROP window: NONE, 16X9, 4X3. With NONE selected the crop aspect ratio can be customized.

 

I know having keyframes during effects is very nice but not at that price, now crop is crap, it used to work really nice and i could see desired frame size then i took that frame size and typed it in rendering window and it was all fine but now, its some transparency area that gets turned into black borders when you crop... noooooo.

 

If you hover the pointer over an effect keyframe, such as CROP, precise coordinates will be displayed.

 

When im using crop in 3.12 and i want to use keyframing to move frame up/ down a couple of times then i get dropped frames on every keyframe and its all ruined very jittery movement through entire crop effect, i think keyframing need tweaks so it would not produce double frames( the same frame displayed twice or more) and dropped frames.

 

I used POSITION and CROP to change aspect ratio and reposition a clip repeatedly, then outputted it at 720 AVI. Preview was rough, but final output didn't exhibit jerking or double frames that I could spot.

Link to post
Share on other sites

I managed to render crpped file inv 3.12, theres setting in options / export to stretch video without black bars.

Im usiing crop to mve frame up/down by keyframes but there is no mention of frame size when i hover over keyframes(1920x1080 etc like in 2.40).

I noticed that export bug with dropped frames is random, yesterday i had it when creating multiple keyframes in crop effect but today it works fine on the same clip, also it happens only when rendering so there have to be some bug there cause it never happens in preview and everything is smooth, If i edit one clip then i can live with that but rendering 5 minute clip and realising that on some parts its dropping frames then i have to cut/paste with direct copy in virtualdub and replace bad parts with fixed rerendered ones also some clips dropped frames when rendered from time 4.02 but didnt dropped when rendered from 4.03 which is weird, im not sure whats causing it, i know it happens when you use fade from one clip to another, you can see dropped frame in the middle of fade, try it yourself and render because preview is always good.

Link to post
Share on other sites

Hi

2blackbar wrote.."If in videopad 3.12 you can make file with other aspect ratio than 16:9 or 4:3 then youre magician."

 

Select clip

Click Effects tab

Click Add Effect tab and select Crop

You will see that the "Force Aspect Ratio" default is set to "None"

 

You can now drag any corner or side of the orange rectangle to produce any aspect ratio.

 

You CAN calculate the X2 and Y2 values to give you any AR and enter them into the boxes but you will need to remember that 100% on each axis are for a 16 x 9 rectangle and not a square. That is 100% X = 19 and 100%Y = 9

 

If you want a square (e.g. 9 x 9 ) then Y = 100% and X = (100/19) x 9 = 47.3%

So, with the default AR at "None"

Set Y2 to 100% and X2 to 47.3%

The orange rectangle will now be a square.

Use only the CORNER handles to resize it.

It can be moved away from any chequerd area by grabbing the centre.

 

You should naw be able to calculate any aspect ratio..like 2:3.5 or 2:35 or 2:20

 

 

 

 

 

Nat

Link to post
Share on other sites

Yeah i managed to crop the files properly but im still using old version because 3.12 is just slower, builds preview much longer, both versions sometimes make the clips choppy and sometimes dont, it depends on what transitions and effects youre using, virtualdub ones dont make much problems, some of them dont work at all but some work fine, they just crash if you have 2 effects before them and hit preview button like RGBEqualizer.

I like the software but if i want to add effects then its very unpredictable, i can rerender bad parts again but id like not to do that because preview works fine without any problems, why rendering final file has to be so unprediuctable, there are some serious bugs and i think they should focus on them first instead of adding more stuff, proper frame by frame rendering without any droped frames is really basic most important thing in video editor, if im gonna be on my faster internet i will upload example files along with project which will render dropped frames so maybe devs will see what i mean, or just use transition and fade one clip into another, then check teh clip, it dropped one or 2 frames at the end of the transition, happens everytime.

Link to post
Share on other sites

In the Options window under the Export tab there's an option to change the behaviour.

 

"When output aspect ratio is not 16:9"

(a) Fill screen (crop)

(B) Fit to screen (letterbox / pillarbox)

 

If you import a weird aspect ratio clip and export at the same aspect ratio, with option (a) it should give you the correct results. Option (B) is useful for other cases.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...