Jump to content

change server port


Kris Verhanneman

Recommended Posts

Hello,

 

my ISP blockes port 86.

Does anybody know how you can change the port to another like 2086 or something?

 

Kind regards,

Kris

 

 

You will find that, while the BroadCam Video Streaming Server is (in my experience) the best combination of being the easiest, most painless, & generally good quality media server available for the Windows OS, the support from NCH Software is pretty much non-existent..., even if you pay for it..., so never expect any answers here from them.

 

That said, the answer to your question is: yes, it is quite easy to change the port.

Just click on "Options" & go to the first tab marked "Web Access". There you will see two buttons labeled "Configure" (one each for the "Private Network" & for the "Public Network").

Click on each of those & the resulting pop-up window will show and easily configurable "Port" setting where you can enter the port of your choice. Then click "OK" as many times as it takes until you have exited "Options" and are back at the BroadCam main interface window.

Don't forget to configure **both** the Private & Public Networks so that you don't get confused trying to access your media pages.

Important advice:

Do NOT use port 2086 because it may cause a conflict as it is already registered/pre-allocated by IANA for a different internet protocol/application. Whenever you configure a custom port for any internet application **always** check the current IANA List of Registered Ports which is available at:

 

http://www.iana.org/assignments/port-numbers

 

Personally, I always use TCP and/or UDP ports in the range of 34981-35353 since they are not registered/assigned to any other protocol/application and, as such, are never blocked by any ISP's.

Note: For Flash Media delivery you cannot change the port (port 1935), as that is the registered/assigned port for the Flash RTMP media delivery protocol and is hard coded as such into Flash Media Delivery applications.

As always, don't forget to open up the applicable ports (1935 & #####) in both any software **and** hardware (router) firewall(s) and, if you do, you can ignore the "Routing" warnings that show up in red on the "Web Access" tab in "Options".

 

Another tip based on my experience:

The "Web Server" that is bundled with BroadCam is NOT essential to the operation of the Media Server component (like Flash Media Server or Wowza) of the BroadCam Video Streaming Server. It is simply a generic web (www/html) server that is bundled with BroadCam for all the n00bs out there who don't know any better. The problem is, that it is really NOT a very good one at all, and it is kind of a resource hog due to being poorly written as well as being quite insecure.

If you are not using an account with a Web Hosting provider to host your web pages (there are plenty of free ones out there, too), and are serving up the web pages from your own local computer, I strongly recommend getting/installing a "real" web server such as XAMPP (Apache) or LightHttpD, both of which are free/open-source, highly supported standards based, and much more lightweight (not as taxing on your computer). LightHttpD is slightly more lightweight than XAMPP (hence the name) but either one is good. Just "Google" search terms "XAMPP Windows" and/or LightHttpD Windows". Each of these web servers has an editable text file named "httpd.conf" located in a directory/folder named "conf" where you can set the default server port (generally port "80") to any port number that works best for you.

The way to permanently turn-off/disable the web server that is bundled with BroadCam is to click on "Options", and under "Non Secure Web Access" click on the "Stop" button. Then click "OK" and are back at the BroadCam main interface window. Finally, exit BroadCam by clicking "File" - "Exit (Turn Off)" - "Stop", and then restart BroadCam.

The bundled web server component of BroadCam will no longer start-up with BroadCam (unless you re-enable it in "Options"), however, the Media Server component of BroadCam still starts-up automatically.

When using a different web server with BroadCam, you need to open "C:\Documents and Settings\All Users|Application Data\NCH Software\BroadCam\Web" in Windows Explorer and copy/upload the "nchplayer.swf" file to the same directory/folder where your hosted web pages are located. The generic web page "embed" code for your videos now needs to look like these samples:

 

Live Stream Sample--

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="640" height="480">

<param name="movie" value="nchplayer.swf?host=Your_IP_Or_Hostname(FQDN):1935&scope=BroadCam&streamName=live&bandwidth=1&src=1&autostart=true">

<param name="allowfullscreen" value="true">

<param name="quality" value="high">

 

<embed src="nchplayer.swf?host=Your_IP_Or_Hostname(FQDN):1935&scope=BroadCam&streamName=live&bandwidth=1&src=1&autostart=true" width="640" height="480" allowfullscreen="true" quality="high" type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer"/>

</object>

 

Recorded Video On Demand Sample--

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="640" height="480">

<param name="movie" value="nchplayer.swf?host=Your_IP_Or_Hostname(FQDN):1935&scope=BroadCam&streamName=vod&bandwidth=1&src=myvideo&autostart=true">

<param name="allowfullscreen" value="true">

<param name="quality" value="high">

 

<embed src="nchplayer.swf?host=Your_IP_Or_Hostname(FQDN):1935&scope=BroadCam&streamName=vod&bandwidth=1&src=myvideo&autostart=true" width="640" height="480" allowfullscreen="true" quality="high" type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer"/>

</object>

 

Notes as to the FlashVars (variables) in the code:

a.) For both Live and On Demand Video streams the "bandwidth=#" variable will always be "1" for your "Broadband"/higher-bitrate (in "Options") streams, and will be "0" for you "Dialup"/lower-bitrate streams.

b.) For Live Video streams the "src=#" variable will always be "1" for the first (or only, if applicable) stream that appears in the "Live Video Streams" window of the main BroadCam interface. Additional Live Streams will be numbered as "src=2", "src=3", etc. in the order that they appear in the same main window.

c.) For On Demand (recorded) Video Streams the "src=______" variable will always the file name of your pre-recorded/encoded video, ***minus*** the file extension ("myvideo" when the actual video is named "myvideo.flv"). In case you don't already know, BroadCam places your pre-recorded/encoded videos in to the following folders:

"C:\Documents and Settings\All Users|Application Data\NCH Software\BroadCam\High" for your "Broadband"/higher-bitrate videos,

and,

"C:\Documents and Settings\All Users|Application Data\NCH Software\BroadCam\Low" for your "Dialup"/lower-bitrate videos.

 

One last note on BroadCam web page video embed code:

The embed code samples given here are given in the format that BroadCam generates in its sample pages/helpfile for n00bs. This format of embed code is klunky, ugly, cumbersome to deal with, and has been abandoned as outdated by the Flash standard & Adobe for quite a long time. Immediately following my (admittedly lengthy) reply to you I will be posting a new thread entitled:

"Serving-Up Your BroadCam Content More Effectively--Tutorial"

which will include a much cleaner, more current, and fully tested method of embedding your BroadCam video content in web pages. You might want to give it a quick read.

 

Good Luck & Happy Streaming,

 

DeDLykMe

"When the going gets weird, the weird turn pro."

-- Hunter S. Thompson

Link to post
Share on other sites

 

The way to permanently turn-off/disable the web server that is bundled with BroadCam is to click on "Options", and under "Non Secure Web Access" click on the "Stop" button. Then click "OK" and are back at the BroadCam main interface window. Finally, exit BroadCam by clicking "File" - "Exit (Turn Off)" - "Stop", and then restart BroadCam.

The bundled web server component of BroadCam will no longer start-up with BroadCam (unless you re-enable it in "Options"), however, the Media Server component of BroadCam still starts-up automatically.

 

-- Hunter S. Thompson

I have some troubles with this part.

I don't see a stop button (okay the solution will be something easy and I will feel like an idiot).

Can you explain this a little more?

 

Thanks.

Kris

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...