Jump to content

[BUG] Axon Ignores Public Static IP


Recommended Posts

I have Axon installed on a server that has multiple public IP's assigned to it. I've configured Axon to use one of them (not the first IP on the NIC), and Axon ignores this and takes the first two IP's on the NIC as Private and Public, respectively. Oddly, to connect to Axon from my HT503, it works for the IP that Axon has picked for its Private IP, not the Public one. Neither of these IP's are what I set in Static IP. UPNP and STUN are both turned off.

 

Additionally, I have Axon's Internal Voicemail enabled, and it registers extensions 500 and 501 at 127.0.0.1 instead of using any public IP. When I call another extension from my HT503 and it tries to go to voicemail, the call disconnects in 2 seconds and nothing is recorded.

 

Static IP I set was 65.111.244.13 which is the 6th or 7th IP on the NIC

IP 65.111.244.8 is the first IP on the NIC

IP 65.111.244.6 is the second IP on the NIC

 

=========================================================

 

06:31:11 Restart telephony engine

06:31:11 SIP Private IP is: 65.111.244.8:5060

06:31:11 SIP Public IP is: 65.111.244.6:5060

06:31:11 Attempting to register sip:500@127.0.0.1

06:31:11 Attempting to register sip:501@127.0.0.1

06:31:11 Registered as: sip:500@127.0.0.1

06:31:11 Registered as: sip:501@127.0.0.1

 

06:36:28 Call 101 -> sip:102@65.111.244.8

06:36:34 Incoming SIP call

06:36:34 Answering call...

06:36:34 Call 101 -> sip:102@65.111.244.8 answered

06:36:41 Recording File: C:\WINDOWS\TEMP\tmpFE.tmp

06:36:43 Call has disconnected

06:36:43 Recording file dropped because it was not long enough.

... during this interval I was speaking to what should have become a voicemail message ...

06:36:50 Call 101 -> sip:102@65.111.244.8 disconnected

Link to post
Share on other sites
  • 1 month later...

I have Axon installed on a server that has multiple public IP's assigned to it. I've configured Axon to use one of them (not the first IP on the NIC), and Axon ignores this and takes the first two IP's on the NIC as Private and Public, respectively. Oddly, to connect to Axon from my HT503, it works for the IP that Axon has picked for its Private IP, not the Public one. Neither of these IP's are what I set in Static IP. UPNP and STUN are both turned off.

 

Additionally, I have Axon's Internal Voicemail enabled, and it registers extensions 500 and 501 at 127.0.0.1 instead of using any public IP. When I call another extension from my HT503 and it tries to go to voicemail, the call disconnects in 2 seconds and nothing is recorded.

 

Static IP I set was 65.111.244.13 which is the 6th or 7th IP on the NIC

IP 65.111.244.8 is the first IP on the NIC

IP 65.111.244.6 is the second IP on the NIC

 

=========================================================

 

06:31:11 Restart telephony engine

06:31:11 SIP Private IP is: 65.111.244.8:5060

06:31:11 SIP Public IP is: 65.111.244.6:5060

06:31:11 Attempting to register sip:500@127.0.0.1

06:31:11 Attempting to register sip:501@127.0.0.1

06:31:11 Registered as: sip:500@127.0.0.1

06:31:11 Registered as: sip:501@127.0.0.1

 

06:36:28 Call 101 -> sip:102@65.111.244.8

06:36:34 Incoming SIP call

06:36:34 Answering call...

06:36:34 Call 101 -> sip:102@65.111.244.8 answered

06:36:41 Recording File: C:\WINDOWS\TEMP\tmpFE.tmp

06:36:43 Call has disconnected

06:36:43 Recording file dropped because it was not long enough.

... during this interval I was speaking to what should have become a voicemail message ...

06:36:50 Call 101 -> sip:102@65.111.244.8 disconnected

Somebody fix that problem? It look like I have the same issue

Link to post
Share on other sites
  • 1 year later...

Nope...as of 2.18 this bug still exists.

 

There should be the ability to set exactly the IP's to use for all the products, including Axon, IVM, and Express Talk, and if Axon needs two IP's we should be able to set them both, and as long as the IP's are on the NIC they should adhere strictly to those. Failover to the first IP on the NIC is fine if the specified IP's aren't valid.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...