Jump to content

not getting external dial - while dialplan is set correctly


Recommended Posts

Hi Guys,

 

Hope you can help, have read all topics and manual, but getting nowhere (outside my network ;-D, that is).

 

Config:

- Axon on Windows Server 2003

- Express talk on same Windows Server 2003 (for testing purposes)

 

Tested and works:

Using same sip provider settings directly in express talk on server and network computers

Internal calls

 

PROBLEM:

While dialing an external number, with the starting numbers as defined in the Outbound Dialing Plan, it does not go to the outside sip provider.

 

Steps taken:

Outbound dial plan:

If number starts with Remove digits Prepend Dial on line

0031 4 0 12connect

 

 

Using an connected Express talk (line 106) on same computer Axon logs shows:

 

17:08:02 Call 106 -> sip:0031643757984@dcserver001.diningcity.local

17:08:03 Error returned: 404 Not Found

17:08:03 Call 106 -> sip:0031643757984@dcserver001.diningcity.local disconnected

 

I've tried several other settings, but ik keeps saying number@dcserver001.diningcity.local where dcserver001 is the server in the internal network diningcity.

 

Hope anybody has an answer, or at least an direction to point me in, because now I am at an dead end...

 

THANKS!

Link to post
Share on other sites

Your description is a bit conflicted. For Express Talk to dial out through Axon, it would have no information about your SIP provider...Axon has that. In your Lines tab of Express Talk Options, you should be putting in the IP address, extension number, and password to Axon. In Axon, make sure the extension you're using has the dial plan you want selected.

Link to post
Share on other sites

Your description is a bit conflicted. For Express Talk to dial out through Axon, it would have no information about your SIP provider...Axon has that. In your Lines tab of Express Talk Options, you should be putting in the IP address, extension number, and password to Axon. In Axon, make sure the extension you're using has the dial plan you want selected.

 

Hi gadget 1024, thanks for looking in to it.

 

Just to confirm the sip provider settings are correct, first I've tested these settings in Express Talk directly, after that i´ve put this connection settings in Axon, and connected the Express talk directly with axon (with the correct extension number, password etc.).

 

the SIP gateway is set in the dialplan, see above, even tested it by setting it as the 'Default Dial On Line'.

Link to post
Share on other sites

A "404 Not Found" SIP error is just like a webpage 404 error.

It means the number you are dialing is not found to be a valid/existing extension or is not a valid phone number.

 

The error is typically generated by the service provider, not the client...

 

However, if Axon is not set to use your outbound SIP service as the default dialing plan, you will find that Axon will actually route your calls internally. In this case, dialing an external number would produce a 404 error because Axon does not recognize the number in its internal database of extensions.

 

You need to make sure that you have selected the correct default dialing plan in Axon.

Link to post
Share on other sites

You're not the only two who have contacted me /posted about this problem, and all of the cases have appeared in a very recent timeframe. I'm willing to bet that something was changed in Axon recently which is causing this to happen (I'll have to put this down to a bug because as far as I can tell there is nothing wrong with your dialplan setups).

Link to post
Share on other sites
  • 2 weeks later...

You're not the only two who have contacted me /posted about this problem, and all of the cases have appeared in a very recent timeframe. I'm willing to bet that something was changed in Axon recently which is causing this to happen (I'll have to put this down to a bug because as far as I can tell there is nothing wrong with your dialplan setups).

 

reaction took some time, been away for holiday...

 

In one way, good to know that we're not the only ones, means I'm probably not that stupid :D.

 

In the other way, means there is probably no easy fix, I'm now going to search for a earlier version to download and install until there is an new version with the bugfix.

 

I was using 2.11.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...