Jump to content

Recommended Posts

Okay, so I found what I'm looking for. Free, easy to set up and use, live internet broadcast. Hurray..

or so I thought. This is very frustrating. The help file refers me to portforward.com...wtf? they don't even have a broadwave application page.. I need a simple, step by step guide to setting this thing up and have not found one that does the trick. a few questions.

 

Welcome and thank you for installing BroadWave.

 

Since this is your first time running the software please do the following:

 

1. Connect the audio you want to stream to the line input of your computer (assuming you want live streaming).

Click on one of the links below to test if it works. If it does not appear to work or is too soft or loud, open the Windows Record Mixer to adjust the volume.

2. Add any recordings using Settings -> Recordings if you want to stream fixed pre-recorded audio.

3. To make the connection available from the public internet use Settings -> General -> Connection.

Click on the "Help about routing" link if you don't know how to setup your router or firewall.

 

That is it! Your server should be up and running in just minutes. If you have any problems see the help manual and support (from the Help menu).

 

in minutes? nope. this thing pops up everytime i hit connect. It is not the first time running the software. But I try and try again to do as instructed, I connect my microphone. It works.

I click connections, and designate that I connect directly to the ineternet via a static ip. and voila. Now when i access it with in my own network it works, but I also get this message at the bottom of the same screen of the last quote (localhost:85)

Warning Because your computer is on a private network

you must setup your router and enter the known host details

for the links to work properly from a public IP.

 

now i've forwarded my port 88 with ip 192.168.1.101 just like everything says to do. It gives me links

This is just an information setup page for BroadWave to provide the links. Ask your website developer to include these links in your website.

 

Broadwave Live 1

Broadband Stream http://192.168.1.101:88/broadwave.asx?src=1&kbps=56

Dialup Stream http://192.168.1.101:88/broadwave.asx?src=1&kbps=24

but i'm confused, because i though 192.168.1.1xx were addresses on my own private network, not very useful to others online..

so i went to Ipaddy.com and got my public ip

tried that

no luck, no one on the internet seems to be able to connect.

 

Help me please before i lose faith in what seems to be perfectly good software.

Link to post
Share on other sites

Yes, this is perfectly good software!

 

The Connect button shows a web page of example urls, it lists the ip address of the broadwave pc on your local network.

 

You actually need to connect from a second pc on your local network (ideally) to verify that the port is open on your firewall on the broadwave PC.

 

Have a look at some of these posts.

 

http://nch.invisionzone.com/index.php?showtopic=12730

http://nch.invisionzone.com/index.php?showtopic=11701

http://nch.invisionzone.com/index.php?showtopic=10435

http://nch.invisionzone.com/index.php?showtopic=11068

Link to post
Share on other sites
Yes, this is perfectly good software!

 

The Connect button shows a web page of example urls, it lists the ip address of the broadwave pc on your local network.

 

You actually need to connect from a second pc on your local network (ideally) to verify that the port is open on your firewall on the broadwave PC.

 

Have a look at some of these posts.

 

http://nch.invisionzone.com/index.php?showtopic=12730

http://nch.invisionzone.com/index.php?showtopic=11701

http://nch.invisionzone.com/index.php?showtopic=10435

http://nch.invisionzone.com/index.php?showtopic=11068

 

I've gotten a connection locally from a different computer on my router. The problem is, when i send my link to freinds online they get page cannot be displayed or no connection errors.

 

when i forward my port to ip 192.168.1.103( which pfportcheck arbitrarily chooses and changes(when i installed it, and did it yesterday, it told me to forward to ip. .101, today, .103 what determines this, there is no option menu?

 

anyway, yesterday my ports were open and good, and today they are no good, wtf? how do i get this working with a lynksis wireless router? Port forward.com is useless...because i've done what it says to do for my router (dispite no bloody broadwave application guide) and i'm having no luck and getting very frustrated.

Link to post
Share on other sites
I've gotten a connection locally from a different computer on my router.

Great, your broadwave pc is going fine.

 

when i forward my port to ip 192.168.1.103( which pfportcheck arbitrarily chooses and changes(when i installed it, and did it yesterday, it told me to forward to ip. .101, today, .103 what determines this, there is no option menu?

 

When your PC connectes to the router, it will either ask the router for an IP address (if it's DHCP enabled) or use an address defined in the PC. You can see which by running the command "ipconfig /all".

 

If it's DHCP enabled, the router's DHCP server will tell the PC which IP address to use, e.g. 192.168.1.103 as in the example above.

If it's not DHCP enabled, then the address has been set in the TCP/IP properties for the specific connection.

 

In the case of DHCP, the router will, by default, assign the next free address, as is happening here.

 

But you can program the router to always give the same PC the same address. In some routers, the function is "static local IP", in others it's "Fixed IP". If you set the broadwave pc to always receive the same address, then that's great. Next, configure the router to port-forward incoming traffic on the broadwave port to that fixed IP address.

 

Note that if your PC has two connections, e.g. a ethernet wired port and a wireless connection, you will get different IP addresses for each, so you'll need to be sure to specify the right one.

 

OK, so once you've got the router forwarding the port to the correct fixed IP, your friends should be able to listen.

 

You need to tell your friends the full URL, using your Public IP address and the Public port number. If you don't know your public IP address, go to the website www.ipaddy.com and it will tell you. Beware that this might change if you power off/on your router, unless your ISP has assigned a your account a static IP address.

 

Two additional notes:

 

1. Not every audio client recognises the .ASX in the URL. In this case, just use .MP3 and Broadwave seems to work just the same.

 

2. You can use a different port number for external listeners: you need to tell your router to also do port translation - e.g. externally-received traffic on port 8001 can be routed to an internal location on port 88. This is a good way of routing two different sets of incoming connections to two different broadwave PCs.

 

Let us know how you get on.

Link to post
Share on other sites

does dhcp have to be enabled? and also how does integrating with dyndns.com and my linksys router change port forwarding and broadwave settings?

I'd like to utilize the free 'domain' (endofinternet.net ;))

 

I've forwarded my ports, sometimes port checker returns ports are open, sometimes not, I'm gratefull for your help plz bare with the newbie haha, i take it back, no open or connectable port...

i've forwarded port 88 to 192.168.1.103 with dhcp enabled as port checker suggests, and no go

i turn off dhcp and try it again w/ 103(pc suggestion) no lucdk

wtf?

why is port forwarding such a pain in the ass?

 

Great, your broadwave pc is going fine.

 

 

 

When your PC connectes to the router, it will either ask the router for an IP address (if it's DHCP enabled) or use an address defined in the PC. You can see which by running the command "ipconfig /all".

 

If it's DHCP enabled, the router's DHCP server will tell the PC which IP address to use, e.g. 192.168.1.103 as in the example above.

If it's not DHCP enabled, then the address has been set in the TCP/IP properties for the specific connection.

 

In the case of DHCP, the router will, by default, assign the next free address, as is happening here.

 

But you can program the router to always give the same PC the same address. In some routers, the function is "static local IP", in others it's "Fixed IP". If you set the broadwave pc to always receive the same address, then that's great. Next, configure the router to port-forward incoming traffic on the broadwave port to that fixed IP address.

 

Note that if your PC has two connections, e.g. a ethernet wired port and a wireless connection, you will get different IP addresses for each, so you'll need to be sure to specify the right one.

 

OK, so once you've got the router forwarding the port to the correct fixed IP, your friends should be able to listen.

 

You need to tell your friends the full URL, using your Public IP address and the Public port number. If you don't know your public IP address, go to the website www.ipaddy.com and it will tell you. Beware that this might change if you power off/on your router, unless your ISP has assigned a your account a static IP address.

 

Two additional notes:

 

1. Not every audio client recognises the .ASX in the URL. In this case, just use .MP3 and Broadwave seems to work just the same.

 

2. You can use a different port number for external listeners: you need to tell your router to also do port translation - e.g. externally-received traffic on port 8001 can be routed to an internal location on port 88. This is a good way of routing two different sets of incoming connections to two different broadwave PCs.

 

Let us know how you get on.

Link to post
Share on other sites

Hi, no problem, port forwarding can be difficult to get sorted.

 

If you disable DHCP on your router, then everything you connect to it (on your internal lan) willr equire to be configured with a static address manually, and that's a pain. Better to leave it on.

 

I have an old Linksys router, and I had a look at the menus, but I can't see how to set up fixed IPs.

 

I would suggest that you pick an addres outside the DHCP range and manually set the broadwave PC to that address. If your DHCP range is, for example, 192.168.1.100 to ...1.199, then choose ...1.200.

 

To set it on the PC, go to control panel / network connections, right-click the actual connection you are using, proably "Local Area Connection" and select Properties.

 

Now, select TCP/IP (or TCP/IPv4) and select Properties. On the General tab, select "use the following address" and use:

IP Address = the address you want to set, e.g. 192.168.1.200 or similar

Subnet mask 255.255.255.0

Gateway = the local IP of your router, e.g. 192.168.1.1

DNS = the local IP of your router, e.g. 192.168.1.1

Link to post
Share on other sites

Alright, I got port forwarding working to the point where i have set my static ip and still connect to the net(i was having trouble w/ the DNS i didn't know i was to use 192.168.1.1 but that works) but pfportchecker still says no go. It's routed to port 88, at ip 192.168.1.200 as i've set my static ip in network properties too. When i try to connect on my network (and at the endofinternet.net address) it says the site seems valid but a connection can not be made. I feel like headway is being made, thanks for the help, any more ideas?

Link to post
Share on other sites

Sounds like progress is being made!

 

So, if I understand your post, your Broadwave PC is set to static address 192.168.1.200 and Broadwave is listening on port 88.

 

That means internal clients can connect and hear you on http://192.168.1.200:88/broadwave.mp3. When I say client, I mean Winamp, or WMP, for example.

 

Let's assume for this test that your external IP address is 1.2.3.4. As I said before, you can check it at ipaddy.

 

You are saying that your router is set to route incoming traffic for port 88 to internal address 192.168.1.200. If that is working, then external clients should be able to connect with http://1.2.3.4:88/broadwave.mp3.

 

If this doesn't work, then it's something in the port forwarding or router firewall. It might also be that the external person has a firewall which is preventing him getting out on port 88 of course.

 

Only once you can connect successfully with 1.2.3.4 should you then replace that IP address with your network name, e.g. www.myname.com. If it works with the IP adress but not the name, then check that the name resolves correctly, using the command "nslookup www.myname.com"

Link to post
Share on other sites

even internally when i try 192.168.1.200:88/broadwave.mp3 it says a valid page exists but a connectoin can not be made. As far as externally i've never had any luck. I don't know how i got the internal to work the first time.. my router went crazy so i had to reset it, i was hoping it would make things work easier. Any ideas as far as router firewall settings? should i uncheck filter multi-cast?

Link to post
Share on other sites

Make sure your internal connection works, every time, before worrying about the extenal clients.

 

Check the IP address of the broadwave pc using "ipconfig /all", to make sure you have the right address.

 

Sorry, I don't know what multi-cast is, my router doesn't have that.

 

If you can get internal clients working ok, try having a look at a Linksys forum to see if anyone has found any "gotchas" re port forwarding, as I don't have a Linksys.

Link to post
Share on other sites

okay, so the problem was in my network connections -> properties -> Sharing => settings -services -> web server (http) needs to be checked.. for some reason it won't let me edit the port to use for the server, but i just set broadwave and my port forwarding to the default port designated by windows and it works :D i'm gonna write up a step by step for the linksys wireless router.look for that in a few hours.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...