Jump to content

Echo cancellation not working


Greg Sullivan
 Share

Recommended Posts

I'm finding that echo cancellation is not working very well at all. I am using a Compaq/HP nw8000 laptop, with it's inbuilt microphone and speakers. Some other softphones don't work well either, however, some do work well. The ones that I have found that do work well so far are: SJ Phone, AdoreSoftphone, and Skype.

 

Are there any tweaks which might improve things?

 

Greg.

Link to comment
Share on other sites

  • 3 weeks later...

Regardless of what softphone you are using, things will always work a lot better if you use a headset so that the audio cannot feed back into the mic.

Skype has invested million(s) in developing its own proprietary platform including one of the best echo cancellation mechanisms, but it comes with a price too, being locked to their service.

 

Since the Express Talk algorithm is probably not as sophisticated, the best I can do is suggest that either

A) You get a headset (best option)

B) You use headphones in combination with the built-in mic (a good alternative)

 

The echo problem is usually the result of the audio from external speakers being sent back through the mic creating a large feedback loop. Because of the natural latency/delay on VoIP this is perceived as a large echo as far as I understand it.

 

Learn more about causes of echo on VoIP here: http://www.voip-info.org/wiki/view/Causes+of+Echo

Link to comment
Share on other sites

  • 1 month later...
Guest N.C.H a.n
Regardless of what softphone you are using, things will always work a lot better if you use a headset so that the audio cannot feed back into the mic.

Skype has invested million(s) in developing its own proprietary platform including one of the best echo cancellation mechanisms, but it comes with a price too, being locked to their service.

 

Since the Express Talk algorithm is probably not as sophisticated, the best I can do is suggest that either

A) You get a headset (best option)

B) You use headphones in combination with the built-in mic (a good alternative)

 

The echo problem is usually the result of the audio from external speakers being sent back through the mic creating a large feedback loop. Because of the natural latency/delay on VoIP this is perceived as a large echo as far as I understand it.

 

Learn more about causes of echo on VoIP here: http://www.voip-info.org/wiki/view/Causes+of+Echo

Spot on.

 

Turn down the mic input volume and maybe even the mic boost in the windows settings, and turn the volume of the speakers down a little.

If you still get feedback coming through, you'll have to use some headphones or a headset.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...