Jump to content

Axon sends out incomplete TO: field value in INVITE message header


powdasnow
 Share

Recommended Posts

Hello,

 

We can receive inbound calls from the PSTN via our Patton 4112 gateway successfully (landline phone -> PSTN -> Patton 4112 VOIP gateway -> Axon -> Express Talk softphone). Our issue is an outbound one. When trying to call with the same registered Express Talk softphone to the PSTN via the Axon and Patton gateway, we receive a: 'Error returned: 400 BAD REQUEST' error in Axon.

Further analysis with the help of the support staff of the Patton gateway pin pointed this issue to an incomplete (thus invalid) value in the TO field of the INVITE message that the Axon sends to the Patton.

In the SIP trace of the Patton gateway down below you can see this incomplete value in the TO field (<sip:0206714540@>) that the Patton receives. The Patton then responds with a code 400 (Bad request) to Axon:

 

PATTON SIP TRACE:

________________________________________________________________________________

___________

172.19.3.3#debug context sip-gateway transport detail 518:26:17 SIP_TR> [sTACK]

< Stack: from 172.19.3.9

INVITE sip:0206714540@172.19.3.3:5060 SIP/2.0

Via: SIP/2.0/UDP 172.19.3.9:5060;rport;branch=z9hG4bK787796

To: <sip:0206714540@>

From: "Ouasima" <sip:10000@82.134.206.178:5060>;tag=3787

Call-ID: 1231707825-796-BRECKENRIDGE@82.134.206.178

CSeq: 626 INVITE

Max-Forwards: 19

User-Agent: NCH Software Axon Virtual PBX 2.01

Contact: <sip:10000@172.19.3.9:5060>

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, INFO, REFER, NOTIFY

Supported: replaces

Content-Type: application/sdp

Content-Length: 348

 

v=0

o=NCHSoftware-Talk 1232554813 1232554814 IN IP4 172.19.3.9

s=Express Talk Call

c=IN IP4 172.19.3.9

t=0 0

m=audio 8000 RTP/AVP 0 8 96 3 13 101

a=rtpmap:0 PCMU/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:96 G726-32/8000

a=rtpmap:3 GSM/8000

a=rtpmap:13 CN/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=sendrecv

a=direction:active

 

18:26:17 SIP_TR> [sTACK] > Stack: to 172.19.3.9

SIP/2.0 400 Bad Request

Via: SIP/2.0/UDP 172.19.3.9:5060;rport;branch=z9hG4bK787796

From: "Ouasima" <sip:10000@82.134.206.178:5060>;tag=3787

To: <sip:0206714540@>

Call-ID: 1231707825-796-BRECKENRIDGE@82.134.206.178

CSeq: 626 INVITE

Server: Patton SN4112 JO EUI 00A0BA03DCFC R5.T 2008-11-24 H323 SIP FXS FXO M5T S

IP Stack/4.0.26.26

Content-Type: text/plain

Content-Length: 21

 

Invalid header(s): To

18:26:17 SIP_TR> [sTACK] < Stack: from 172.19.3.9

ACK sip:0206714540@172.19.3.3:5060 SIP/2.0

Via: SIP/2.0/UDP 172.19.3.9:5060;rport;branch=z9hG4bK787796

To: <sip:0206714540@>

From: "Ouasima" <sip:10000@82.134.206.178:5060>;tag=3787

Call-ID: 1231707825-796-BRECKENRIDGE@82.134.206.178

CSeq: 626 ACK

Max-Forwards: 20

User-Agent: NCH Software Axon Virtual PBX 2.01

Content-Length: 0

________________________________________________________________________________

______________________

 

 

The dialing plan in use on the Axon is simple, any call to a number starting with a zero will be routed over line 10000 (the Patton gateway that is connected to the PSTN).

We don't have clue why Axon doesn't put anything after the @ sign when placing outbound calls (<sip:0206714504@>).

We also don't see an option to manually put something static there in Axon's settings section and don't know what value should show up after the @ (ip?, name of server?, other????)

Axon is installed on a stand alone Windows XP Pro server that isn't part of a domain.

 

Any help would be welcome!

 

 

Carlos

Amsterdam, The Netherlands

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...