Jump to content

ExpressRip filename format fails to work

Recommended Posts



First, based upon someone else's recommendation, I purchased ExpressRip, version 1.55. This may have been a serious mistake because now I see that I have to pay $60 or so for support.


Anyway, it appears that custom file naming does not work under Options -> Filename Format for Extracted Files.




1. First, the documentation is incorrect. The help information says:


[%a %b %g]\{%n %t %y}

This will extract your audio CD tracks to a folder named "Artist - Album - Genre", with filenames structured as "Tracknumber. Trackname - Year".



So it says that the file names will be "Artist - Album - Genre\Tracknumber. Trackname - Year". This is inconsistent and undoubtedly incorrect for two reasons:

a. A " - " is inserted in place of a space in the format string.

b. Except after tracknumber, where a space is replaced with ". ".


What I would expect in this case would be "Artist Album Genre\Tracknumber Trackname Year". Does anyone have any correct documentation?




2. The example in the program rip settings is inconsistent with the documentation. In Options -> Filename Format for Extracted Files, the example is:

[%b]\\{%n %t} => Album\\Tracknumber Trackname.ext


a. In this case, a space in the template is translated to a space in the output file name, not " - " or ". ".

b. Also, it appears from interpolating both examples that a "\" is translated to null, but "\\" is translated to "\\". Thus, there appears to be no way to create a "\", as in a directory\filename delineator.




3. I want to name ripped tracks as follows:


"k:\Music\MusicLibrary\artist\album\(2 digit track number) (track name).flac"

Where parenthesis are only for clarity above. For example:

"k:\Music\MusicLibrary\Steve Kahn\Suitcase\01 Where's Mumphrey.flac"



I tried the following custom formats:


k:\[Music\MusicLibrary\%a\%b]\{%n2 %a - %t}

k:\\[Music\\MusicLibrary\\%a\\%b]\\{%n2 %a - %t}


In all of these cases I got the error message "Unable to create the folder name you have specified for your output file..." as soon as I started ripping.



Then I tried the format:


k:\\[Music]\\[MusicLibrary]\\[%a]\\[%b]\\{%n2 %a - %t}

This resulted in a track being saved as:

"k:\Music\MusicLibrary\01 Steve Khan, Anthony Jackson & Dennis Chambers - Where's Mumphrey.flac"


Which is clearly incorrect.


How to I specify a file name format to get the desired naming convention?


Where do I find correct documentation for this feature?





Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...