Jump to content

VOIP DTMF recognition-problem with PSTN gateway


Claudio

Recommended Posts

Hi ALL,

 

we have just implemented IVM on a server to receive VOIP-Calls, and it works fine, when it recieves direct SIP-calls(SIP-to-SIP). But when we call from a fieldline to get through the SIPGATE-PSTN-gateway (Fieldline-to-SIP) to our IVM-Server, the DTMFs is not beeing recognized at all. Googleing we found the information ,that perhaps the codecs of the gateway, used to compress audiodata might be filtering the signals.

 

any experiences or suggestions?

 

Thanks,

 

claudio

Link to post
Share on other sites
Guest guest
we have just implemented IVM on a server to receive VOIP-Calls, and it works fine, when it recieves direct SIP-calls(SIP-to-SIP). But when we call from a  fieldline to get through the SIPGATE-PSTN-gateway (Fieldline-to-SIP) to our IVM-Server, the DTMFs is not beeing recognized at all. Googleing we found the information ,that perhaps the codecs of the gateway, used to compress audiodata might be filtering the signals.

 

any experiences or suggestions?

 

got some troubles with PSTN gateway and DTMFs too, each digit being recognized a dozen of times, for ex. if caller presses 1 it turns to 1111111111111 and he accesses a matching mailbox.

 

guess there's something to do with VoIP DTMF timeouts...

Link to post
Share on other sites
got some troubles with PSTN gateway and DTMFs too, each digit being recognized a dozen of times, for ex. if caller presses 1 it turns to 1111111111111 and he accesses a matching mailbox.

 

guess there's something to do with VoIP DTMF timeouts...

 

We changed the PSTN-Gateway-Provider and now we are recieving the DTMF-Tones, but we are also experiencing the same problems with the many key-press recognition. But we found a workaround for that with the OGM-Algorythms: in the data-entry-ogm, when a tone is dialed we limited the variable to only get one digit. So it might recieve the same tone four or five times, but it only gets the first tone. To avoid that the following OGMs get the rest of the tones and puts it into following variables, we created a OGM that lets the IVM read the last entered digit, and with a "ignore respnose" in the menu of "key respnose" section it ignores all pressed keys. After that you can compose the variable again:

example:

OGM get digit1

OGM read digit1(to ignore doubled keypress recognition)

OGM get digit2

OGM read digit2(to ignore doubled keypress recognition)

OGM get digit3

OGM read digit3(to ignore doubled keypress recognition)

then you can compose all the variables: %digit1%%digit2%%digit3%

 

It seems to work.

 

Bye

Link to post
Share on other sites

<_< I'm guessing it has to do with the echoing the touch-tones from the broadband connection. I'm experiencing something like this with my Vonage phone service. But, it's usually only when there is alot of bandwidth being used at the tones the touch-tones are coming through. So, I guess the settings in the "General" section specifying the "Tone High Pass Filter" might need to be adjusted or it might even be under the "Devices - Advanced Line Settings - Line Settings - Call Detection Timing - DTMF Tone Delay Detect" might need to be adjusted. I think that might help or solve your problem. However, this has not been tested by myself with the VoIP features in the new IVM 3.01. I uninstalled it once it expired because, as a registered paid user/customer of 2.43 version, they still wanted you to purchase the software again. I have already purchased this software, so they wanted to give me a discount...well, the discount price is practically the same price I paid for the software the first time. So, it's a rip off and frankly, the new version really isn't something to brag about. Couldn't get a few things working the way I had wanted them and it even appeared that I wasn't being able to detect busy, answer, hang-up, etc... when the drivers for my CallURL card are the same, but somehow, the software itself was changing things as well.

 

So, I uninstalled.

:angry:

Markus

markus@comm-breakdown.com

Communications Breakdown

;):lol::D

Oh, and you are more than welcome to call my system and play around with it...try to trip up the system if you can. My company line is answered by IVM and will doesn't get answered by a live person. The number is (408) 850-0144.

:rolleyes:

Just FYI, the system is connected to Vonage phone service, with SBC being the main provider for the DSL and Vonage active on the DSL line. I have 5 lines thru Vonage with the SBC DSL Pro (up to 3.0 mbps, supposedly). You may also call the other incoming lines (which are also answered by IVM) that I have active for associates and outside field reps which use the system to make national phone calls, being this is free from the Vonage phone service. My field reps and associates are able to call into the system that I've created using IVM and IVM will transfer them to any number of their choice (because transferring calls is also part of the Vonage phone service).

B)

Link to post
Share on other sites
Guest Guest
So, I guess the settings in the "General" section specifying the "Tone High Pass Filter"  might need to be adjusted or it might even be under the "Devices - Advanced Line Settings - Line Settings - Call Detection Timing - DTMF Tone Delay Detect" might need to be adjusted. 

 

It seems that these settings are only good for POTS line, not VoIP.

High pass filter only affects outbound voice and not DTMF recognition.

 

Using BroadVoice, the very same multiple recognition problem.

Link to post
Share on other sites

Forget to include the other lines numbers for reviewing IVM and the way it asnwers and responds to calls.

Line 1: 408 625-7634

Line 2: 425 609-8162

 

<_<  I'm guessing it has to do with the echoing the touch-tones from the broadband connection.  I'm experiencing something like this with my Vonage phone service.  But, it's usually only when there is alot of bandwidth being used at the tones the touch-tones are coming through.  So, I guess the settings in the "General" section specifying the "Tone High Pass Filter"  might need to be adjusted or it might even be under the "Devices - Advanced Line Settings - Line Settings - Call Detection Timing - DTMF Tone Delay Detect" might need to be adjusted.  I think that might help or solve your problem.  However, this has not been tested by myself with the VoIP features in the new IVM 3.01.  I uninstalled it once it expired because, as a registered paid user/customer of 2.43 version, they still wanted you to purchase the software again.  I have already purchased this software, so they wanted to give me a discount...well, the discount price is practically the same price I paid for the software the first time.  So, it's a rip off and frankly, the new version really isn't something to brag about.  Couldn't get a few things working the way I had wanted them and it even appeared that I wasn't being able to detect busy, answer, hang-up, etc... when the drivers for my CallURL card are the same, but somehow, the software itself was changing things as well.

 

So, I uninstalled.

:angry:

Markus

markus@comm-breakdown.com

Communications Breakdown

;)  :lol:  :D

Oh, and you are more than welcome to call my system and play around with it...try to trip up the system if you can.  My company line is answered by IVM and will doesn't get answered by a live person.  The number is (408) 850-0144. 

:rolleyes:

Just FYI, the system is connected to Vonage phone service, with SBC being the main provider for the DSL and Vonage active on the DSL line. I have 5 lines thru Vonage with the SBC DSL Pro (up to 3.0 mbps, supposedly).  You may also call the other incoming lines (which are also answered by IVM) that I have active for associates and outside field reps which use the system to make national phone calls, being this is free from the Vonage phone service.  My field reps and associates are able to call into the system that I've created using IVM and IVM will transfer them to any number of their choice (because transferring calls is also part of the Vonage phone service).

B)

Link to post
Share on other sites

Hi,

We have 2 problems:

calling SIP to SIP the keypad enteries are not recognized

calling PTSN to SIP any number entered is entered infinite number of times.

Any suggestions?

 

 

Hi ALL,

 

we have just implemented IVM on a server to receive VOIP-Calls, and it works fine, when it recieves direct SIP-calls(SIP-to-SIP). But when we call from a  fieldline to get through the SIPGATE-PSTN-gateway (Fieldline-to-SIP) to our IVM-Server, the DTMFs is not beeing recognized at all. Googleing we found the information ,that perhaps the codecs of the gateway, used to compress audiodata might be filtering the signals.

 

any experiences or suggestions?

 

Thanks,

 

claudio

Link to post
Share on other sites
Guest Guest_Claudio_*

Hi,

 

SIP-to-SIP: Check if your Sip-Phone Soft- or Hardware has the DTMF-Signalising enabled. There are different types of sending DTMF:

- in-audio (may be filtered when using PSTN-gateways)

- via RTP (RFC2833) (I have no experience with that)

- via SIP INFO (works fine)

as far as I know X-Light have DTMF

turned off by default.

 

PSTN-to-SIP: I could not find out why it is happening, but we found a solution

with a workaround described in this post above...

 

Bye

 

Hi,

We have 2 problems:

calling SIP to SIP the keypad enteries are not recognized

calling PTSN to SIP any number entered is entered infinite number of times.

Any suggestions?

Link to post
Share on other sites
Guest Guest
We believe we have fixed the issue for the next release - it works on Vonage from PSTN to SIP, so it should work for other providers too. The next release is coming within the next couple of weeks or so.

 

The new release works ok with Vonage but still fails with BroadVoice (every digit is recognized 2 times)

 

Maybe you can give the ability to fine-tune the setting to the end user?

Just asking :)

Link to post
Share on other sites
  • 3 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...