Jump to content
Sign in to follow this  
Tallbloke

Silent Calls

Recommended Posts

Hi there,

 

I am trying to configure Axon with Express Talk.

 

I have Axon install on a computer behind a firewall with SIP 5060 and RTP forwarded to 8000. Axon connects to my SIP Gateway just fine.

 

I have express talk installed on the same machine and I have SIP 5061 and RTP 8002 forwarded in the network settings.

 

Express talk connects to Axon fine.

 

My Public IP is being picked up by Axon fine.

 

My problem is one way sound. However, this is ONLY ON OUTBOUND calls. People can hear me, but I can't hear them!

 

I have set up another extension on an XP machine. The same problem here as well, can dial out, the person can hear me but I can't hear them. BUT if someone phones in, it works fine.

 

Express talk status window shows the following :

 

SIP Private IP is 192.168.1.103:5601

SIP Public IP is 84.68.229.138:5601

SIP Number is 101@84.68.229.138:5601

 

I assume SIP and RTP are both UDP protocols?

 

Has anyone got some hard and fast info on port forwarding for this.

 

If it helps I'm behind a Linksys WAG160N

 

Thanks!

Share this post


Link to post
Share on other sites

My understanding is the SIP messages are transferred using the TCP protocol (because you want to make sure the message reaches the destination even if it takes a little longer) and the audio/RTP stuff uses the UDP protocol (like multiplayer games) so a lot of streaming data can be sent quickly and if some packets get lost, misplaced or out of order it's not the end of the world (i.e. it won't crash the phone system, it'll just cause a slight audio disruption such as a crackle or dropped word in speech, etc.)

 

Typically you want to use TCP port 5060 for Axon and have public TCP port 5060 forward to private TCP port 5060. The RTP ports (which range greatly depending on the device) usually start between UDP ports 8000 and 10000 and can use up to 10000 ports (e.g. 8000 to 18000) for transferring audio. With many other devices the range is 10000 to 20000, I do not know for certain what the default upper limit is for Axon.

 

You can also try putting your Axon computer on the DMZ (opens up all connections/firewall disabled for that PC) and if you still encounter problems, there may be another source to the problem (such as a software-based firewall on your computer).

Share this post


Link to post
Share on other sites

I tried changing SIP to TCP and AXON wouldn't register.

 

I've tried putting the Axon machine in the DMZ with no luck.

 

I managed to get it work once when I disable my software firewall (BitDefeder) but haven't had much joy repeating the success, in fact I just tried again after turning the whole suite off and still no luck.

 

This is also the case on the XP machine with windows firewall.

 

On my router I have a rule that point 5060 -> 5060 for SIP and this seems to work, everything registers as it should.

 

Like I say, when people phone me, it works.

 

It's just when I dial out, I can't hear anything.

 

Do I need to forward a RANGE of ports for UDP?

 

If I just use Express Talk and bypass Axon the same problem occurs.

Share this post


Link to post
Share on other sites

I forgot to mention the most important thing. Make sure you complete the 'Network Setup Wizard' in both Axon and Express Talk. This will usually solve audio and registration problems by finding the computer's public IP address, open network ports and various other information.

 

Also as I said in my previous post you should definitely have a range of UDP ports forwarded. Some VoIP devices require a range of almost 10,000 ports (e.g. 10000 to 20000). NCH software begins at 8000 by default, but I do not know the upper limit. For best results I would open 5-10 thousand ports in that range (>=8000).

Share this post


Link to post
Share on other sites

I have run the network setup wizard. Like I say my external IP is found just fine.

 

I have tried forwarding a range of ports or just single ports.

 

I know how to forward ports on my router as I have done it for plenty of other applications. The link you sent for Skype has the same port for both TCP and UDP incoming connections, but wth AXON we need to forward SIP and RTP. Are you saying that they need both forwarded with TCP and UDP so therefore 4 entries in the forwarding chart?

 

Just to re-iterate, when someone phones me everything works perfectly. It's just when I phone out, no one can hear me.

 

But thanks for your help thus far, I really want to get this working so that I can start looking at all the plugins!

Share this post


Link to post
Share on other sites
...when someone phones me everything works perfectly. It's just when I phone out, no one can hear me.

Like this, but when I phone is ok, when somebody phones from outside nobody can't hear and speak.

Yes, I forwarding SIP 5060-5070 and range of RTP 16000-2000 ports (the same ports configured in Axon PBX). Also I use STUN server.

By the way, if I use my Linksys PAP2T directly to my SIP provider (without Axon PBX) everything works perfectly! :(

Share this post


Link to post
Share on other sites
Like this, but when I phone is ok, when somebody phones from outside nobody can't hear and speak.

Yes, I forwarding SIP 5060-5070 and range of RTP 16000-2000 ports (the same ports configured in Axon PBX). Also I use STUN server.

By the way, if I use my Linksys PAP2T directly to my SIP provider (without Axon PBX) everything works perfectly! :(

 

Now all Ok!!!

Just forgot take on one of the options of Axon PBX.

Working with STUN. Router is not nessesary forwarded ports. :rolleyes:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...