Jump to content
pythonpoole

SPA3000 / SPA3102 GUIDE

SPA FXO CONFIGURATION GUIDE  

7 members have voted

  1. 1. Was this guide helpful?

    • Yes! It worked perfectly
      4
    • Yes it helped, but I had some difficulty along the way
      0
    • This helped a bit, but I still have problems with my SPA / Axon
      3
    • This didn't help at all
      0


Recommended Posts

Setup Guide for using your SPA3000 / SPA3102 FXO adapter with Axon

 

This quick-start guide will help you setup your new Linksys/Sipura FXO adapter you have purchased for your Axon PBX phone system. At the end of this guide you will be able to make calls to your PSTN (also known as POTS) line from a phone on your Axon PBX and also receive calls from your PSTN phone line through your PBX.

 

FIRST THINGS FIRST

 

Thre first step is to physically setup your FXO adapter.

Take a standard phone cable (RJ11) and connect it to the "Phone" port on the adapter

 

NOTE: DO NOT PLUG THE PHONE CABLE CONNECTED TO THE "Phone" PORT INTO A WALL PHONE JACK, YOU MAY DAMAGE YOUR EQUIPMENT, AND IT WONT RING THE OTHER PHONES ON THE LINE (WITHOUT REWIRING) IF THAT IS YOUR INTENTION. THE "Phone" PORT IS FOR PHONES ONLY.

 

Take the same RJ11 phone cable and connect the other end to any analogue / standard telephone.

Take a second RJ11 phone cable and connect it to your PSTN wall phone jack, or whatever phone jack you are trying to convert to a VoIP line.

Take the same RJ11 phone cable and connect the other end to the "Line" port on the FXO adapter.

 

Take the 5v Power adapter, connect it to the FXO adapter and plug it into an active power outlet.

The adapter should turn on and a green LED status light should indicate this.

 

ACCESSING FXO ADAPTER CONFIG PAGE

 

Next, it is time to start configuring your FXO adapter.

Pick up the phone connected to the "Phone" port on the adapter and dial * * * *

You will be transfered to an IVR menu. From this menu, you will need to dial 110#

Write down the IP address it gives you, you will need it later for further configuration.

 

Note: If you have changed any settings before reading this guide, it is best to reset the device to factory default settings to make sure all settings are correct. To do this, dial 73738# from the same IVR menu. Press 1 to confirm when prompted.

 

Now open any browser on the same network as the FXO adapter and go to:

http://[ADAPTER IP ADDRESS]/admin/advanced

where the IP address is replaced with the one you wrote down earlier, example:

http://192.168.1.30/admin/advanced

 

If you receive a user name/password prompt, you are in bad luck. Most likely the device has been locked to a certain Voip service and you won't be able to change the settings. Try contacting the people you bought it from and see if you can obtain an unlock user/pass to access the device.

 

Depending on the device you may either have 2 sets of tabs with the top one having "Router" and "Voice" tabs, or only 1 set of tabs that all the devices have (Info, system, SIP, ...). If you have the Router and Voice tabs, select Voice.

 

CONFIGURING THE ADAPTER FOR USE WITH AXON

 

1) Click on the "Line 1" tab

2) Make sure Line Enable is set to Yes

3) Under the SIP Settings header, change the SIP port to 5070 (Try 5070 first, and only if you cannot get this setup to work, then come back and try another port number)

4) Under the Proxy and Registration header, type in the IP address of the computer with Axon installed into the "Proxy:" text box

5) Make sure use outbound proxy is set to No

6) Under subscriber information set the display name to FXS1

7) Set the User ID and Password to FXS1 as well

8) (I think this step is optional), set the Dial Plan at the bottom to "(xx.)" with no quotes. If you leave the standard dialing plan you may encounter problems dialing certain numbers on the phone especially if you do not live in a country in the North American region. The (xx.) dial plan accepts pretty much any dialed phone numbers.

 

9) Click on the "PSTN Line" tab

10) Make sure Line Enable is set to Yes

11) Under the SIP Settings header, set the SIP port to 5060

12) Under the Proxy and Registration header, type in the IP address of the computer with Axon installed into the "Proxy:" textbox

13) Again, make sure use outbound proxy is set to No

14) Under Subscriber information set the display name to FXO1

15) set the User ID and Password to FXO1 as well

16) Under the Dial Plans header, type in "S0<:701>" (no quotes) into the Dial Plan 1: textbox. This is very important. You can change 701 to whatever extension or group you want to ring when a PSTN call is received in Axon. If you wanted to ring extension 101, you would type S0<:101> exactly.

 

17) Under the VoIP-To-PSTN Gateway Setup header, set VoIP-To-PSTN Gateway Enable to Yes

18) Set VoIP Caller Auth Method to None

19) Set VoIP Caller Default DP to 2 (This step is very important! If you leave it at 1, you won't be able to dial out, you will simply hear a "tone" when dialing and you will be disconnected. Also check to make sure that the Dial Plan 2 textbox (under the one modified in step 16) is set to (xx.)

20) Under the PSTN-To-VoIP Gateway Setup header, set PSTN-To-VoIP Gateway Enable to Yes

21) Set PSTN Caller Auth Method to None

22) Set PSTN CID For VoIP CID to No (You can try with Yes, but in some cases it may prevent Axon from answering your phone calls altogether).

23) Set PSTN Caller Default DP to 1 if it is not that already

24) Under the FXO Timer Values (sec), set PSTN Answer Delay to 3 or 4 (Either should be fine. This tells the FXO adapter how long to wait before routing the call to Axon. Usually, this should be 3-4 seconds to allow time for Caller ID information to be sent. It is important to change this step! If you leave it at 16, you will have to wait many many rings before axon receives the call)

 

25) If you live outside North America, you may need to configure additional Regional settings for your device (See Regional tabs). For example Caller ID information is transmitted differently in different regions of the world, so if you are having trouble receiving Caller ID, it is possible that is the problem.

 

AXON CONFIGURATION

 

You are now done with the FXO adapter configuration. You can press "Submit All Changes" now if you wish, although it may take a few minutes after you setup Axon before it "clicks" in and registers, so I prefer to keep the window open and set up axon first before submitting.

 

Open Axon's web configuration page. If you have created any external lines or extensions for the FXO adapter already, I suggest you delete them and just return to how your Axon was before the introduction of the adapter just because some settings you have made changes to may conflict with this setup and the guide might not indicate what those settings should be set back to.

 

26) Go to the Extensions tab in Axon and add a new extension with Extension ID (or User Name) FXO1

This is the extension that calls from the PSTN will come in on. When a call comes through on the PSTN line, the FXO adapter is kind of like a softphone with extension FXO1 and it will dial the Axon group/extension itself instead of acting like an "external line"

27) Set the Display Name and Password to FXO1 as well

28) Set the dialing plan to one you will use for the phones on the PBX system which you want to have access to the PSTN line

29) Save the changes, and create another extension with Extension ID (or User Name) FXS1

This extension is the extension of the phone connected to the FXO adapter, so when you call the FXS1 line the phone on the FXO adapter will ring.

30) Set the Display Name and Password to FXS1 as well

31) Save the changes, and then go to the External Line tab

32) Create a new External line for your FXO adapter like "FXO LINE"

33) Unlike the instructions from NCH, in the server address enter [iP ADDRESS OF FXO ADAPTER]:5061

For example 192.168.1.30:5061

34) For the username enter anything such as "user", it does not matter.

35) Leave the password field blank, or put any random text in it, it doesn't matter either.

36) Set the "Incoming Calls Ring On Extension or Group" to an extension of your choice. Note the extension you chose in the FXO adapter settings should override this setting, so if you are trying to figure out why the wrong phone extension rings, refer back to your SIPURA adapter settings (see step 16).

 

37) Optional: You can add FXS to the group (example 701) that configured the FXO adapter to ring when an incoming call comes in so that the phone connected to the FXO adapter will also ring. You can also make a seperate group like 702 with just the FXS extension in it so you can dial that phone internally from a phone which can only dial numbers and not letters.

38) If you haven't done so, now is a good time to click the "Submit all Changes" button in the Sipura SPA configuration window. Your FXO and Axon should now try and communicate with each other after this.

 

39) You are now DONE!!! You should now have a working PBX system where you can place calls out through any Axon connected phone through the PSTN lines and have any PSTN phone call come through your Axon SIP/VoIP system.

 

40) If you are seeing errors in the Axon Window / Logs, Do NOT Panic, everything is fine, trust me (see the end of this guide for more details).

Now is a good time to setup your dialing plans in Axon so for example if the dialed number starts with 0 make it use the PSTN line. After configuring your dial plan, test it out on a phone connected to the PBX or the FXO adapter. Assuming all works well, now test inbound dialing. Use a mobile (cell) phone and dial the PSTN phone number and allow for a few seconds for the FXO adapter to kick in and transfer the call to Axon.

 

You're Done!

 

Here is my actual complete configuration settings for the FXO adapter for your reference, ignore

some of the configuration I have changed in areas such as the System tab as this is not relevant.

 

http://scorptek.org/MISC/advanced.htm

 

Explanation to errors in the Axon window / log such as this one:

21:11:38 Register attempt for sip:user@192.168.1.30:5061 failed

21:11:38 501 Not Implemented

Although this error appears, your PBX system should work perfectly. All incoming calls should go through the PBX and ring the nominated extension/group and all outgoing calls on the "FXO LINE" should be able go through on the PSTN line as well. This is the only method currently that seems to work, the way NCH explains the configuration in their instructions does not seem to work correctly, and leaving the Server blank for the external line seems to do nothing at all. With this configuration Axon is trying to register the line with the username "User" and password "Password" but can't, thus the error; however everything is fine and the FXO adapter can still handle this configuration and calls made through this "Not Implemented Line." In other words, just ignore it.

 

Ok thats it folks, hope everything works out for you ok. It took me quite a while to figure this out and get it working and I just want to thank a couple of the users who I got help/information from: Francoz and Fredtheman

Share this post


Link to post
Share on other sites

I need help with configuring AXON & IVM & IMS. We are willing to pay for the services so that you may provide us with a solution that works. Please let me know if anyone is interested in taking up this project for us. Thanks

 

PS: We are using Linksys Router with 2 phone port & are upgrading to the polycom 501's.

 

Tushar

Share this post


Link to post
Share on other sites

I have configured two different SPA-3102 exactly as you show. Neither unit will allow me to call out to the PSTN line nor will Axon answer an incoming call from the PSTN through the FXO line. The FXS phone port works perfectly, and I can dial out through my VoIP account or receive calls at the configured extension. I even have a fax machine connected to one of the FXS ports, and it operates flawlessly over the VoIP line.

 

My problem is solely with configuring the FXO port to accept or make calls. Obviously, I have different usernames and passwords associated with each PSTN line setup.

 

I am using the newest version of Axon at 1.09.

 

Does anyone have any other detailed explanation how to configure the SPA-3102 to receive calls and send calls via the PSTN and FXO setup?

 

Screenshots would be most appreciated.

 

Thanks,

-Henry :blink:

Share this post


Link to post
Share on other sites

Is there any way you can post your SIPURA configuration settings? You can do this by going to your sipura page and going to File > Save as or Save page as...

 

Then simply upload it somewhere for us to see. If you can provide that I may be able to identify the problem.

Also if you can give a brief overview about what you have done with axon that would be great to. Also if possible, please note down what the Axon log says when 1) You attempt to make a call out through the adapter. 2) When there is an incoming phone call to the FXO adapter.

 

I should be able to get it working for you if you can provide some of these details. I realize the guide is long and its very easy to skip or misinterpret a step which could prevent the whole thing from working. About the username/passwords, just so long as these are exactly the same as the username and passwords you setup with the extensions, you shouldn't have a problem.

Share this post


Link to post
Share on other sites

Thank you for your help.

 

I have posted the Sipura 3102 settings at:

http://www.allnetbiz.com/sipura3102.htm

 

With the current configuration, the FXS operates flawlessly.

 

The FXO will answer the call and pass-on the call to extension 102 as desired in the dialing plan.

 

The issue is with the FXO when trying to dial out from a VoIP extension. I have setup the dialing plan to use the "FXO Line" when I press 8.

 

You may see the Axon setup of this external line at:

http://www.allnetbiz.com/axon_external_line_setup.htm

 

 

The log on the Axon when trying to dial out from extension 185 shows:

 

16:06:06 Call 185 -> sip:87032628@10.10.10.125

16:06:12 Call 185 -> sip:87032628@10.10.10.125 disconnected

16:06:16 Server 10.10.10.114:5061 did not respond to register (sip:user@10.10.10.114:5060)

16:06:16 Check server details for that line

16:10:25 Call 185 -> sip:87032628@10.10.10.125

16:10:31 Call 185 -> sip:87032628@10.10.10.125 disconnected

16:16:58 Server 10.10.10.114:5061 did not respond to register (sip:user@10.10.10.114:5060)

16:16:58 Check server details for that line

 

I hope the above information helps.

 

Thanks,

-Henry

Share this post


Link to post
Share on other sites

one undocumented issue of the spa3102 (that makes it different from the spa3000) is that the sip ports used for the FXO and FXS *MUST* be different or else your FXO port simply will not work. by default those sip ports in the configuration are at 5060 which, if left untouched, will leave your FXO in a 'not working' state. change one of the FXO/FXS ports to 5061 and that should do the trick.

 

on the spa3000 you can leave both those values at 5060 and it will work, the spa3102 will not let you get away with doing that.

 

 

i had the exact same issue as you and it took me forever to work this one out ........

Share this post


Link to post
Share on other sites

If you will notice on the stored Sipura setup at http://www.allnetbiz.com/sipura3102.htm , I already had the FXS port (Line 1) set to 5070. I had the FXO port (PSTN Line) set to 5060. In addition I had the external line (FXO Line) setup in Axon set to 10.10.10.114:5060 as shown in your tutorial.

 

I changed the external line in Axon for FXO Line (server = 10.10.10.114:5061). I want to dial out on the PSTN line. Therefore, I have setup the dialing plan with "8" as the identifier for dialing on the FXO Line (external Line in Axon). When I dial 8 plus the desired phone number, I receive error 503 within the Axon dialog box and error 480 on the Grandstream GXP2000 phone with a busy signal. Nothing rings. Thus, I changed the external line (FXO Line) back to 10.10.10.114:5060.

 

Next on the 3102, I changed the PSTN Line SIP port to 5061. I received the exact error messages as above.

 

Finally on the 3102 out of desperation, I changed both the PSTN Line SIP port to 5072 and the Line 1 port to 5065. According to the Axon dialog box, they registered correctly. Now, when I dial 8 with a desired phone number, I do not receive the error 503 message within the Axon dialog box. I do hear one ring before the error 480 is displayed and ringing stops with a busy signal.

 

I changed the external line in Axon for FXO Line (server = 10.10.10.114:5072) hoping to match the PSTN line SIP port above (5072). The identical error message with 1 ring and the then the 480 message with busy signal is the result. At least we have eliminated the error 503 message.

 

As your tutorial setup shows, the Axon External Line (FXO Line) is setup with the user ID as "user" and a blank password. As you noted I do continually receive error messages in the Axon dialog box, which shows the "user@10.10.10.114:5072 did not respond."

 

I apologize for being so troublesome, but I do not see where changing the SIP ports has resolved the issue. Can the issue now reside within the Axon settings for the external line?

 

Thanks,

-Henry ;)

Share this post


Link to post
Share on other sites

FINALLY, I have the Linksys 3102 working properly. It allows calls from the VoIP extensions within Axon by dialing out on the PSTN line as well as answering on the PSTN line. This provides a backup in case the VoIP external network is down.

 

I posted an updated configuration of my 3102 setup at:

http://www.allnetbiz.com/sipura3102.htm

You can also see screenshots of the Axon external line settings from links on the above webpage.

 

Here is what I discovered:

  • Yes, the SIP ports must have different numbers. Make certain you specify ports, which no other device is using.
    In the Axon setup use the same port number assigned to the FXO settings in the Sipura 3102. For example, the IP address in the Axon External Line "Server" name should be 192.168.1.124:5072 if the FXO (PSTN LINE) SIP port is set to 5072.

These few notes and additions to the setup shown in the original posting above should be the complete picture for allowing the Sipura 3102 to perform well.

 

Thanks,

Henry :rolleyes:

Share this post


Link to post
Share on other sites

good to hear its working better ! your 3102 guide is very nice too ! i do need to clarify/correct a couple of things though:

 

>> As your tutorial setup shows, the Axon External Line (FXO Line) is setup with the user ID as "user" and a blank password

 

the tutorial doesn't say to make the password blank, it says to make the *server* blank. Step 2 of the NCH guide clarifies this.

 

>> For example, the IP address in the Axon External Line "Server" name should be 192.168.1.124:5072 if the FXO (PSTN LINE) SIP port is set to 5072

 

if you keep the server blank in Axon you won't have to deal with this issue, let the FXO register with Axon and that way Axon keeps cached the location of the FXO at the time of registration. therefore it will always know where to send data to. this is exactly how i do it and home and it works quite nicely.

Share this post


Link to post
Share on other sites
Guest nchto
Too bad G.729 can't be used with Axon :(

Why not? Axon supports all registered SIP codecs. The only exception is when Axon is playing on-hold messages or recording calls. Then the calls are reinvited to u-law, a-law or GSM to be compatible with the on-hold format.

Share this post


Link to post
Share on other sites
FINALLY, I have the Linksys 3102 working properly. It allows calls from the VoIP extensions within Axon by dialing out on the PSTN line as well as answering on the PSTN line. This provides a backup in case the VoIP external network is down.

 

I posted an updated configuration of my 3102 setup at:

spam://www.allnetbiz.com/sipura3102.htm

You can also see screenshots of the Axon external line settings from links on the above webpage.

 

Here is what I discovered:

  • Yes, the SIP ports must have different numbers. Make certain you specify ports, which no other device is using.
    In the Axon setup use the same port number assigned to the FXO settings in the Sipura 3102. For example, the IP address in the Axon External Line "Server" name should be 192.168.1.124:5072 if the FXO (PSTN LINE) SIP port is set to 5072.

These few notes and additions to the setup shown in the original posting above should be the complete picture for allowing the Sipura 3102 to perform well.

 

Thanks,

Henry :rolleyes:

 

 

Thanks Henry!

 

I have got my 3102 working like this with axon through your instructions and alot of pulled hair!

 

I only have a slight niggle though, the FXS1 line rings once when a call comes in on my phone line then its diverted to my pbx like it should,

does any one have any ideas on how you can stop the FXS1 handset ringing initially when the call comes through?

 

Adam

Share this post


Link to post
Share on other sites

In the Sipura config page under Line 1 settings (in Admin > Advanced mode) set the 'PSTN Ring Thru Line 1:' option to No.

 

This will still allow calls from Axon to ring the phone connected to the FXS port, but when a PSTN call comes into the FXO port it is not directly routed to the phone connected to the FXS port.

Share this post


Link to post
Share on other sites

I'm still confused about the axon external line config. I am using axon 1.20 and the latest 3102 firmware 5.1.7 and still getting the failed to register errors in the axon log.

 

"Server 192.168.1.77:5061 did not respond to register (sip:799@192.168.1.77:5061)

Check server details for that line"

 

My setup is working fine but I would like to eliminate the errors if possible. The external line config screen is different in axon 1.20 and I have tried different settings but the axon docs are not clear on how the use the new options.

My current config can be viewed at:

http://www.tadlock.com/voip/cfg/LinksysSPA3102v517Cfg.htm

 

TIA!

Share this post


Link to post
Share on other sites

When using my method the error will continue to appear every once in a while. Using the 'official' method, you can avoid the error, but I have yet to be able to set mine up that way and have it work as intended. Currently my setup is working fine allowing me to call out and receive calls through the line connected to the Sipura adapter. I don't really mind the message and just leave it and it doesn't seem to have a problem.

Share this post


Link to post
Share on other sites

Hi guy's sort of another problem,

 

Call comes into gateway and is redirected to Axon, rings destination but then gets cut off after an x amount of rings, how can you get the call to goto the voicemail

on external calls coming into axon as internal voicemail works fine.

 

Adam

Share this post


Link to post
Share on other sites
Anybody? Please :rolleyes:

 

Hello Adam,

 

You can setup IVM to accept unanswered calls from Axon. For example: An Axon extension (by default) is configured to forward call to Voicemail (Ext: 199) after ringing for 14 seconds. You can use the default OGM for Voicemail in IVM or modify it as required.

 

Anuj

Share this post


Link to post
Share on other sites

Thanks Anuj

 

I'll have a play around with it this evening! I did have another problem but can't remember it anymore, so it couldnt have been that big an issue

 

Adam

Share this post


Link to post
Share on other sites
Thanks Anuj

 

I'll have a play around with it this evening! I did have another problem but can't remember it anymore, so it couldnt have been that big an issue

 

Adam

 

 

Sorry to be a pain again but could you provide me with some instructions on how to do this?

 

Thankyou

 

Adam

Share this post


Link to post
Share on other sites

I do not have the option "None" in the e "Incoming Calls Ring On Extension or Group"

 

According to the manual I need to Set the "Incoming Calls Ring On Extension or Group" to None

Share this post


Link to post
Share on other sites

I realize this is a very late reply, but I should still answer.

 

It shouldn't matter what extension you pick from the list, in the previous version you could select none, but I guess now you are forced to pick one. Regardless of what extension you choose, it should ring on the extension specified in the FXO adapter configuration.

Share this post


Link to post
Share on other sites

Just install SPA3102

 

All worked fine, except for Caller ID - I was just getting FXO1 as the caller ID

 

Tried to enable PSTN CID for VOIP (step 22) and was getting the error on Axon - cannot find line with ID '300' or extension with ID 'xxxxxxxx' -- 300 is my incoming group - xxxxxxx was the calling number

 

I solved it by adding another external line called 300, ringing on 300 - with username and password of 300 and "Other device will contact us (eg. FXO, UpLink, etc...)" selected

now I get full Caller ID - on talk express and Grandstream 2000 I get

 

FXO1

'calling number '

 

which is quite useful as it shows the call has come in on that line!

 

 

Thought this might be useful for any with problems on caller id!

 

My setup

 

1 FXO line

8 VOIP Lines

3 Grandstream 2000

7 Grandstream BT200 (3 in other countries)

6 Talk Express

IVM

Uplink to Skype

Share this post


Link to post
Share on other sites

Has anyone gotten the CID to work from the FXO?

 

all i get from the pstn is FXO1 call. if i login into the spa 3102 you can see the last caller info but it does not pass that info to axon that should pass that info the the ext dialed?

 

logs from axon and ivm only shows (call FXO1)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...