Jump to content

Recommended Posts

I am testing the software to see if it will suit my needs. So far I am mostly happy but I am not able to email any Invoices to customers from within the program. I am using Gmail as my email client and I get this error message.
"mail host server error(MAIL FROM not accepted). Please check your email settings. dbpspilot@gmail.com - (550 - )
I have tried various fixes from the forums but nothing seems to work.
My SMTP server is set as smtp.google.com and I have inserted my email address and password. Also ticked the SSL/TLS and send direct boxes. Any ideas would be appreciated.

I do use Authentication on my google account but I am not getting any messages regarding unauthorised account activity. I have also disabled the authentication so that teh account is open for third party software use but I still can't email Invoices nor do I get any notification of unauthorised account activity.

 

 

 

Share this post


Link to post
Share on other sites

Please make sure you follow these steps:

  1. Open your email settings in Express Accounts by clicking the Options button on the toolbar
  2. Select Other from the list on the left
  3. Click the Email Settings... button
  4. Select the radio button for Use SMTP to send email directly to the mail server
  5. Enter the server address in the SMTP mail host text box (this varies depending on your email client)
    • Gmail: smtp.gmail.com
    • Yahoo: smtp.mail.yahoo.com or smtp.mail.yahoo.co.uk (if email address ends in yahoo.co.uk)
    • Hotmail/MSN/Outlook.com: smtp.live.com
    • AOL: smtp.aol.com
    • Comcast: smtp.comcast.net
    • Other: Contact your mail provider for your SMTP server address
  6. Check the box labeled Server requires authentication
  7. Enter your User Name, (e.g., youraddress@gmail.com), and your Password in the appropriate text boxes
  8. Check the box labeled Use secure connection (SSL/TLS) if available
    Please note: Comcast users should skip this step
  9. Enter your email address into the Default reply email textbox
  10. Click OK to save your changes.

If you are using a Gmail account, you will need to do additional work:

  1. Log into your Gmail account, and go to this page.
  2. Make sure the option "Allow less secure apps" is set to ON.
  3. Confirm all settings within Express Invoice, and then test emailing an invoice.

Note that the SMTP for a Gmail account is smtp.gmail.com

Share this post


Link to post
Share on other sites

Hi Elk, 

I have done all those things as per your instructions and rechecked them multiple times but still can not get the program to email my Invoices.

Do you know of any other settings that I should be checking? or changing?

2 hours ago, elk said:

Please make sure you follow these steps:

  1. Open your email settings in Express Accounts by clicking the Options button on the toolbar
  2. Select Other from the list on the left
  3. Click the Email Settings... button
  4. Select the radio button for Use SMTP to send email directly to the mail server
  5. Enter the server address in the SMTP mail host text box (this varies depending on your email client)
    • Gmail: smtp.gmail.com
    • Yahoo: smtp.mail.yahoo.com or smtp.mail.yahoo.co.uk (if email address ends in yahoo.co.uk)
    • Hotmail/MSN/Outlook.com: smtp.live.com
    • AOL: smtp.aol.com
    • Comcast: smtp.comcast.net
    • Other: Contact your mail provider for your SMTP server address
  6. Check the box labeled Server requires authentication
  7. Enter your User Name, (e.g., youraddress@gmail.com), and your Password in the appropriate text boxes
  8. Check the box labeled Use secure connection (SSL/TLS) if available
    Please note: Comcast users should skip this step
  9. Enter your email address into the Default reply email textbox
  10. Click OK to save your changes.

If you are using a Gmail account, you will need to do additional work:

  1. Log into your Gmail account, and go to this page.
  2. Make sure the option "Allow less secure apps" is set to ON.
  3. Confirm all settings within Express Invoice, and then test emailing an invoice.

Note that the SMTP for a Gmail account is smtp.gmail.com

 

Share this post


Link to post
Share on other sites

yes, I have tried Gmail, my web site email server and msn email no one works I had this program on my last computer and it worked fine.  I tried it on my new desktop and laptop it doesn’t work so I stopped all firewalls and virus program still nothing I tried a different internet connection nothing.

I installed a smtp tool app and it work fine I installed another one and it work fine I tried one on line and it work fine

my setting is without real information is

smtp.live.com:587

myemail@msn.com

password

I set Use smtp to send email directly to the mail server and with SSL/TLS

For your FYI here are the tools I used

 Febooti Automation workshop

Smtp tester

And online       SMTP Test Tool

And here is a port tester      Simple Port Tester

 

if anyone has something to add please do so

Share this post


Link to post
Share on other sites

Had the same problem before. Can You try to add this line to registry:

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\NCH Software\ExpressAccounts\Email]
"SMTPAuthOn"="1"

This worked for me.

Thanks.

Share this post


Link to post
Share on other sites
On 7/10/2020 at 1:40 PM, jarekszegarek said:

Had the same problem before. Can You try to add this line to registry:

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\NCH Software\ExpressAccounts\Email]
"SMTPAuthOn"="1"

This worked for me.

Thanks.

That line was already there but with a value of "0" so I have changed that to "1" and setup the email settings again. Still does not work but I get a different error message now.

"EMAIL AUTHENTICATION USERNAME OR PASSWORD NOT ACCEPTED:

 

I have checked the password is correct and I am entering my username as "xxxxx@gmail.com"

Have tried ticking the extra options and un-ticking also but I did see that this could also be a problem with my gmail account as I have 2 factor verification turned on:  Any Idea what I can try next.. 

Have found that there is another item that must be fixed as well.

APP PASSWORDS: 

 

Sign in with App Passwords

Tip: App Passwords aren’t recommended and are unnecessary in most cases. To help keep your account secure, use "Sign in with Google" to connect apps to your Google Account. 

An App Password is a 16-digit passcode that gives a less secure app or device permission to access your Google Account. App Passwords can only be used with accounts that have 2-Step Verification turned on.

When to use App Passwords

Tip: iPhones and iPads with iOS 11 or up don’t require App Passwords. Instead use “Sign in with Google.”

If the app doesn’t offer “Sign in with Google,” you can either:

  • Use App Passwords
  • Switch to a more secure app or device

Create & use App Passwords

If you use 2-Step-Verification and get a "password incorrect" error when you sign in, you can try to use an App Password.

  1. Go to your Google Account.
  2. Select Security.
  3. Under "Signing in to Google," select App Passwords. You may need to sign in. If you don’t have this option, it might be because:
    1. 2-Step Verification is not set up for your account.
    2. 2-Step Verification is only set up for security keys.
    3. Your account is through work, school, or other organization.
    4. You turned on Advanced Protection.
  4. At the bottom, choose Select app and choose the app you using and then Select device and choose the device you’re using and then Generate.
  5. Follow the instructions to enter the App Password. The App Password is the 16-character code in the yellow bar on your device.
  6. Tap Done.

Tip: Most of the time, you’ll only have to enter an App Password once per app or device, so don’t worry about memorizing it.

 

Because of the 2 factor verification I needed to create a specific APP PASSWORD.

Once I created this password and finished the process I am now able to email 

 

HURRAY, FINALLY FIXED

THANK YOU SO MUCH FOR THE STARTING POINT.

 

 

 

Share this post


Link to post
Share on other sites
7 hours ago, dbpspilot@gmail.com said:

That line was already there but with a value of "0" so I have changed that to "1" and setup the email settings again. Still does not work but I get a different error message now.

"EMAIL AUTHENTICATION USERNAME OR PASSWORD NOT ACCEPTED:

 

I have checked the password is correct and I am entering my username as "xxxxx@gmail.com"

Have tried ticking the extra options and un-ticking also but I did see that this could also be a problem with my gmail account as I have 2 factor verification turned on:  Any Idea what I can try next.. 

Have found that there is another item that must be fixed as well.

 

I'm not using google mail as my bussiness email - thats why it is working without setting App Passwords. After updating Express Accounts "SMTPAuthOn"="1" registry line was missing. Tried everything but was unable to send invoices directly from software. Now it is working as it should (with "SMTPAuthOn"="1" line added). I'm using IONOS email account.

Share this post


Link to post
Share on other sites
12 hours ago, jarekszegarek said:

I'm not using google mail as my bussiness email - thats why it is working without setting App Passwords. After updating Express Accounts "SMTPAuthOn"="1" registry line was missing. Tried everything but was unable to send invoices directly from software. Now it is working as it should (with "SMTPAuthOn"="1" line added). I'm using IONOS email account.

Awesome jarekszegarek, Well your tip started the chain to help me find out why I couldn't get my email's to work.

I hadn't realized about the App Password setting because nothing came up to alert me. But once I changed that registry setting, the notice for App Passwords came into play. 

The rest is history.

I hope this will help other's who are and will have an issue with emailing from within the software.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...