Jump to content
dtfan

Beat Maker won't download drum samples

Recommended Posts

I have tried 3 different MixPad versions (up to 5.53 and a new version as a "trial version") and none of them can download the offered drum samples. I sent in a Tech question using the website but as usual, in my experience at least, no response since I submitted it 5 days ago. I have uninstalled it choosing to also delete the database. Nothing seems to help.

Any advice?

 

Share this post


Link to post
Share on other sites

I tested it using that version 5.53 (trial) and I was able to download it without problems. What occurs when you try to download it? Are you getting any error message? 

In attempt to fix this issue, please try the steps below:

Uninstall MixPad, then delete 3 folders named "MixPad" and 1 named "Components" from these locations:
**C:\Users\<username>\AppData\Roaming\NCH Software\MixPad\
**C:\Program Files (x86)\NCH Software\MixPad\
**C:\Program Files (x86)\NCH Software\Components
**C:\ProgramData\NCH Software\MixPad\
**If you can't find any of the folders, just continue. 

After that, restart your computer and reinstall the program using this link: http://www.oldversiondownload.com/oldversions/mixpad-5-53-2019-08-07.exe

Once done, restart your system one more time.

Share this post


Link to post
Share on other sites

Elk, I followed the steps you outlined. Thank you for taking the time to help me with this, unfortunately, it gave me the same results as I have been getting.

Here is the information you asked me about...and more.

The error message that comes up reads: "MixPad was unable to install the sample kit."  The title of the error message is: "Unable to download"

Just before this error message comes up, there is a message that says something to the effect that it is: "downloading the files" and there is a progress bar at the bottom of this message that seems to indicate that a download has started. However with a second or so it is covered up by that error message and everything stops.

I am running Windows 10 - 64 with the most current update and I have Chrome installed but I also tried to use Edge and the results were the same.

(I did attempt, with my WavePad program,  to "download from Sound Factory". The "Loading Sounds" message comes up reading: "Connecting to Server..." it is immediately obscured by the next message labeled: "Connection Failure", it says, "Could not connect to server. Please check your internet connection and try again.")

I have tried using the newest WavePad trial with the same results.  Thank you!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...