Jump to content
Sign in to follow this  
Amy Jamieson

Cannot download file from SwiftConverter

Recommended Posts

Help please... if you can.  I get the same error message when I am trying to convert DSS or DS2 files to mp3 : CANNOT DOWNLOAD FILE FROM SWIFT CONVERTER. 

It starts to convert just fine, but then it fails and gives me that error message.  I am MACOS.  I know DSS and DS2 are not compatible with MAC but the conversion from DS2 to mp3 worked fine on Monday before I paid for the software. 

When it failed I assumed I should pay for the software (I did) and it still fails to download.

Anyone have advice how to fix this?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...