Jump to content
martyson

Game sound not recording Debut missing a filter file

Recommended Posts

I upgraded my PC from WIN7-64 to WIN10-64

Debut v2.16

Soundblaster fx card

Soundblaster Fury headset and mic

All was ok in WIN7-64

Using WIN10 the game (P3Dv4 Flight simulator) the game and my mic sound is recorded ok but no game sound.

When setting up Output to use mic and speaker (mixer) I get a message window:

Windows cannot find

debutfilterinstaller64.exe

 

 

Share this post


Link to post
Share on other sites

In attempt to fix this issue, try the steps below:

Uninstall Debut, then delete 3 folders named "Debut" and 1 named "Components" from these locations:
**C:\Users\<username>\AppData\Roaming\NCH Software\Debut\
**C:\Program Files (x86)\NCH Software\Debut\
**C:\Program Files (x86)\NCH Software\Components
**C:\ProgramData\NCH Software\Debut\
**If you can't find any of the folders, just continue. 

After that, restart your computer and reinstall the program using this link: https://www.nchsoftware.com/capture/debutpsetup.exe

Once done, restart your system one more time and try again.

Share this post


Link to post
Share on other sites

Thank you for the reply,

 

That fixed the problem with new Debut version 5.52 in my WIN10 (update from WIN7).

 

When I upgraded to WIN10 it had removed my older versions of Debut,  Editpad and WavePad but I noticed the NCH folders were still there.

So I copied back my saved backup folders of Debut,  Editpad and WavePad (as I have done in the past after testing/trying a newer version of Debut but rolled back to previous version).

Your instructions included to Uninstall Debut .... and then I noticed Debut was not in my Windows Control Panel as an installed program.

Following your instructions corrected the missing Debut file and I got the sound recording via my headset mic and the games (PC) sound.

All good.

So the question is ... is my Debut v2.16 (and older versions of EditPad and WavePad) not compatible with Win10 ?

Do I have to now purchase updated versions of Debut,  Editpad and WavePad for WIN10?

 

Share this post


Link to post
Share on other sites

Update:

Today I submitted a e-mail to support for information.

When I ran new ver 5.52 again today I got a message Trial / Demo was over and I could not run or test Debut again.


So I uninstalled it.


After that I followed previous (thank you elk) instructions to clear out folders/data.

Then, instead of copying my backup Folder/files to (C:\Program Files (x86)\NCH Software), I ran the installer (setup.exe) for my old version of Debut.

I wanted to test Web Cam input for Mic and Sound from Speakers to see if that would work.

While setting up options and testing I got a message from Debut that I needed to restart the PC for changes to take effect for using the speakers.

After that I now get recorded audio from my Headset Mic and also from the Speakers (recording the video).

So, the problem was mine alone.

Debut is working just fine in WIN10.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...