Jump to content
TDDK

Crossfade of video does NOT adjust the audio

Recommended Posts

I am trying to crossfade several short video segments but the audio does not adjust and goes out of sync - any ideas?

And where is that setting that I know exists - because I accidentally stumbled across it months ago - searched everywhere.

And the manual pdf is bad too with NO order to the topics - NO search - you have to go thru each topic by topic to find anything.

Really ? ? ?

Share this post


Link to post
Share on other sites

With the PDF on screen in a browser press <ctrl-F>.  That will bring up a FIND search box.  Or download the file.  Your PDF reader should provide a search field.

If audio and video are linked, as with most clips, they should track.  They do here.

If A/V are not linked, use the FREEZE option for transitions.  Click OPTIONS|EDITING tab and set the Video Clip Transitioning field to either ASK or GENERATE FREEZE FRAMES.  If OVERLAP is used, sync problems may result.

Use the latest version of VP.  Keep in mind that, for licensed users, upgrades are free for up to six months.  After that, VP will continue to fully function but a fee will be required in order to register the newest.

Share this post


Link to post
Share on other sites

Hi

There is a way to re-position audio track if it is unlinked and you have used a crossfade with overlap on the video track....

  1. Click the X and add a cross-fade transition, selecting to overlap the clips. The audio track, being unlinked stays where it is and as a consequence is now out of synchronization. It needs to move left.
  2. Use the II< button to step the red cursor line back to the start of the blue transition marker (left end of the blue bar)
  3. Split the Audio track.
  4. Delete the section of the audio track you have split off.
  5. Close the gap in the audio track

The overlapping cross-fade will remain and the audio will now be in synchronization.

Nat

Share this post


Link to post
Share on other sites

Nice approach, Nat.  But you may have omitted one step...

3. Split the Audio track.

4.  Use the >|| button to step the red cursor line to the end of the blue transition marker (right end of the blue bar)

5.  Again split the Audio track.

6.  Delete the section of the audio track you have split off

7.  Right-click|CLOSE GAP

The result is that the audio track that corresponds to the position and length of the video transition marker is deleted.

VP_sync.jpg

Share this post


Link to post
Share on other sites

Hi Borate

Nope.....I don't think I missed a step... but it produces a similar end result I think....

Initial situation with Clip 1 and Clip 2 on the timeline. Clip 2 (the Clips are separate but identical clips except that Clip2 has a copy of the audio beneath it and consequently it's unlinked. This is apparently similar to TDDK's situation. (I used the same clip as it had recognizable synchronized sound (a tapping pencil))

aa.jpg

After applying the crossfade this is the situation below... The Video track has contracted due to the overlap but the Audio hasn't as unlinked audio is not overlapped. Consequently Clip 2 now does not synchronise.  It needs to move left by a distance corresponding to the transition. Clip 2 actually starts at the LEFT end of the transition bar

bb.jpg

This means splitting the Audio of Track 2 at the LEFT end of the transition blue bar.....Not the RIGHT end ;  removing the  piece of Clip1 audio under the transition bar and then sliding Clip 2  audio left to close the gap ending up like this.....

ccc.jpg

It now plays clip 2 in synch.....However..

The problem with both these solutions is that you lose a section of audio from one of the clips just for the sake of keeping the sequence on one track. Obviously the correct way is to take the unlinked audio from Clip 2 and drop it down  onto Audio track 2 so it lines up with the left end of the transition blue bar. Now it will all synchronize  and the audios will overlap in the same way as the Video tracks.....

dd.jpg

Now it plays OK with overlapping sound....

Of course one may have to add audio fade outs and fade ins to smooth the overlap......-_-  &etc &etc.:)

It might have been simpler if unlinked audio overlapped like linked audio when transitions are created with overlap.

Nat

 

Share this post


Link to post
Share on other sites

Hi Nat,  My example had both audio clips unlinked;  yours had only the second.  Either scenario, audio sync is restored.

The two-track overlap route you suggest is a good approach.

Perhaps it's best to avoid the problem entirely by specifying FREEZE, instead of overlap, when making the video trans.😉  That's normally fine on short transitions.

Share this post


Link to post
Share on other sites

I had to step back to vers 7.05 for another problem I had & needed to get the video out asap for a client. So with 7.05 there is NO option to freeze or overlap the video transition I want to use - CROSSFADE - silly because I always standardized using crossfade versions ago & it always worked - foolproof - several versions later, that broke.

Also, in 7.05 there is NO option to either FREEZE or OVERLAP when I select crossfade.

So hoping the latest vers of VP installed solves this problem - I use many transitions in my short 10 min video - about 10 approx - so don' t want to use the above "laborious" mucking around - like a maximum employment solution.

 

T

 

Share this post


Link to post
Share on other sites

Hi TDDK

There should be no difference between these versions in respect of transitioning.

"...Also, in 7.05 there is NO option to either FREEZE or OVERLAP when I select crossfade. ..."

Version 7.05 does give the user the option to use Overlap or Freeze frame. 

Check the setting you have under File/Options/Editing/Video clip transitioning.  The option should be Ask me.

Cross-fading is still the same.........:(

With linked audio the clips crossfade correctly on   both the Audio Track and the Video track.

However, with unlinked audio, only the Video tracks are overlapped. Unlinked audio then becomes out of synch. So if you want to resynch the audio and still have an overlapping video track you will have to pull it down to the next lower audio track, and drag it to the left  to line it up with the start of the transition bar as shown my post above.

Alternatively use the transition choice to use still frames.

Nat

 

 

Share this post


Link to post
Share on other sites

Thanks Nat - finally purchased the upgrade to V.24 - I was just days before the 6 month upgrade on my previous license - this sync problem caused me to spend time on working on this problem hence I missed the 6 month to upgrade to latest version - usually happens this way ;)

But with 7.24 the sync problem is solved - works now.

Then I stumbled onto the main reason all this started - my original problem;

I always add my logo watermark to lower left of my videos - always have & it worked. Now I see the logo gets cut off at the 1/3 position horizontally from the left when I set X = -42 - like something is there - same happens at the 2/3 position horizontally when I make X = +42.

Any ideas on this one ?

T

Share this post


Link to post
Share on other sites

Apply one of the new aspect ratio effects to the logo and see what happens.  If no go, upload the watermark and folks will check it out.

image.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...