Jump to content
SolarPH

Bug Report VP7.10 - Auto-Resize of image in rendered video

Recommended Posts

WINDOWS VERSION: 10

VP VERSION: 7.10 WINDOWS RELEASE

 

Hello! I have encountered a bug wherein the rendered video do not exhibit the result that is seen in the preview of the VP project. Here's the details:

 

I have 2 images. One is 1920x1080, and one is 1920x1200. When I only have the 1920x1080 before rendering the whole video, it renders perfect. But when I have the 1920x1200 added, the problem do exist in a way that the 1920x1080 image shrinks.

 

I have Zoom and Animated Position on the effect of the 1920x1200 image to animate a loop, but even without the effects, the problem still exists.

 

Here's a bit of a word summary of the bug.

 

2 Images

     - 1 1920x1080 image

     - 1 1920x1200 image

Problem

     - 1920x1080 image shrinks in all directions when the 1920x1200 image is added. It appears that the vertical sides is the basis of the resizing because the image boundaries of 1920x1080 is aligned in the vertical sides of 1920x1200 image. This bug still appears even if you disabled the Resize Video option.

Share this post


Link to post
Share on other sites

Hi

Are you using Auto Match Content setting for the resolution . The default here will be 1920 x 1200 for both clips. So the larger clip (1920 x 1080) will be "reduced" to 1920 x 1200.

If you set other resollution (including Auto match values) one or other of the clips will have a border. I don't think this is a bug as both clips have different ARs and something must give if you don't want a border.

Nat

Share this post


Link to post
Share on other sites
7 hours ago, borate said:

Please upload the project to a free server, such as MS OneDrive, share it and paste the shared link here,  so someone can attempt to duplicate your result.

Here's how...   http://nch.invisionzone.com/topic/23659-tips-for-getting-help-on-this-forum/

Specifically, where do you see the "resize video" option.

The file is in here: https://drive.google.com/folderview?id=1--i9j5KHnrDtPdbUh_CoH-8-9C5AloOu

The Resize Video option was beside the Video Format Dropdown Box (it was a hyperlink text type).

 

I have a NOTE.txt file that indicates which test was in the 3 .apng files that I rendered. Trial 1 don't have the bug shown, but Trial 2 and 3 does.

 

2 hours ago, Nationalsolo said:

Hi

Are you using Auto Match Content setting for the resolution . The default here will be 1920 x 1200 for both clips. So the larger clip (1920 x 1080) will be "reduced" to 1920 x 1200.

If you set other resollution (including Auto match values) one or other of the clips will have a border. I don't think this is a bug as both clips have different ARs and something must give if you don't want a border.

Nat

I think I have seen that option somewhere but disabled it, but I might have missed it. Cannot remember correctly as I did it yesterday night.

 

I will run another test for today.

Share this post


Link to post
Share on other sites

Just found the Auto Match Content, but it wasn't an option though. It was a Video Resolution.

 

Seems like Auto Match Content still does it's work even if it was in resolution that doesn't need Auto Match Content.

Share this post


Link to post
Share on other sites

Just found a workaround that can fix the current situation. However, it is not recommended to do with actual photos on the same scene.

 

It took 3 passes before it got done.

Pass 1 have all elements uncropped and have no effects other than the Animated Position. Resolution must be set to Auto-Match Content (Non-Forced)

Pass 2 will require the user to Crop Pass 1 to 16:9 Ratio.

Pass 3 will require Zoom Effect application. The attributes must be set to 5,5,95,95 in their respective order.(X1,Y1,X2,Y2)

 

I have been uploading the .apng files to the same shared folder right now. They are named with Video Pass Number at the end. They are with the .apng with Trial as their file names. They will be available soon.

 

Here's the shared folder's link. Just in case you might need it without scrolling into the first instance of this link: https://drive.google.com/folderview?id=1-1pd0Z9S4Nn0oSnFEaOHG38DyevDRtjK

Share this post


Link to post
Share on other sites

This wouldn't of happened if the Letterbox/Crop and Zoom feature was never invented. :/

Share this post


Link to post
Share on other sites

I have found some bug signs. This time, it happens to appear depending on the order of your layers and not just the size of your image per layer.

The bug that has been said before was in this order in layers: Layer 1 has 1920x1080, and Layers 2 and 3 has 1920x1200. Disabling either Layer 2 or 3 do not make any difference in this case. Note that Layer 3 is the top layer.

 

However, making the Layer 1 as the top layer, then disabling 1 of the 2 1920x1200 layers seems to fix the problem, and renders exactly what is in the preview window before rendering. But in this case, I included a Transparency Effect so the background elements can be seen even if it was meant to be at the topmost layer.

Although when I leave the layers enabled, the bug is still present. Seems like one layer is being outnumbered by the others, and that makes the scaling-down of the other elements, which was the function of the Widescreen Fit.

 

I'm still experimenting with the bug. Will keep you guys updated with the findings.

Share this post


Link to post
Share on other sites

Another finding has been made.

 

Seems like VP is looking for the largest Resolution if there were only 2 layers enabled, but looks for the most used resolution for the fitting of each element.

 

I reverted back the project file to the state wherein it was the same as the one that I sent, but I added the same 1920x1080 image on the bottom-most layer. I named them OL1 and OL2. This is to outnumber the 2 layers that has 1920x1200. There is now two 1920x1200 and three 1920x1080 layers present on the timeline. The output however seemed to be corrected. I might call this a solution, but it's not friendly in workspace. Haven't tried to have the OL layers shortened though, if the bug will appear after the time of the OL layers have ended or will it stay as it was as solved?

 

Edit: It seems like if you shorten the time of the OL clips(which makes it as the major resolution), that it was shorter than the time of the clip itself, the bug goes back.

Share this post


Link to post
Share on other sites

Yep, what a mess. :lol:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...