Jump to content
plevintampabay

Bugs with Picture on top of Video

Recommended Posts

I loaded a video, and an image.  Added both to  different channels in the timeline.  Shrunk (resize tool) and positioned (same tool) the image.

First bug- how do I consistently get the preview window to show the image overlayed above the video.  Often the preview only shows one or the other.  This is very inconsistent.

Feature request - when using the Size and position tool show all channels - I need to see the video to know where to position the image and the best size.

Second bug - when I export to a video file, the image is much bigger than in the preview.  This is a critical bug.  If you know of a work around, please tell me.

Share this post


Link to post
Share on other sites

Hi

Your video will go onto Video Track 1 and your image will go onto Video Track 2...the Overlay track. If you have reduced the size of the image using the Scale effect then it will be smaller than the video, so place the red cursor line at any point where the image clip overlays the video and the Sequence Preview window will show the image overlaid upon the video. Note: Upper tracks (overlay tracks) take precedence over any lower tracks they are coincident with.

If you have Video Track 2 selected..i.e. the image and you are in Clip Preview mode you will only see the image...  You need to be in Sequence Preview mode and then you will see what the output looks like at the cursor position.

If you want to see BOTH separately then in Options/Display  tick the box marked Show dual previews and right click the image track. The Clip Preview window on the left will show the image clip (reduced if Scale has been used) and the Sequence Preview on the right will show the complete timeline at the red cursor line position.

e.g...

aa.jpg

Note that if the image is the same size as the video frame then you will only see the image in Sequence Preview as it hides the video underneath.

If you are using the Position effect then dual previews will easily allow you to see where your overlay image is being placed.......

bb.jpg

In what way is the image bigger than in the preview? The export should appear exactly as it appears in the preview .  VP preview frame on left and exported MPEG4 in VLC  frame on right... The overlay image on VP track2 is the blue sign... It appears the same size in this example........

VP.jpgxx.jpg

Nat

 

Share this post


Link to post
Share on other sites

Wow, fantastic!  It worked.  Even better you taught me something critical (how to use that red arrow to change beween overlay and individual channel viewing in that upper window.  How cool!

Thanks.  I just overlaid an shrunken image and a scrolling text.  Nice!

I do have another question, that I'll put into another ticket.  Thanks. You can close this one.

Share this post


Link to post
Share on other sites

oops. I spoke too soon.  I hope to attach 2 pictures to this post. The first is the preview window showing me (the video), the small bird like logo above and to the right of my head, and the text coming in from the right all the way over in the black area.  This last point is the subject of my other thread.

The 2nd pic I'll attach is me and the logo after exporting.  Notice the relative size and position is completely different.

It imperative that positioning and size of the overlay export the same as it appear in the preview.  Is there a fix or workaround for this?

Ok, how do I attach pictures to these posts?  When I click "Insert Other media" it says something about existing attachments and that I don't have any??

Share this post


Link to post
Share on other sites

Here is the first pic I mentioned - https://www.dropbox.com/s/mv6u3zv1tuxz0lk/Preview.PNG?dl=0

This is the preview window showing the wonderful set of overlays I had designed with VideoPad.

Here is the second pic - https://www.dropbox.com/s/k3xppwdcumm8y28/exported.PNG?dl=0

This shows what was exported. Notice the logo has gotten much smaller and has moved relative to the frame.  I can not use this tool for my purposes if it does not export what the preview shows. :(

Share this post


Link to post
Share on other sites

Hi

Bit odd. Did you use the  Position effect to place your logo?  Not sure why it should change size either. It would be useful if it's not too large if you could save your project as a portable file using Save Portable Project As  This will create a folder containing copies of all the component clips/images as well as .vpj file.  Upload this to Dropbox (or similar). make it public and post a link here. Someone will download the files and reconstruct your project to see what might be wrong. details are here...

http://nch.invisionzone.com/topic/23659-tips-for-getting-help-on-this-forum/

Nat

 

 

Share this post


Link to post
Share on other sites

I have not solved this problem, and it is no longer a problem for me.

I had another thread about how to change the aspect ratio of the frame, which was successfully answered -

(Options / General / Preset / Cell phone)

Having done that, when I export now the position and size remain as shown in the preview.

 

Share this post


Link to post
Share on other sites

I've encountered the same preview vs. generated issues.  I spent HOURS the other night, adding the blur effect to sensitive PII info for a video that is ~1hr 40min long.  The preview looked great, then I exported, and the blurs were off in positioning.  All of that work  --- drained.  I figured the preview was displaying a different aspect ratio than what I exported (both were default) and this lead to the difference in preview vs generated.  That said -- thats a horrible usability issue.  Your users need to know that the preview needs to be the same resolutions as your intended export.

 

I'm also not able to preview a very small image in the top right location of the preview window.  More context -- Im trying to change recorded powerpoint slide numbers without re-recording the slides in Debut.  I imported cropped slide numbers from full screen slide screenshots....

Issue #1 :  When I import the image, it blows it up and scales it to fit the resolution of the preview.  This is super annoying because I just want to import the image and drop it over the video's existing slide number.

Issue #2:  When I go to change the position of the small image overlay, the image and the widget are disconnected.  I dont know if I should follow the widget or the image when deciding on position.  What's worse, I have no idea where the image is going to show up after I export the file (which may take hours).  This is a relatively simple task and I'm having immense difficulties.  Very frustrating.

Share this post


Link to post
Share on other sites

Hi

Issue 1.......I don't think there is a way around this. I just loaded a 192 x 107 pixel image and it totally covered a 1920 x 1080 video clip....... You will need to reduce it with Scale and position it with Position. Using Dual preview displays makes it easier.

Issue 2......Dragging the scaled down image to another position when using the Scale effect does leave the widget rectangle in the same place. I also find that the moved image does not respond beyond a certain position doing it this way.

aa.jpg

So reduce the size with Scale and use the Position effect to place the image within the frame.That works OK here.

With regards to your Blur......dis you use the Censor effect or did you blur a masked area? Upload a short section of the project as Borate suggests.

Nat

 

 

 

Share this post


Link to post
Share on other sites

Thank you NationalSolo.

As I mentioned above, if I change the aspect ratio and frame size in Options BEFORE loading a video, then it loads as I need it to.  That is, set the size to cell phone and then load a video that was recorded on a cell phone. 

This solves the export position being different than the preview problem.  Now when I export, it looks just like the preview.

Agreed, I need to use scale to reduce the size of the overlay image, and then I use the position tool to move in the frame.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...