Jump to content
johnywhy

Amplify Has No Effect

Recommended Posts

i applied the amplify effect, but there's no difference in audio volume. 

Steps:

  1. select first clip in sequence
  2. ctrl-A, to select all clips
  3. toolbar>audio>effects>amplify
  4. "apply to all"
  5. press 'play' and listen
  6. increase gain to 200
  7. hear no change in volume of audio

how to fix?

thx

Share this post


Link to post
Share on other sites

Hi

Try this....

  • Pick just one clip
  • Check volume is 100
  • Click sound FX Click the green plus and select Amplify. (Gain = 100)
  • Move effect cursor to start of clip (Left)
  • Move gain slider to right to set it at 400
  • Click the keyframe button.
  • Move the effects cursor halfway along the clip and create another keyframe
  • Grab the graph line to the right of the keyframe marker and drag down to the bottom
  • A bit further along drag it back to half way up. Should look a bit like this....

aa.jpg

Now play the clip... You should hear the volume start loud and then drop and then rise back to normal reflecting the graph line. If this happens the effect is working........HOWEVER...

If you have grouped several clips it seems that the sound effects will only affect the first clip of the block, or the clip selected first before the group is made even though VP recognizes that you have grouped a number together. This appears to be an error.(I think it has been noted before in previous versions.)  A Bug report has been sent.

Nat

 

Share this post


Link to post
Share on other sites
3 hours ago, Nationalsolo said:

thx.

  • Pick just one clip
  • Check volume is 100

 

How? I don't see "Volume". 

Quote

 

  • Click sound FX

 

i notice if i'm not zoomed in enough, then the FX button isn't visible. Can't i just click toolbar > audio > audio effects > amplify?

Quote

 

  • Move effect cursor to start of clip (Left)

 

Where's effect cursor?

Won't the effect work with cursor in anywhere, as long as the clip is selected?

Quote

 

  • Click the keyframe button.

 

Where's keyframe button?

  •  
Quote

 

  • Move the effects cursor halfway along the clip and create another keyframe
  • Grab the graph line to the right of the keyframe marker and drag down to the bottom
  • A bit further along drag it back to half way up. Should look a bit like this....

aa.jpg

 

 

is all that necessary? Can't i just set the gain for the whole clip using the gain slider or typing the number?

so, if my sequence has 50 clips, then i have to separately set the volume for each one?

if i'm not zoomed in far enough, some clips might be too short to even see them. So i might miss them. 

Quote

If you have grouped several clips it seems that the sound effects will only affect the first clip of the block, or the clip selected first before the group is made even though VP recognizes that you have grouped a number together. This appears to be an error.(I think it has been noted before in previous versions.)  A Bug report has been sent.

Wow. Pretty huge error!

Any other way to apply an effect to all clips, that will work in current version?

thx

Share this post


Link to post
Share on other sites

1.  Complete editing

2.  Click the SEQUENCE tab above the bin

3.  Right-click on SEQUENCE 1 and "Save Sequence Audio as New File"

    (The AUDIO tab automatically activates to display the new .wav file, which is in the PC's MUSIC folder.)

4.  Double-click that file and apply the AMPLIFY effect

5.  Move the scrubber (red preview line) far left

6.  Right-click the .wav file and OVERLAY AT CURSOR

7.  Click on the words "Audio Track One" that are just left of the track itself and DELETE TRACK or mute that track

If you want to get fancy, right-click the .wav file in the bin and OPEN WITH|WAVEPAD.

Share this post


Link to post
Share on other sites

HI

The post was setting out some steps for you to check that the effect was actually working. A simple change in gain over the whole of a clip might  not really be noticed. A change in gain along a clip possibly would.

"How? I don't see volume"

Volume is the value shown when you click the loudspeaker icon on the sound track. (Not the same as gain) It was just to check the volume level of the clip

"Can't i just click toolbar > audio > audio effects > amplify? "

The FX and other timeline prompts can disappear if you are zoomed out too much.But using the toolbar prompt will also work. This enables the use of effects on multiple grouped clips. The FX is for a single clip which was what I was describing as a test.

"Where's effect cursor? "

The effect cursor line (scrubber bar) is the red vertical line in the effects window..see my image which is the effects window.This can be moved right and left to indicate  particular points in the clip. (Left is start and right is end.)

"Won't the effect work with cursor in anywhere, as long as the clip is selected?"

Yes. With no keyframes created the effect is applied automatically  to the whole clip at the value selected. As I mentioned though with the whole clip treated you may not notice a change. Hence using keyframes at different points makes the change more evident.

"Where's keyframe button?"

This is the first button above the graph pane with a small green cross. Clicking this sets the selected parameter value at the red cursor line position. In effect it fixes the graph line at that point. You can now grab the line further along and drag it to a different point. When released each point becomes a keyframe where the parameter value is different. The parameter will change between these points as the clip is played.

"Can't i just set the gain for the whole clip using the gain slider or typing the number?"

Yes..For a single clip (with no keyframes) but not multiple clips

"if my sequence has 50 clips, then i have to separately set the volume for each one?"

That's about it (with this apparent bug) You can easily lower the volume of the whole Track but not all the clips grouped

"Any other way to apply an effect to all clips, that will work in current version? "

You could create a sequence from the clips on the timeline which, if reloaded will act as a single clip. You would then need to save the sequence audio as a new file and drop down to the timeline. Now the effect can be added to the whole of the sequence.

Edit: Borate has just outlined this procedure above. :-)

Nat

Share this post


Link to post
Share on other sites

thx for info, guys. 

saving out a new sequence and then importing will work, but if more clips added to the sequence afterward, then new probs. Hope this bug can get fixed. 

does this bug affect all audio effects? or just amplify?

18 minutes ago, Nationalsolo said:

The post was setting out some steps for you to check that the effect was actually working. A simple change in gain over the whole of a clip might  not really be noticed. A change in gain along a clip possibly would.

ok, thx. But that just confused me. I can easily hear the gain-change on the whole clip. 

Quote

With no keyframes created the effect is applied automatically  to the whole clip at the value selected. As I mentioned though with the whole clip treated you may not notice a change. Hence using keyframes at different points makes the change more evident.

Can a keyframe apply to the entire sequence of clips, to change gain for all clips with a single keyframe?

Quote

You can easily lower the volume of the whole Track but not all the clips grouped

But not add gain to whole track?

thx!

Share this post


Link to post
Share on other sites

Hi

Had another look at this...You can apply the audio effect to all the other clips but it needs an extra step.....

  • Group your clips on the timeline (Select the track /Ctrl+A/Right click and select Group Clips)
  • Select the group
  • Press the SHIFT key and then right click the Toolbar Audio Effects down button.
  • Select your effect. This will open the Apply effect to all clips etc. dialogue screen . (As several clips are selected as a group)
  • Click Apply to all. The FX on each clip in the group will turn blue.
  • Apply the effect.  Currently the effect is only applied to the clip under the cursor line even though the other clips in the group have the FX in blue. This has led to some confusion.  Another step is required...
  • With the effect pane still open Click the 4th button along at the top. It looks like a piece of film with a tick. This button will replace the effect on the other clips in the group.
  • All the clips should now have the effect applied.

Nat

Share this post


Link to post
Share on other sites

Another good method Nat.  It can be simplified a bit.  Try this...

1.  Select the clips to which the effect will be applied.

2.  Click FX in one of the clips or AUDIO EFFECTS on the toolbar

3.  Choose AMPLIFY and move the slider to the desired volume

4.  Click the 5th button from the left on the toolbar whose popup reads "Append to chain."

If the selected clips' volume later needs to be adjusted, make the change with the slider, then click the 4th button, "Replace in chain."

Share this post


Link to post
Share on other sites

Hi Borate

Yes, I noticed both 4th and 5th worked for the grouped clips. I originally got the impression that the option dialogue that comes up when the toolbar  tab is used for grouped clips automatically dealt with all the clips without that last step as the FX for each went blue but only one  worked. Gives the impression that its a program error.

The 5th button is more logical in its description though. There have been questions on the forum before about the action not working correctly. Anyway it's sussed now. :)

Nat

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×