Jump to content
dc.dreamcatcher

Preview Lag/Buffer

Recommended Posts

I see this was an issue back in 2016.  I am having issues with lagging/buffering.  I purchased the professional version thinking this would help.  I cannot figure out if the video is being properly edited if I cant get a smooth result.  what are the best settings I should use in order to correct this issue and any other feedback would be greatly appreciated.

Share this post


Link to post
Share on other sites

Use the latest version, if it's been less than six months since purchase.

Right-click in the preview window and change preview resolution to a lower preset.

Allow the green line above the timeline thumbnails to complete before previewing.  The line represents the caching process.

Close all background applications while editing and exporting.

Share your project, if it's not a lengthy one, so someone can check it out.  Here's how...

1.  Save the project.  Then, with it on the timeline, click the FILE menu. SAVE PORTABLE PROJECT AS to any convenient folder.

2.  Open the folder that contains the saved files and ZIP them all.

3.  Upload the zip file to DropBox, Google Drive, MS OneDrive or the like.  It's free.

4.  Make the uploaded file public (share it) and copy the shared link.

5.  Paste the link into this forum.

Video editing is resource intensive.  It's advisable to have at least 8GB of RAM, copious free disk space, and a fast processor such as an I5 or I7.

Share this post


Link to post
Share on other sites

The stuttering result is apparent.  Please upload the project, per the instructions above, and someone will check it out.

Share this post


Link to post
Share on other sites

Can't pin down why preview is choppy, but export is fine.  Suspect it's related to speed changes.  Video runs short of audio;  no doubt that's intentional or the project is incomplete.

There were two gaps near the head, which you can spot in STORYBOOK mode.  To close them, right-click and CLOSE GAP.

As a matter of practice, if this project is to be monochrome, you might want to hold off on the color title and B/W effect for each clip.  After assembling the clips, create a new sequence by clicking the + sign to the right of the sequence 1 tab, above the timeline.  The new sequence 2 will be blank.

In the bin (top-left) click the SEQUENCES tab and drop sequence 1 onto the sequence 2 timeline.  It will then contain the whole project as a single clip. (The audio track won't display, but it's there.)

Then apply the B/W effect to that clip and add the color title at the head.  Export sequence 2.

Share this post


Link to post
Share on other sites

Yes I am nowhere near done. This was just a practice run.  I have a lot more footage. Do you recommend that I build separate videos since  mine will be a 3 minute video with a lot of cuts. Maybe 5 or 6 separate videos then connect them at the end? Since the lag doesn't happen in the actual video then I can at least have the cuts more accurate.  Also,  would it make sense to adjust the original footage speed? I used the go pro camera whatever the basic settings are.   I don't mind reducing the quality somewhat.

Share this post


Link to post
Share on other sites

Divvying up the project isn't a bad idea.  Not clear on what you mean by "adjust the original footage speed?"

Experiment with first creating lower-resolution clips, and use those in editing.  When satisfied, and the project is saved, replace those clips with the originals by using FILE|CHANGE FILE. 

Share this post


Link to post
Share on other sites

This has been an issue much longer than 2016. I have the version 6.24 and am having the same problem. The video segment I'm working on is only about ten minutes long. Letting it sit for about a half an hour until it completely loads doesn't solve the problem. Splitting all tracks will generate the building preview and stuttering of the video as well as adding six seconds of text. Leaving it alone for extended periods of time after any change doesn't solve the problem either. This problem makes the program virtually unusable. When exported, the video plays fine.

As long as this has been a problem, it appears to be a problem with VideoPad itself. 

 

Share this post


Link to post
Share on other sites

Two suggestions...

Share the project or a portion thereof, so someone can check it out.

Use low-res thumbnails when editing, as described above.  When ready to export, replace those with the original video.

Share this post


Link to post
Share on other sites

Hi

Under File  save your project as Save Portable Project As, this copies all the files to a designated folder including a .vpj file. Zip them all and post.

Nat

Share this post


Link to post
Share on other sites

I've already attached in an earlier post.  I don't know, i'm almost ready to give up.  I have a lot of footage and only 1 minute into the project lol.  It looks horrible.  This needs to be on time with the music also.  So I don't know if there is a way to get this done on this program.  If I change from black and white I still see lagging

Share this post


Link to post
Share on other sites

https://www.nch.com.au/general/refund.html

Before you bail out I suggest that you try the method suggested earlier - editing with low-resolution copies.  When done, replace those with the originals before exporting.  Tested here, that produced a glitch-free preview.  Here's the approach...

Place the original files in a "high-res" folder, which initially will be ignored.

Convert those files and place them in a separate "low-res" folder, to be used for editing.  NCH Prism can batch convert video files.

When done, right-click on each clip in the media bin - one at a time - and click CHANGE.  Find the original file in the hi-res folder and click on it.  Export.

Share this post


Link to post
Share on other sites
On 10/11/2018 at 11:32 AM, dc.dreamcatcher said:

I see this was an issue back in 2016.  I am having issues with lagging/buffering.  I purchased the professional version thinking this would help.  I cannot figure out if the video is being properly edited if I cant get a smooth result.  what are the best settings I should use in order to correct this issue and any other feedback would be greatly appreciated.

I just updated to 6.24 and was having a slew of weird problems. I think maybe the update reset a bunch of settings. I had the audio export glitching with that codec that you have to delete and have the program redownload for you, and up until just right now I was suffering through impossible preview lag and buffering time. 

I right clicked the preview window and set the preview down to 360p (it was at 480p when I looked) and it's working great again now.

If your computer is strong enough, you shouldn't need to create low-res copies and edit with those and then "change file" back to the hi-res ones. I mean it's a solid suggestion but it might be circumvented by some tiny change like this instead. My ancient laptop was working with multiple gigs of videos up until I got my new PC a few months ago. I think for the most part, most computers should be able to find a settings combination that work for it.

Anyway Videopad is not without its fair share of infrequent irritations, but it's powerful and versatile and I have stuck with it this long so hopefully you can find the quick fix and not have to get your money back. Good luck!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×