Jump to content
Sign in to follow this  
HunterEdits

Video blur when adding images to timeline

Recommended Posts

I have had this issue for a long time. If I try to add a still image like a PNG to a video, not only will the image itself lose focus, but the video somehow becomes compromised and blurrier. This was a serious issue in my video where I had captured frames, made them grayscale and added captions, because they are immediately compared to adjoining video, so the video gets suddenly blurry and then goes back to sharpness when motion resumes.

But even then the video itself isn't as clear when pictures are on the timeline. I have also had abundant issues with audio pops when using images. Here is an example of a title I made in Gimp along with a lossless copy of it in a video. At first glance, it's the same. But check the contrast of the text, and the detail on the texture of the green thing. Look around the rim of the green eye and the base of the tentacles.

VTKtiI4.png

Oh, just so you know, the image is the same size as the video, custom made for it. That is 512x384.

Is there anything I can do about this besides trying to sharpen everything, since I know it won't render right? It looks sharp in the editor.

I have even tried converting these PNGs to little video clips. Same thing, it lowers the quality of the image.

Help!

 

Share this post


Link to post
Share on other sites

Hi

I often include images into my videos but they look OK. However what is the actual resolution of your video? You say the image was custom made at 512 x 384, This has an AR of 1.3333 whereas a 16:9 video has an AR of 1.777  Are you using scale a little to eliminate possible borders as that may have an effect.  Try 512 x 288 for your images which is 16 :9.IMHO I this this is a little low.  For clarity is probably better to use images that have the same resolution as your video e.g. 1280 x 720  or 1920 x 1080.

Nat

Share this post


Link to post
Share on other sites

The video and images are exactly the same size, 512x384. So there should be no border. Put this aside for a second.

In my other project I captured frames, made them grayscale and added captions. So they are literally frames from the same video made into a PNG with some captions. So it should look, if the source file is of good quality, the same as the adjoining video frames. SHOULD...

It doesn't look horrible, but it is worse. As the picutre demonstrates. At a glance it's the same. But the details are gone.

What format do you use for inserting pictures? Do you do anything special with them other than dropping them in?

Share this post


Link to post
Share on other sites

Most of the video compression methods are loosy. They also designed for motions so are especially bad for small text that sit still.

Try open "Advanced Encoder Options" and choose high quality settings when you export.

Share this post


Link to post
Share on other sites

Hi

Using a snapshot of text made at HD1080 added to the timeline of the same text generated in VP showed no obvious degradation between the two BUT  there was noticeable difference in the registration of the snapshot text with the original. Different text lines with different sized fonts showed changes in both size and relative position.

" What format do you use for inserting pictures? Do you do anything special with them other than dropping them in? "

Most images I use are .jpeg or occasionally .tiff  or .bmp  I normally use images of  equal or greater resolution than the video and I just drop them to the timeline. They look OK to me.

Nat

Share this post


Link to post
Share on other sites

Hi Nat,

1 hour ago, Nationalsolo said:

Using a snapshot of text made at HD1080 added to the timeline of the same text generated in VP showed no obvious degradation between the two BUT  there was noticeable difference in the registration of the snapshot text with the original. Different text lines with different sized fonts showed changes in both size and relative position. 

Could you please post a screen shot that shows the difference?

Share this post


Link to post
Share on other sites
22 hours ago, c_major said:

Most of the video compression methods are loosy. They also designed for motions so are especially bad for small text that sit still.

Try open "Advanced Encoder Options" and choose high quality settings when you export.

The left image is the source file and the right image is a lossless rendering of it.

But that's beside the point. The video looks good compressed (of course a little better lossless, but 2x as large). If I could somehow massively increase quality to get the pictures to look the way they do outside of videopad, which I can't, that wouldn't be a solution because of the massive file size.

I understand compression, I just don't think what I am experiencing is normal.

Share this post


Link to post
Share on other sites

I've tried the result looks good to me:

P84dw0X.png

You do need to make sure the source image and output are at exact same resolution. The blurring could be introduced by stretching the image.

Also are you using the latest version of VideoPad?

 

Share this post


Link to post
Share on other sites

Hi Sam

" Could you please post a screen shot that shows the difference? "

Well. Ive been trying but can't seem to reproduce the same conditions. The snapshotted text remains obstinately the same as the original on the timeline... 😫

What I did have definitely moved at the join but I am afraid I dumped it. I remember I re-snapshotted it at 720 to see what difference there was and the jump was a lot less. I'll have another play and come back if I find what I did.

Nat

Share this post


Link to post
Share on other sites

Hi Sam

OK ...

" Could you please post a screen shot that shows the difference? "

As images you may not see much so try these steps....

  • Open VP and create a text file that is simple black text left justified  as follows....

AAAAAA (enter) AAAAAA (enter) AAAAAA(enter)AAAAAA

  • Swipe first row and size 20
  • Swipe second row and size 18
  • Swipe third row and size 15
  • Swipe fourth row and size 12

30w6B.jpg

  • Place the image on Video track 2 and add a white blank background behind it on Video track 1
  • Move cursor to where the preview shows the text
  • Create an HD 720 snapshot
  • Place on Video track 1 at Start (Both clips will look identical with black text on a white background)

30WFl.jpg

 

You should see, when dragging the cursor over the join that the text jumps at the join.

The movement is also noticeable if the snapshot is made at 4k Ultra HD but not when HD1080 is chosen.

If the video is exported as a You Tube 1080p the movement is present.

If another export is made and Preset is clicked the export is You Tube 1280 x 720p   the movement is absent.

Nat

 

 

Share this post


Link to post
Share on other sites
On 7/25/2018 at 8:15 PM, c_major said:

I've tried the result looks good to me:

P84dw0X.png

You do need to make sure the source image and output are at exact same resolution. The blurring could be introduced by stretching the image.

Also are you using the latest version of VideoPad?

 

I did. They are at 512x384. At least that's what virtualdub says it is. That's how videopad detects it too.

Version, I was using 5.2 because I don't love the dark color scheme, but I switched over to 6.1 to check and it's pretty much the same, except for some reason 6.1 absolutely refused to make a lossless video with any picture in it. I tried PNG and BMP and both renders "failed." So I compared with the two native renderers at high quality, MPEG4 and H264. H264 was the better of the two, but comparable to the results with version 5.2.

As far as general video quality, I think there is something going on when pictures are included in projects. I am going to try some crazy workarounds to putting pictures in my other project because sharpening won't work there (picture frame should be the same as video frame and it is not). For this project, I am going to sharpen the hell out of it and that should work.

But it's too bad it doesn't just come out looking good with 1:1 pixels.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×