Jump to content
Nationalsolo

Removing overlapped crossfade does not restore the clip(s) original length

Recommended Posts

Hi

I am posting this just to see if anyone sees a similar ?bug. I have just started editing a rather long project of a 24 hr sailing race. I started by loading a first block of some 92 short clips using Ctrl+A and dragging them all to the timeline. As these were  in chronological order and many would be dissolved from one to another I decided to select the lot (Ctrl+A on the timeline) and using the Transition tab on the top toolbar to add a moving clips  crossfade between all the clips. During editing I would then work along the timeline deleting unwanted clips and trimming others using START/END markers in the clip preview window and removing  crossfades where they weren't required as I came up to them.

It was then I noticed that when removing a crossfade by clicking  the blue transition X and selecting the No Transition option. that although the transition disappeared the clips remained trimmed in the clip preview window.  This meant that the clips were not restored back to their original lengths. I was expecting the portion "lost" in the overlap would be restored (i.e. the end of clip 1 and the start of clip2.) Instead these portions remained greyed out in clip preview.  Can anyone confirm this or NCH comment?

Nat

Share this post


Link to post
Share on other sites

Was this a case, when specifying the transition, you were offered the choice to overlap or freeze?

Choose FREEZE and see if it exhibits the same behavior after trimming and removing the trans.

Share this post


Link to post
Share on other sites

Hi Borate

The addition of the multiple crossfades used the Overlap option as it produces a better dissolve.The overall length of the timeline decreases as you know when this is used as each clip is trimmed to make the necessary overlap . My original 92 clips had a timeline duration of 27:23 minutes. After the addition of 6 second crossfades this dropped to 18:31 minutes.

As I found the ?bug when removing single transitions I decided to remove the lot in one go so..Ctrl+A on the timeline and select No Transition and apply to all.  Ungroup the mass selected clips. The transitions got removed but the timeline remained 18:31 minutes long, and each clip showed the ends still trimmed with the START/END markers!

t8V9D.jpg

Your suggestion of trying the Freeze option is logical but If I were to use the Freeze option there would be no shortening of the clips and one could swap the transition from Crossfade to No transition without any change in timeline length

Apart from this unwanted effect the method of going along the timeline like this works OK and VP has had no glitches so far and I can insert a bookmark at the point I have reached before Saving the Project As

Nat

Share this post


Link to post
Share on other sites

Hi

Going further, I noticed that even with two 1 minute clips on the timeline (i.e. sufficiently long enough for adding a transition between them) adding a crossfade  puts up the option window........ as usual...

tM6Nn.jpg

But what does the top sentence actually mean?  Two 1 minute clips is ample material for an overlapping transition.

Nat

Share this post


Link to post
Share on other sites

Hi Nat,

When create transitions, VP will check if there is enough materiel outside in/out point. If yes, it will just extent the in/out point to create overlapping section. Otherwise, typically when there is nothing outside in/out point, VP will shift the clips on the right to create the overlapping section. In this case frames will change their position on the timeline.

The same logic applied to removing transitions. When removing transitions, we will move the in/out point to remove the overlapping area instead of moving the clip.

We don't provide option to move clip when removing transitions. That's because keep the video frames stay on the time position seems like a safer option. For example if you already syncing with the audio track, you really don't want the frames move their position when you editing transitions.

You can always restore the original clip length by move the in/out point in clip preview.

Share this post


Link to post
Share on other sites

Hi Sam

Thanks for the explanation. I understand the logic but still can't see the reason for the top statement in the window. Two long clips must have sufficient material for a short overlapping transition. I assume its hard wired.

I can see that resetting the in.out points might cause problems in many cases where the transition is removed particularly where the sound is unlinked. The post was just an observation that some might have found irritating (even if they noticed.) and I wondered why it did this and whether it was an oversight.

In this case there is absolutely no problem and in fact it is somewhat advantageous.?

For some reason the end of all the raw clips shot with this camera ( a Toshiba ) had the soundtracks truncated by around a second.   making 1 second sound gaps when the clips were assembled on the timeline. Synchronization of the sound was otherwise perfect.....

tbpnu.jpg

 Editing these out using Split/delete/close gap or the Clip preview  IN/OUT markers would have been a nightmare with 100s of clips. However, automatically adding the overlapping  crossfade transition to all the clips automatically removed this silent gap in the soundtrack.as well as smoothing out the action between the shots.  After editing out the unwanted transitions (or even them all,) by using No transition, the clips were left in the same position so eliminating the sound gaps.    Perfect!

Nat

Share this post


Link to post
Share on other sites
Quote

I understand the logic but still can't see the reason for the top statement in the window. Two long clips must have sufficient material for a short overlapping transition

That's true, Nat.

To clarify how the prompt works, place two ten second or longer videos on the time line.  Specify a two-second transition.  The prompt appears.

Trim out the last five seconds of the FROM clip or the first five of the TO clip and specify a trans.  The prompt appears.

Now trim both FROM and TO clips by five seconds, so that each clip has sufficient excess video at their tail and head respectively to cover the transition duration.  No prompt.

Share this post


Link to post
Share on other sites

Hi Borate

Yes I noticed this previously when I tried to Add a transition then No Transition. Got the message each time.....Transition disappeared but timeline remained shortened as expected. The Clip preview showed in/out markers still set to the ends of the old transition.

I then thought, "What happens if I do the same again with these clips...Will the timeline get even shorter?"...Well YES it did and the message also appeared as well. So the timeline shortened twice with two add and deletes.

I then thought  "Hmmm. If I do this enough times will the clips shorten to zilch?"  ? Well no! The third time I added the crossfade transition and removed it, the message didn't appear and the timeline length didn't change either. I didn't calculate  anything from the values I set  but I guess with two shortenings the in/out markers had moved in enough to allow the transition to install without requiring a message.

No problem just academic. It works!

Nat

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...