Jump to content
Brett Brandon

Audio Not Following Crossfades

Recommended Posts

This has become very frustrating. I even redid the entire project from scratch with similar results. I am crossfading between clips and some of the fades are not including the audio. The audio abruptly stops and starts. If I view it in your software, all fades work properly. Viewing the exported mp4, not so much! All clips are from the same camera with identical size and settings. It is being exported the same size and settings as the original video files...

Is there something I am missing. I just came across this software a couple of days ago and other than this, the software is great. I am a professional audio person, not video, and I understand this is a free version, but why would I consider buying something that dosen't work properly. This has been very aggrevating...

Brett

Share this post


Link to post
Share on other sites

Under the OPTIONS|EDITING tab, confirm that "apply sound crossfade to video transition" is checked.  Program transitions LAST, after making all edits on the associated clips.

If the project is not voluminous, or a portion that exhibits the behavior can be isolated, please share it.

With the project on the time time line, click FILE|SAVE PORTABLE PROJECT.  Upload every file that results to DropBox, Google Drive, MS OneDrive or the like.

Make the link public and post it here.  If there are many files, zip them first, then upload the ZIP file.  Someone will check it out.

The latest VP version is here.

Share this post


Link to post
Share on other sites

Thanks for the reply.

Apply sound crossfade to video transition, is checked. I downloaded and installed the software a couple of days ago.

This video is from a friends wedding and I'm not sure that I should share any of it...

The way I assembled the time line is this:

1. Drag clip to time line after previous clip.

2. Edit beginning and end of clip.

3. Select audio track and apply vst effect "Isotope Ozone" a mastering plugin to the audio.

4. Click on and select the previous video clip and apply crossfade between that and current clip (all clips in project are using crossfade).

5. Insert next clip, ect...

I took this approach on the second try thinking some of the editing of clips that were previously edited was causing the problem in the first attempt. What I don't understand is why only some of the clips are affected.

I do see now where in the tutorial they say to click on the "transition box" to apply one. I was clicking on the video track Itself to apply the transition. Was this possibly selecting just the video for the transition, but if so, why did most work as expected fading both video and audio?

Thanks again for the reply... Brett

 

Share this post


Link to post
Share on other sites
Quote

I was clicking on the video track Itself to apply the transition.

Not clear how that method enables a transition.  Normally, there are two routes:  click the X on the clip or click TRANSITION in a menu bar.

Does the issue arise if the Ozone plugin is not used?  Is audio linked to video on all clips?

You might also test editing  to satisfaction, selecting all clips with <ctrl-A> and, lastly, clicking on TRANSITION in the menu bar and choosing CROSSFADE.

A prompt to "apply to all or one" should appear.  Apply to all.

Share this post


Link to post
Share on other sites

I clicked the video track to select it so the program knew where to apply the transition. I then clicked the transition icon on the "Home" toolbar to select and apply the transition.

All the clips have Ozone on them. The audio is the original from the video clips, not imported. Applying to all won't work as there are different crossfade times.

A confusing part is they all play properly in the software but not after export...

I think I am going to try one more time from scratch using the "X" to set the crossfade. If that dosen't work, I found that I can fade the audio seperately to fix the ones that don't want to work properly.

 

Thanks again, Brett

Share this post


Link to post
Share on other sites

If feasible, share the project, as instructed above, and folks will try to duplicate your result.

You can "apply to all', then click on a specific clip's transition X and change that clip's transition duration.

Share this post


Link to post
Share on other sites

Hi

The transition is applied by clicking the X that is between the clips.It doesn't make any difference if you select the left hand clip first. Choosing the Crossfade transition the audio should also cross fade irrespective whether  you have chosen to move the clips (overlap) or keep single frames, provided the Option box/Editing Apply sound crossfade for video transition is ticked. The fade out/fade in starts at the left edge of the transition blue bar. trimming the clips does not prevent this action provided you have closed any gap correctly.

If this box is not ticked then irrespective of the crossfade options the sound cuts immediately at the join between clip1 and clip2.

That's the way it is meant to work. If it doesn't do this something is wrong.

Does the blue transition bar at the top of the clips sit centrally on the join? or is it all on the left clip? If so it may indicate that you have a very small gap between the clips.

Older versions of VP used to show whether there was a sound track crossfade. The latest version doesn't. Run a test with a voice soundtrack on clip 1 and a music track on clip 2. Set a crossfade transition od 6 seconds. If all is well you should hear the music fade in 3 seconds before the end of clip1 when the cursor reaches the transition marker.

Nat

Share this post


Link to post
Share on other sites

Howdy,

example.png

Apply sound crossfade is ticked. The break between the clips is centered in the fade. The clips are butted up together. The transition farthest to the left is one of the crossfades that did not work. You can see at the end of the wave file where I did a manual fade to fix it. What tells me somethings wrong is the fact that playing the project in the software plays fine... All fades are working. When rendered to a file, some of the fades are not fading... I don't understand why it works in the software but not after export. That tells me it is the software, not operator error.

I appreciate all the help, but I have wasted eight to ten hours fighting this and have decided to just manually fade what isn't working and be done with it. This is just a favor for a friend. I wish I could let you see the files so you can troubleshoot your software as I find it laid out very well and was quite easy to jump in and do what I was looking to do. If I were getting into video, I would definately give this a try... It also has fast and experienced help in the forum here, thank you for that.

Brett

Share this post


Link to post
Share on other sites

Hi

Your settings are correct so clip 2 should fade in from the start of the transition marker bar.. I notice however that you seem to have added a soundtrack fadeout to clip one which may be affecting it .This is not really necessary as (normally) crossfade does this within its duration but should make the Clip2 soundtrack fade in more easily heard. I checked this out and found that with the soundtrack fadeout to Clip 1 , Clip2 did not fade in during the transition, it started at the END of the transition. So remove the soundtrack fadeout and see if that cures things.

Nat

Share this post


Link to post
Share on other sites

Nat

I put the manual fades in after I wasted hours and hours trying to get the "crossfade" to fade the audio as well, and not just the video, so I could put this puppy to rest.
What nobody seems to be paying attention to is the fact that THE FADES WORK PROPERLY WHEN THE PROJECT IS PLAYED IN VIDEOPAD. SOME FADES DO NOT WORK AFTER EXPORT. Something is going wrong during the export process. I have even tried doing the export after a fresh reboot, and left the computer completly untouched during the export in case something from the computer was interfering...
I understand that I'm a newbie to the software, but I have been running complicated audio and graphic programs since the 90's (thus why I was able to figure out the program in minutes without a manual). This is not operator error. This is a problem with Videopad! I appreciate the help, but at this point I have had enough and this will be my last post. I used the manual fades to fix what the software wasn't doing properly, end of story.

If you want additional info to continue troubleshooting: Camera - Canon VIXIA HF R70, all clips at 1920 X 1080 60fps, audio is original audio from clips edited with a vst plugin (dynamis and eq only, no length change), project is 40 minutes long. This is from a friends wedding so I will not post samples.

I just noticed a new post where a long time user can't do manual fades in windows 10. I guess it's a good thing I have windows 7 64 bit, or I might not have been able to finish the project.

Brett

 

Share this post


Link to post
Share on other sites

It isn't necessary to post the project to the forum.  A private message (PM) is an alternative.  If you can isolate a small portion of the project that exhibits the fault, please PM me or c_major (admin) as instructed earlier.  Provide details.  Tests here with several same track audio transitions have exported successfully.

Share this post


Link to post
Share on other sites

Hi,

There was a bug when loading saved transitions with sound crossfade.

We'll get it fixed in the next release.

Share this post


Link to post
Share on other sites

Would this problem have anything to do with Videopad adding noise to transitions? I get a weird digital type sound which you can hear when editing, but it does not show up on the sound track until you render the video. It can clearly be seen then and removed by doing another edit, cut before and after the sound and then mute it. I've had to do that on several videos lately. Should not have to do this I don't think.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×