Jump to content
robkblue

Clip transitioning options

Recommended Posts

How can you change the setting on the clip transitioning dialog box that comes up when you are setting a fade. You get these 2 options: 

-Yes, move the clip for an overlapping transition

- N. Freeze frames at start/end of transition.

Once you tick 'Use this choice...' box, it won't reappear and I need to change the setting.

 

Thanks.

Share this post


Link to post
Share on other sites

I made the setting change and it doesn't prompt me, it is still moving the clips when I change the fade transition time. I even uninstalled the program and reinstalled and it is still defaulting to this. Frustrating!

EDIT: Actually it started working. I think the issue was related to the fact that the particular transition I was having trouble with, the end of the clip had a very tiny clip hidden at the end because it was so small (timewise). I couldn't see it until I zoomed right in and was able to delete it.

Share this post


Link to post
Share on other sites

Hi

Tiny clips which are not readily visible in timeline mode at "normal" zoom levels can easily be found if you switch into storyboard mode as then every clip, no matter what its duration is shown as a single thumbnail "slide"and can easily be detected and deleted.

Nat

Share this post


Link to post
Share on other sites

This is still happening! When I make a fade transition between two clips the whole timeline shortens a bit. I have changed the suggested settings but I am not getting asked for which setting as I set it. And even uninstalling then reinstalling the whole program makes no difference!

Any ideas?

Share this post


Link to post
Share on other sites

As mentioned earlier, the default behavior is set in OPTIONS|EDITING tab.

To clarify how the prompt works, place two ten second or longer videos on the time line.  Specify a two-second transition.  The prompt appears.

Trim out the last five seconds of the FROM clip or the first five of the TO clip and specify a trans.  The prompt appears.

Now trim both FROM and TO clips by five seconds, so that each clip has sufficient excess video at their tail and head respectively to cover the transition duration.  No prompt.

If the default it set to FREEZE, the time line should not be shortened.  Or set it to ASK ME and you should be prompted if the above conditions are met.

Share this post


Link to post
Share on other sites

Hi

"When I make a fade transition between two clips the whole timeline shortens a bit "

ignoring for the moment whether the prompt window comes  up or not, there are two options....(e.g. with Crossfade)

  1. When a transition between clips is set as Yes, Move the clip for an overlapping transition", The clips are in effect overlapped. The timeline consequently is shortened by the duration of the transition and the transition is divided between the clips
  2. When the prompt selected is No, Freeze frames at the start/end of transition, Clip 1 fade out over the first frame of clip 2. Clip 2 is  fades in over the last frame of clip 1. The overall length of the timeline does not change.

What length are your untrimmed clips and what duration have you set for the transition between them?

Assuming clips and transition durations are OK then I would have thought that the tick box would only be active for THAT editing session.

Nat

 

Share this post


Link to post
Share on other sites

Thanks for answering in detail. My last post said that I changed the suggested settings, the ones you are both talking about but it does not seem to be having any effect.

https://ibb.co/bOizWK

With this setting in place, the transitions still shift and overlap. Even uninstalling and reinstalling the software does not change the behaviour.

Share this post


Link to post
Share on other sites

Hi

Under Tools/Options/Editing/Video clip transitioning

Click the down arrow and select Ask me

Your image shows you have Generate freeze frames as your default. If this is the case then the option window won't come up.

Nat

Share this post


Link to post
Share on other sites
On 8/8/2018 at 8:33 AM, Nationalsolo said:

Hi

Under Tools/Options/Editing/Video clip transitioning

Click the down arrow and select Ask me

Your image shows you have Generate freeze frames as your default. If this is the case then the option window won't come up.

Nat

Sorry I should have mentioned that I have already tried that setting (Ask me). It changes nothing, the timeline continues to overlap depending on the duration I specify. Nothing I do to the options or program including reinstallation will get it to retrigger the ask me so I can stop it overlapping.

Share this post


Link to post
Share on other sites

Tested two clips with fade transition between them.  If OPTIONS is set to "freeze" - no overlap.  If set to "ask" the query box appears.  Choose "freeze - no overlap.

Share your project and someone will test it.  Here's how...

1.  With the project on the timeline, click the FILE menu.  Then SAVE PORTABLE PROJECT AS.  Save to any convenient folder.

2.  Open the folder that contains the saved files and ZIP them all.

3.  Upload the zip file to DropBox, Google Drive, MS OneDrive or the like.  It's free.

4.  Make the uploaded file public (share it) and copy the shared link.

5.  Paste the link into this forum.

Share this post


Link to post
Share on other sites

Hi all

Perhaps there is a bug here......Check this out please...

  • Set transition Options to Ask me
  • Put a single clip on the timeline
  • Split clip with cursor scissors prompt
  • Add a  xfade transition (or any other for that matter)

There was NO prompt and no transition appeared although timeline showed one there. Clip was 40 seconds and transition set to 2 seconds so there was adequate duration etc..

This works as it should with separate clips and the feature toggles between the three options set in Tools.

So..Is Robkblue  having a similar issue with SPLIT clips caused some odd combination of settings that always overlaps clips without any prompt even though the Option  is set to Ask me?  Whereas I see no transition when I do this.

Nat

.

Share this post


Link to post
Share on other sites

Laid down a 55 second AVI clip, split it and tested FADE and FADE THROUGH WHITE.  The options setting was Ask Me.  (Repeated the test with a MOV clip.)

Though the timeline thumbnails seemed to indicate that the clip had been abridged, its content was unaffected and the transition was shown.

Share this post


Link to post
Share on other sites

Hi Borate

I just tested this again.......

  • Opened VP.
  • Confirmed Option transition prompt was Ask Me.
  • Loaded a 37 seconds clip to timeline by drag and drop.
  • Moved cursor to the centre of the clip and used the scissors icon to split it. Moved cursor away from the X
  • Clicked the X and set duration to 4 seconds
  • Clicked crossfade
  • There was NO PROMPT (i.e. No Ask me box for transition choice)
  • Timeline showed what seemed to be a transition of 4 seconds across the split but timeline showed the same overall length.
  • There was no transition evident when the clip was played. ***

EDITED  Originally I thought the transition did not work when a clip was SPLIT.

The test seems to show that some transitions do not APPEAR to work but in fact they do. (The explanation is in Borate's post below) Both sides of a split clip will be pretty identical so a crossfade for example will in effect show nothing (or almost nothing) as you are dissolving from one clip to an almost identical one.

Nat

 

Edited by Nationalsolo
Interpretation

Share this post


Link to post
Share on other sites

Did precisely the same, Nat, but used the X (not FX) icon. ^_^

Because reveals, fades, circles, etc. add nothing, some won't be seen if applied where there is no video differential at the split point.  But FADE THROUGH WHITE, SHATTER and BLINDS each add an element.  CROSSFADE and FADE here both displayed a slight dip during the trans, confirming that they too are functional.

Share this post


Link to post
Share on other sites

Hi

 "Bug" explained...Thanks......and Oh, YES  Sorry  (Meant...X   😯  (Just edited my post above)  and Yes again, you're right with regards no difference between the clips in a Split and some transitions not appearing to work . That explains it nicely so not a bug.   Hadn't thought of that!  Still, the  Ask Me prompt doesn't appear when the Option is set so that wouldn't appear to be working ...........(or am I making another faux pas..:blink: )..

Nat

 

Share this post


Link to post
Share on other sites

It shouldn't appear, unless the FROM or TO side of the split has insufficient end or start 'slop' to cover the transition's length requirement.  (8/1 post, above.)

In this case the split is in the middle of the clip - with ample video on each side.

Share this post


Link to post
Share on other sites

With all that's been tested here, my issues are still in effect. I add 2 separate clips of 10 seconds in length, I set the editing option to either ASK ME or GENERATE FREEZE FRAMES and when I add a 4 second fade between the two clips, they immediately overlap so that the entire timeline length that started out as 20 seconds, reduces to 16 seconds. The only way I can get the fade to work without overlap is to leave a small gap between the clips then do a separate fade out and fade in for each clip. Another thing I noticed while doing this is that if I fade out the clip for 4 seconds, it has gone completely black after only 1.5 seconds. If the fade out changes to 6 seconds or 2 seconds, the fade out happens proportionately early i.e. in a 2 second fade, it's gone black in less than 1 seconds.

I also installed VideoPad on another freshly installed computer and got the same behaviour for both a new project and this one that I saved as a portable project.


 

Share this post


Link to post
Share on other sites
On 9/2/2018 at 9:42 PM, robkblue said:

I add 2 separate clips of 10 seconds in length, I set the editing option to either ASK ME or GENERATE FREEZE FRAMES and when I add a 4 second fade between the two clips, they immediately overlap so that the entire timeline length that started out as 20 seconds, reduces to 16 seconds.

Testing with version 6.20, that behavior is seen intermittently, especially when changing the fade duration at the bottom-right of the transition effects window.  The easy workaround has been to set the default transition time in OPTIONS|EDITING tab to the desired length prior to applying the trans, or to drag the edges of the transition bar on the timeline to the desired length.  If an overlap does occur, hit <ctrl-Z> immediately, to backtrack.  What version are you using?

Quote

Another thing I noticed while doing this is that if I fade out the clip for 4 seconds, it has gone completely black after only 1.5 seconds. If the fade out changes to 6 seconds or 2 seconds, the fade out happens proportionately early i.e. in a 2 second fade, it's gone black in less than 1 seconds.

That isn't seen here.

Share this post


Link to post
Share on other sites

Hey thanks Borate, both of your suggestions work even though the overlap still happens when manually changing the fade duration in the bottom right of the effects window.

Share this post


Link to post
Share on other sites
2 minutes ago, borate said:

That issue should be resolved in the next version - soon to be released.

Excellent, thanks again.

Share this post


Link to post
Share on other sites

Hi,

I have tested this behavior and in fact it works as intended.

VideoPad will automatically generates transitions with overlapped video if there is no need to shift video frames (clips) on the timeline.

When the clips has enough heading or tailing materiel (sections that outside Start/End  point), VideoPad will automatically expand the Start and End points to produce the transition without ask for the option.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×