Jump to content
luchelibre

Normalizing multiple clips to each other

Recommended Posts

After searching other threads about normalizing in videopad, none deal with this issue.

I have two audio tracks (first is pre-normalized outro music, 2nd is raw voiceover) in one project synced to video. Because of signalling claps used during voiceover that are removed in editing, normalizing before editing is pointless.

I need to be able to normalize a specific edited audio track across multiple clips. I haven't been able to find out how to export as one file a specific audio track that has multiple clips, so I can't use that kind of workaround. Finally, I can't normalize the rendered video because the outro music is already at 0db, nothing would be changed. Attempting to use audacity to highlight and normalize the voiceover screws up the outro music fade in (which is behind some of the voiceover).

So what am I missing here? What's my way forward?

Share this post


Link to post
Share on other sites

Back up the entire project first, just in case.

Individual clips can be modified by clicking their FX button and choosing the NORMALIZE or AMPLIFY tool.

Multiple clips might be handled by selecting (highlighting) them, pressing <ctrl-c> to copy, then clicking the + sign next to the sequence tab, to open a blank sequence.

In that new sequence, press <ctrl-v>, to paste.  Now export the sequence as an Mp4.

Bring the Mp4 back into VP on an overlay (higher numbered) track, lining up the clips it contains with the originals, which can be deleted or muted.

The new audio is now a single clip that can be NORMALIZED in VP or run through Wavepad prior to VP import.

When done, unlink video from audio and delete any confusing blank video.  To avoid messing up other tracks, lock them.

If you make a mistake, immediately press <ctrl-Z> to undo.

Share this post


Link to post
Share on other sites

HI

Once you have edited all your clips.....

  • Select them all.  (Click the first audio clip with SHIFT pressed and then keeping it pressed click the last audio clip) The sound tracks will all turn from blue to grey with the VP dark version showing they are all selected. You won't need to group them.
  • Click the Audio tab on the top tool bar (not the FX button on the sequence line) and then the Audio effects down button. This now brings up a  list of the audio effects.
  • Select the Normalize option. You should now see a message box asking if you want to apply the normalize effect to ALL the selected clips or just Apply it to one or Cancel..
  • Click the Apply to All button.

Nat

Share this post


Link to post
Share on other sites

Suspect a little bug, as Nat's good advice didn't work in several tests here with NORMALIZE.  Despite specifying "apply to all clips" only a single clip was affected

The procedure did succeed, however, with the FLANGER and ECHO effects.

Share this post


Link to post
Share on other sites

HI

Confirmed.......Yes. :mellow: Looks like a bug! 

Even though you group the clips, and get the prompt to apply the effect to all clips, only the clip with the focus gets the effect applied to it. (The light grey one.) I didn't test that the normalize effect (reduced to 1%) had actually been applied, just accepted it had when the message came up. Even if you group the clips using the Video track, when all the audio clips are evenly greyed out, selecting Normalize will show the message for the number of clips selected but still only applies it to one clip.!

Despite the message it seems you can only work on a single clip with this effect. As Borate says Echo and Flanger work for all the selected clips

A rather long winded way around this might be to.....

  • Save your project as a .vpj file.
  • Create a sequence of your edited work.
  • Save the sequence audio. This will place a copy of the audio  in the default file setup in Options.
  • Reload your project You will now have your edited work at the point where you saved it.
  • Mute the audio track by clicking the microphone icon at the left end of Audio Track 1. (Plus any others) Your project will now play silently.
  • Load the saved sequence audio track from the default save location and drop it onto the next free Audio Track and drag it to the start point.
  • If necessary un-mute the original project audio Audio Track(s)  and match the new track up  by playing the sequence. You could also do this visually by zooming in and matching any peaks.
  • Once they match re-mute the original Audio Tracks.
  • As the new Audio Track will be a single file it can be normalized.

OK..It's a bit involved but should work.

Nat

 

Share this post


Link to post
Share on other sites

Certainly these workarounds aren't great and I hope you're able to figure out a way to normalize multiple clips to each other (emphasis on "to each other," just doing a batch normalize like echo and flanger operations will not produce the desired result. I presumed this was why the program doesn't do it.)

What I've decided to do in the meantime is quieten the outro music track to about the same level of the voice track, export, new sequence, import rendered file, normalize audio, then finally re-export losslessly, which goes quickly.

This introduces some fiddly problems and I really don't like the wait of importing twice, but I'll live.

Share this post


Link to post
Share on other sites
21 hours ago, luchelibre said:

I haven't been able to find out how to export as one file a specific audio track that has multiple clips, so I can't use that kind of workaround

To do this, on the audio track you want to export, click the third button from the left (the one with 3 little people on it, between the lock and speaker icons) to toggle "Solo" status, meaning only this track will be played / exported. Then, in the clip bin, you can go to the "Sequences" tab, right-click the relevant sequence, and click "Save Sequence Audio as New File". VideoPad will import this generated file as a new audio clip. 

Note that the "Solo" status is just a toggle, so you can click it again to get all the other tracks playing again.

You won't have to match up any peaks or anything, just drop the new clip onto a new track at the start (the clip perfectly matches the length of the whole sequence), and it doesn't bother exporting or importing any video content. Because it exports the audio to a .wav file, it also imports back into VideoPad much quicker than a compressed file format.

Share this post


Link to post
Share on other sites

Nice approach NADWW describes!  Dissecting it further, individual (unlinked) audio clips can be dragged down to a new sequence, which would then be handled as above.  The NORMALIZE effect would then be applied, and affect only - but all - of the selected clips.

Share this post


Link to post
Share on other sites

Holy moly, that I never saw the 'save sequence audio' option before now is embarrassing. I don't make multiple sequences and so never used that tab. Thank you very much notadev! Saves me a lot of hassle.

Share this post


Link to post
Share on other sites

Hi

I mentioned "Save Sequence Audio" ...step 3 in my workaround above  -_-  ..but......Where is the tab with the "3 little men" please?  I can only see  Minus/Speaker/ Lock  at the left end of the audio track although Mute/Solo/Lock/Collapse  come up on a menu when the area is right clicked. (VP Professional version 6.0 Licensed.)

Nat

 

 

Share this post


Link to post
Share on other sites

Hi

OK.  Found it!  "Enable track solo.."   If anyone else can't find it, it only appears when you have more than 1audio track.  Oooh!  It's so logical!....a single track IS solo and doesn't need to show the button.:rolleyes: 

Nat

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×