Jump to content
willpower

Multithreaded rendering

Recommended Posts

I recently upgraded from version 3.7 or so to version 5.20, and video export seems unusually slow to me. I noticed videopad.exe is using only 14% or so of my CPU, and x264enc7.exe is using 0-1%. Is there an option somewhere I need to check to enable multithreaded rendering?

I've searched these forums a bit on the topic of CPU use, and everyone seems to have different answers. For reference, I've got an excellent 8-core PC with 16 GB of RAM and I'm currently exporting an 8 minute video. Resolution is 1920x1080, 60FPS. I have lossless export set to auto detect, and I'm using the H264 codec with quality set to 16.

The video itself has a few transitions and effects, but nothing unusual for my videos. The render time however is unusual... I started exporting an hour ago and it's only 20% done! This is render time I'd expect from one of my 20+ minute videos, in version 3.7. Any tips for speeding things up, and putting more of my CPU to work?

Share this post


Link to post
Share on other sites

Two things to try...

Install the latest version.  What graphics card, and is the driver up to date?

Under OPTIONS|EDITING tab, toggle hardware acceleration to its other state, and see if that makes a difference.

If no joy, with your project loaded click FILE|SAVE AS PORTABLE PROJECT.

Upload the results (all files, or zip into a single file) to DropBox, Google Drive, MS OneDrive or the like.

Make the link public and post it here.  Someone will check it out.

Share this post


Link to post
Share on other sites
19 hours ago, willpower said:

I noticed videopad.exe is using only 14% or so of my CPU, and x264enc7.exe is using 0-1%. Is there an option somewhere I need to check to enable multithreaded rendering?

Is the rest of your CPU was idle? If not which process was occupying the CPU?

Share this post


Link to post
Share on other sites

I let the render finish yesterday and it turned out okay. The total time was about 4.5 hours.

Had some time to play around with it this morning and do some more tests. I noticed yesterday that the second half of the video exported a LOT faster, and I realized that I had some positioning and scaling effects on the first half that I had forgotten about. So that part's my bad- I guess this particular video did have a little more going on than my usual videos. I do want to try to get to the bottom of this though- relatively simple position/scaling effects don't feel like they should cause Videopad to take 1 hour to render 1 minute of footage.

20 hours ago, borate said:

Install the latest version.

Do I need to purchase again to update to the latest version? If not, how do I do this?

20 hours ago, borate said:

What graphics card, and is the driver up to date?

I have two: An older Radeon HD 7900 series, and a much newer Radeon RX 480. The older 7900 is still a powerful card, but the newer RX 480 has significantly more bus width on my system. Drivers are up to date.

20 hours ago, borate said:

Under OPTIONS|EDITING tab, toggle hardware acceleration to its other state, and see if that makes a difference.

Thank you! This made a HUGE difference, despite having two very good graphics cards. I had hardware acceleration turned on for the 4.5 hour render. This morning I tried again with it unchecked, and it was significantly faster: Only 1.5 hours, and it (mostly) uses 100% of my CPU! Much better, although it still slows down considerably during the first half of the video, where the position/scale effects are. During that section, it goes down to about 20% CPU usage. Still, that's a huge improvement. I'm going to try to avoid effects when I can in the future, to speed things up.

2 hours ago, c_major said:

Is the rest of your CPU was idle? If not which process was occupying the CPU?

Yes, the rest of the CPU was idle during this time. As I describe above, even with hardware acceleration turned off, the CPU is mostly idle and rendering becomes slow when rendering parts of the video that use any sort of effects.

Share this post


Link to post
Share on other sites

Here's the stated NCH policy on upgrades...

"Your registration and activation code will work on any fix or new version of the software released within 3 months from the date of purchase. After that you are always entitled to discounted upgrade pricing."

The latest version can be downloaded here.

Developers continually strive to improve rendering/export efficiency.  One day they may even come up with a 64bit VP incarnation.

Share this post


Link to post
Share on other sites
On 12/23/2017 at 2:41 AM, willpower said:

I had hardware acceleration turned on for the 4.5 hour render. This morning I tried again with it unchecked, and it was significantly faster: Only 1.5 hours, and it (mostly) uses 100% of my CPU! 

That sounds like a problem. Could you please share the .vpj file (no media files needed) via a file hosting service (e.g. Google Drive, Drop Box etc.) so we can investigate?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×