Jump to content

"Fade out" function for audio stopped working


Fuod

Recommended Posts

So I use VideoPad Video Editor to make some small clips.

 

I put in some video clips and add some music to it.

 

I usually fade the clips in and out between 2 of those, and I do the same with music.

 

But I have just started to get this problem: It seems like I can fade audio in and out, but though it shows as normal, it does not fade out anymore.

I have tried different lenghts, and restarting the program, it doesn't work.

 

If anyone have a solution, or maybe just an idea on what to do about this issue, don't hessitate to let me know.

 

Thanks in advance.

 

- Benjamin

Link to post
Share on other sites

Hi

 

Follow Borate's advice---Load the project and then clear unused cache files. One thing to note is that the TRANSITION option of FADE does not act on the Audio track 1. Clip1 will fade out and Clip 2 will fade in but the associated audio is not affected.( I think this is an oversight as if the visuals fade out I would expect the audio to do the same- but that is just my opinion).

 

However, you now have to select and right click each audio clip and choose Fade out or Fade in as appropriate and make their duration equal to half of your transition time.

In version 4.48 this adds a black line to the centre of each audio Clip on Audio Track 1 showing the change in sound levels....

 

3ef07f64ef11f370559bea6d0434ac7a.png

 

 

The audio should now fade out and in with the visuals.

 

Is this the action that is NOT working with you?

 

Nat

Link to post
Share on other sites

I've tried both options as well as re-installing to make sure the version were right.

 

I usually fade each music file up and down manually like you explain Nationalsolo, and I get the black line in the middel of the track which shows that it SHOULD fade up in the beginning and fade it down at the end, but all the tracks I have will fade up, but not down though it seems to look like it.

I hoped that by reinstalling it, it would work, even though I wouldn't know what caused it to happen.

 

EDIT:

Okay so I found the error, but not a fix for this.

If I right click the track and choose "Change Clip Speed", then change the speed % to 110 or 120, and uncheck "Keep audio pitch unchanged", it will be able to fade the track in, but not fade out.

I have tried this in a new project with different fade times, and in different parts of the track, and this error seems to do persist.

 

Is this a bug I should report or is there another explanation for this?

Link to post
Share on other sites

Hi

 

If VP is working normally and you have multiple audio tracks you should be able to simply select any of the tracks (left click) and choose Fade-in from the right click menu and then enter a duration value. The black volume line along the audio clip should then appear with an upward Fade-in slope at its left hand end.

Re-selecting the same audio clip one more and choosing Fade-out from the menu followed by a second duration should produce another volume slope, this time at its right hand end of the audio clip.

The audio should play with both Fade-in and Fade-out. (Does here)

 

You should also be able to repeat this procedure for any other or all audio clips on any other track including the main track overlapping or not.

This procedure works OK here with 4.48 and all the clips play with the indicated fades.

 

Changing the clip speed up however, does prevent a Fade out as you mention. It also seems to happen whether or not the retain pitch box is checked or whether the fade is added before or after the speed change. I would suggest that the fade effect is actually cut off as the clip is shortened with respect to the sound track, video frames being removed to make it run faster.

 

I checked this out with an 8 second clip having a 7 second fade out. Changing the speed to 110, the Fade out played OK but ended before the end of the clip. i.e. increasing the clip speed truncated the fade out. With a short 2-3 second fade out it is ALL cut off if the clip speed is increased significantly.The volume line is then incorrect as it doesn't alter...BUG

 

Slowing the speed down also produces a similar problem as the fade-out starts much earlier (probably in its original point) and finishes before the clip actually ends, video frames being added throughout the clip to make it run slower.

 

I am pretty sure this is a bug. NCH may come in on this if they test.

 

Nat

Link to post
Share on other sites

Thanks for testing this out on your end too Nationalsolo, at least I now know that it is not just a problem for me.

 

I'll try some different approaches to get this to work on a satisfying level until this issue has been resolved.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...