Jump to content
Vellora

How to remove 1-second blank frame at the end of exported videos?

Recommended Posts

Alright. First thing first, I've read the other 2 topics here that also talked about blank frame being added automatically and unwantedly by VP to exported videos, but they didn't really described my situation and I couldn't find any solution to my problem over there.

 

So now I'm creating a new topic and I'm going to post everything you need to know to replicate the problem I have and hopefully you could advise me on how to disable this unwanted thing VP is doing.

 

First, the original video file:

https://www.sendspace.com/file/45ggyu

 

Of course, this is just a dummy video I created for this purpose.

My intention was to remove the audio from this MP4 video file, and every time I exported the finished video, VP would automatically add a 1-second blank frame at the end of the video, and I certainly did NOT tell it to do so.

 

The VP version I'm using is the latest one: 4.48

Below are the detailed steps I took to do this...

  1. Click "Open" button at the top bar.
  2. Add "Test (original - with audio).mp4" into VP.
  3. Drag the video file from the "Video Files (1)" tab at top-left and drop it on "Video Track 1" bar at the bottom.
  4. Right-click on "Audio Track 1" bar and click "Unlink from Video".
  5. Right-click again on the same place and click "Delete".
  6. Click the down arrow of the "Export Video File" button at top bar and click "Video File".
  7. Rename the file to "Test (edited - withOUT audio).mp4".
  8. Click "Detect..." and click "OK".
  9. At this point the settings on this "Export Video" window are...

    1. Preset: Custom
    2. File Format: .mp4
    3. Resolution: 720 x 480
    4. Maximum Frame Rate: 29.948
    5. Constant frame rate NOT ticked

[*]Click "Encoder Options..." button and the settings are...

  1. Video Compressor: MPEG4
  2. Custom quality selected
  3. Quality: 3.0
  4. Audio Compressor: AAC (but not selectable)
  5. Average bitrate: 128

[*]Click "OK" and click "Create".

[*]An "Aspect Ratio Conflict" window would pop up. Click "Crop Edges".

At the end of all this, this video file was created:

https://www.sendspace.com/file/ivip33

 

Notice the 1-second blank frame added to the end of the video. In the steps above there is no such instruction leading to the addition of that blank frame. VP did it itself.

Why? And most importantly, how to stop VP from doing that?!

 

Any advice is highly appreciated.

Thank you very much.

 

P.S.

I forgot to mention, the video player I'm using is MPC-HC (Nightly) v1.7.10.252 with Playback set to "Repeat forever" so that MPC would just loop the video.

 

P.P.S.

By the way, why is there such a big difference between the file sizes of the 2 files (original and edited)?

Share this post


Link to post
Share on other sites

HI

 

Yes, there does seem to be a short blank section at the end of your exported clip, but not sure why. It's there even if you don't edit out the sound. NCH may comment if they can download your clip and have a look at it.

The blank section does not occur when played with VP however.

 

The difference in file size you mention is due to the compression settings and quality settings you have used.

My output Mpeg4 file from your clip (2.3Mb) was 183K and outputting with the sound made very little difference.

However your clip was an H264 Mpeg4 clip and so exporting with these settings and using the highest encoder quality produced a file of 8.39 Mb! Quite a difference. It's Horses for Courses.

The encoder quality can make a huge difference to the file size although the image may not seem to change a lot

 

Checked with some of my short Mpeg4 clips shot on a Toshiba camera; there were no blank end on any of these even after a second export. :mellow:

=========================

Just exported your clip as image files just to see what frames there were at the end of it...There are 161 in all and No. 161 is a black frame.

So I thought it would disappear if I recreated the clip excluding the black frame...

I used 160 of the images to recreate the original clip. This seemed to play OK but when re- exported this 160 image clip as images I ffound I got 161 again with the last image black! (although I used 160!)

As a check re this behavior I re-created the clip with 29 images and again, re-exported it as images......black frame added (clip back to 30 images) Weird!

Seems VP adds a frame....Must be a reason for this but I don't think it is connected to your 1 second problem.

 

Nat

Share this post


Link to post
Share on other sites

@borate

Yes, now that I think about it Constant Frame Rate should be ticked. It's better that way.

 

@Nationalsolo

Hi. So...... after all the testing what do you think? Is it a bug? If it is then I REALLY don't understand why it's not fixed yet since it appears to have existed for years already! The other topics about blank frame being added go way back. I very much hope to get some solution for this because I really like software by NCH.

Share this post


Link to post
Share on other sites

Hi Vellora,

 

Have you tried match the output framerate with the input video? You can use the "Detect" button in the export dialog to automatically do so.

Share this post


Link to post
Share on other sites

Hi Vellora,

 

Have you tried match the output framerate with the input video? You can use the "Detect" button in the export dialog to automatically do so.

Hi c_major.

 

As stated in my first post, I've done that. Didn't work.

Share this post


Link to post
Share on other sites

My bad for the late reply but hey..... I've retried it at 29.97 [TV NTSC] and it worked!!

Now at least we have an idea as to WHY the blank frame happened! :rolleyes:

 

I tried another video of mine and the "Detect..." button told me the frame rate was 30.016, and I went ahead with it and there was the 1-second blank frame.

But I exported again at 30fps and the blank frame disappeared.

 

I guess NCH should fix VP's auto detect feature. :mellow:

 

But anyway I'd like to thank all of you very much!! :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...