Jump to content
marcussantiago

Don't upgrade past v. 5.77 if you use num pad hotkeys coz they won't work

Recommended Posts

I use El Capitan on a MacBook Pro with the larger Mac wired keyboard (the one with the full number pad). This is specifically to use the number pad as hotkeys.

 

Note that if you upgrade to any version later than 5.77, these number pad hot keys will stop working. Your only solution would seem to be to downgrade back to 5.77 or earlier.

 

Also, surprisingly, punching your keyboard till your hands are bloody, does not rectify the issue.

 

A friendly reminder to always keep backup installer files handy.

Share this post


Link to post
Share on other sites

One thing that is not clear here is if you set the hotkeys after you updated the software version; and when you were assigning the hotkeys did you see the option to select those keys from the keyboard?

For further assistance on this matter you may want to create a support request at NCH software's support site.

Share this post


Link to post
Share on other sites

After installing the updated software, my hotkeys were no longer there in the settings, so I had to re-do them.

 

I just re-tried this and the same thing happened again, so I'm explaining it in detail.

 

when you were assigning the hotkeys did you see the option to select those keys from the keyboard?

 

I don't understand. I assigned the hotkeys the same way I've always assigned them in all the years I've used the PC version of this software, with no problems. I went to Preferences > Hot-Keys and it had the default hot-keys. I selected and deleted them, and clicked "Add". The box comes up that says "Add New Hot-Keys" and Click "Change..." to assign key. I click the button and a new box comes up that says "press a key or combination." I press the numpad 5 to assign it to play, and it accepts it. Go through the process for all my shortcuts.

 

But once I load a file and try to play, pressing the numpad key shortcuts doesn't work. However, pressing "5" on the main keyboard row (the numbers above all the alphabets, NOT on the numpad) activates the shortcut. With Word or Text edit open, the numpad only inserts the number into the text. This is a real problem as I've been using numpad shortcuts on Express Scribe for something like 8 years, I even purchased this overpriced Apple full keyboard so I could continue using numpad shortcuts when I switched to a Mac (I'm also trying to launch a career in art, so the Mac was kind of essential).

 

What's strange is that nowhere else in the Mac OS is there any distinction between the top row number keys and the numpad number keys, they're treated as the same characters everywhere... except in Scribe. I've Googled everything I can and there's no equivalent "num pad lock" or similar for Mac that I can find.

 

For further assistance on this matter you may want to create a support request at NCH software's support site.

 

I'm not sure my warranty covers this, I purchased Express Scribe with some kind of discount. But I'll try. In the meantime if anyone figures this out (or a new version comes out that actually works) please update and let us all know.

 

Thanks for reading my ranting.

Share this post


Link to post
Share on other sites

Update: I checked the support page and the only relevant thing I can find is this sentence:

 

The system-wide hot-keys are not working on my Mac

 

Be sure to press the "fn" key when using your hotkeys.

 

 

 

Which is strange because 1) I've never, ever had to do that in years of using Express Scribe for Mac and 2) this would be so cumbersome that the primary advantage of using Express Scribe for transcription would be nullified. I might as well use VLC and use the built-in Mac media player keys for iTunes instead, it would be the same thing and just as inconvenient. I mean the whole point is that you should be able to assign your own shortcut keys.

Share this post


Link to post
Share on other sites
On 2/16/2016 at 0:26 AM, marcussantiago said:

I mean the whole point is that you should be able to assign your own shortcut keys.

Seriously.

Hey, NCH, any chance you're going to fix this? I rely on the num pad for playback, and taking the option from me really stinks.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...