Jump to content
Sign in to follow this  
cameraoperator1

How can I zoom without stretching a non-4:3 or 16:9 picture?

Recommended Posts

I'm using the free v4.10 and I'm making a video consisting of photos. I want to use zoom on a picture that does not have an aspect ratio of 4:3 or 16:9, but when I try, and I click on "None" for "Force aspect ratio:", it stretches the picture to fit one of the two ratios. The picture I'm using is in a portrait orientation and I want to zoom/pan from left to right while the whole picture from top to bottom is in the shot. I realize that the video will be narrow and will have thick black bars on both sides, but that's what I'm going for. Is there a way to zoom on a picture that's not 4:3 or 16:9 without distortion? I was able to do this with the older VideoPad v2.41. Thanks for any help.

Share this post


Link to post
Share on other sites

HI

 

I don't think this works correctly either :( at least not in the way I would expect which was ,as you say effective in the earlier version..

Zooming with anything other than 16:9 results in a deformed or stretched image. Of course I am probably missing something here........ :wacko:...............?

 

A moving Crop does not pan....but a movement behind a crop might...

So try this (or a variation of it)

 

Click the FX button on the thumbnail and add the Position effect.

Set red cursor to start and make horizontal offset 12 (A smaller amount might be better but this is for a trial)

Click green cross to set keyframe.

Slide cursor to end of clip and set horizontal offset to -12.

Click Apply.

The image should now scroll.

Click FX and add the crop effect.

Move the red cursor line left and right to set the left and right edges of the image to the corresponding edges of the crop

Click apply. As the offsets chosen are the same the crop will be central.

 

The image should now pan keeping the AR you set. Obviously you will need to experiment with the offset values as your image is already narrow being portrait orientated.

 

Nat

Share this post


Link to post
Share on other sites

HI

Further to this......

Perhaps NCH could check this please....

 

A portrait image will correctly be fitted top to bottom of the frame.

In the preview window of the Scale effect you can set the first key frame as 100% on both axes.(i.e Leave it alone but set a keyframe)

You can then go to the last frame of the clip with the cursor and set the scale on each axis to 300%

 

The image in the effects preview window correctly Zooms in on both axes.

 

Click Apply and preview the sequence in the normal way and you see that the image only scales in the horizontal axis and consequently deforms.

The program to fit the image to the height of the screen still appears to remain in force although the scale effect should enlarge it in height to 300%. This means that the image becomes stretched horizontally.

It should "zoom" in like the preview seen in the Effects window.

 

I think this is the cause of the problem outlined by the original post at the top.

 

Nat

Share this post


Link to post
Share on other sites

Hi,

 

Zoom effect is designed to use the image in the rectangle to fill up your output frame - what ever aspect ratio it is.

 

The output frame is the preview and the exported result. They can be different though e.g. preview in 16:9 and export at 4:3. In your case the preview AR is set to 16:9 therefore the image will be stretched unless you have a 16:9 zoom rectangle.

 

In order not to stretch the image, the zooming rectangle must have the same aspect ratio as the output (preview and export). You can change the preview dimensions in Option->Display dialog. Manually type in width and height so you can have any AR you want. You can also specify width and height when you export.

 

Best regards,

Share this post


Link to post
Share on other sites

c_major,

The problem with what you suggested is that while it solves my problem with the one portrait oriented photo, I also have landscape oriented photos in my video that I also want to zoom in a similar fashion, but after I changed the preview dimensions I ended up with the same problem with the landscapes as I had with my portrait oriented photo.

I think I came up with a complicated solution using Crop, Zoom and Position. It was so much easier to do in the earlier version of VideoPad, I don't know why they messed up that feature.

Nat, I just tried your suggestion and it worked, but if you want to zoom in while panning, I think you would have to add the zoom effect to the other two effects. Seems like a lot of dicking around for a simple maneuver.

Thanks for all your efforts. I hope NCH improves on this feature, soon.

cam

Share this post


Link to post
Share on other sites

Hi Borate

 

You're right - with 4:3 and 16:9 which you tried it work OK. But I used the default "None" for the AR.

However, I found my mistake and it's when "None" is selected or left as the default. It's an inconsistancy in the behaviour of the green crosses. In some effects like Zoom, when "None" is selected or the default is taken for AR, just clicking the top cross sets all the lines with a keyframe marker at the values shown irrespective of the AR setting, but when doing this for Scale it just sets the top marker if "None" is selected. That's why there was a distortion; the 100% changed to 300% all the way along for one of the axes when I scaled up the end of the clip. I hadn't noticed either that the blue line moved up horizontally for that axis..Doh! :wacko:

I just clicked the top cross as usual as I force 16:9 normally and that sets all the lines in an effect at the values shown.

Perhaps there ought to be some consistancy across the board..

 

Nat

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...