Jump to content
Sign in to follow this  
tallahasseefirstsda

Need live stream available when program starts

Recommended Posts

Running BroadWave on unattended Windows 2003 server. I have the option set to start BroadWave when computer restarts. The problem that I am having is that the stream from the sound card is not available from the internet unless I remote into the machine, access BroadWave from the systray, click the live stream icon (which shows the sound card configured as default in), then click ok. How do you configure Broadwave to automatically make the Live Stream connection available to the internet upon program startup? I don't see any configuration options or command line parameters for the services published anywhere.

Thanks for any recommendations.

Share this post


Link to post
Share on other sites

Select the Broadwave menu item, then Settings. On the General Tab, there's a tick-box "Run when computer starts" and a drop-down to select how. I have it set as "Start before logon...."

 

If that doesn't work, then you may have to have the server log in automatically upon boot (see Microsoft knowledgebase article 324737). I do that on XP, and set a short screensaver timeout which requires a password to unlock, so the PC is protected except for a few minutes after boot. My PC runs headless anyway, and I VNC into it.

Share this post


Link to post
Share on other sites

Select the Broadwave menu item, then Settings. On the General Tab, there's a tick-box "Run when computer starts" and a drop-down to select how. I have it set as "Start before logon...."

 

If that doesn't work, then you may have to have the server log in automatically upon boot (see Microsoft knowledgebase article 324737). I do that on XP, and set a short screensaver timeout which requires a password to unlock, so the PC is protected except for a few minutes after boot. My PC runs headless anyway, and I VNC into it.

 

Thanks for the suggestion, but my problem isn't with the program starting (I think). It's that the Live Stream isn't available until I manually click on some stuff. I was hoping that there was some way during program launch to tell it to start listening for Live Stream requests from the internet.

 

thanks.

Share this post


Link to post
Share on other sites

Hi,

 

I'm a bit unclear as to the problem. If Broadwave starts running automatically, it should be able to accept incoming requests as soon as everything is in place - e.g. once the network connections are up and firewall permitting connections and so on. You can check this by requesting one of the saved sample audio files, to check whether the problem is Broadwave accepting any streams.

 

If, on the other hand the problem is that the default live stream is connectable but silent when you first start, and you need to "click stuff" with the audio config of the soundcard or Windows, then you've hit what can be a common problem due to the soundcard drivers. I'm having this problem on a test on a new PC with Windows 7, and I can't send sound to Stereo Mix until I go via the audio settings.

 

So, please describe exactly which of the two your problem actually is, and also tell me the exact steps you take to get it working, including the type of soundcard, and I'll try to offer some more detail if I can.

Share this post


Link to post
Share on other sites

While trying to document the problem I figured out what needed to be done to correct the issue. The Broadwave service was set to manual instead of automatic. When I was trying to solve the problem earlier, if I could not connect to the stream I would remote desktop into the server and do all of stuff as listed in the previous email before attempting to connect to the stream again. If I would have attempted to connect first before doing anything else after the logon it would have been more obvious this was a program startup issue and not a live stream availability problem when the program launched. Thanks for your assistance.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...