Jump to content
Sign in to follow this  
jonasjar

Custom send method using thunderbird email client fails

Recommended Posts

Currently on 5.23 Im trying to use a "custom comman-line" send method, consisting of a call to thunderbird email client (3.1.7). The call works well to begin with, the send mail form comes up nicely with the sound file attached. But when trying to send the mail I get error message: Cannot open temporary file C:\Users\jonas\AppData\Roaming\NCH Swift Sound\Express\Send\0-62 2011-01-31 100402.mp3 , Check your settings for "temporary folder". When I check that folder, thet mp3 file seem to be non-existent. Using windows vista sp2.

 

What could be wrong here? When I initally set it up yesterday, I also got this error. Then later it worked. Then today when i redo it, it appears to be broken again. So its like an intermittent problem somehow.

 

(I initially used the standard Email method, but didnt like the fact that I cant control the automatic contents of the resulting email, it looks machine-maid. Furthermore, this automatically formatted email format was repeatedly rejected by the hotmail/live mail servers and discarded as spam/junkmail, which wasnt so nice.)

 

Rgs, jonasjar

Share this post


Link to post
Share on other sites

Sorry, I forgot to supply the command line:

C:\Program Files\Mozilla Thunderbird\thunderbird.exe -compose attachment='"%filepath%"'

 

As I said earlier, the mp3 file doesnt seem to be in the temporary folder. I can see the .dau files that constitute the message, but no trace of

the corresponding mp3 file.

/Jonas

Share this post


Link to post
Share on other sites

C:\Program Files\Mozilla Thunderbird\thunderbird.exe -compose attachment='"%filepath%"'

 

As I said earlier, the mp3 file doesnt seem to be in the temporary folder. I can see the .dau files that constitute the message, but no trace of

the corresponding mp3 file.

I think the temporary file is deleted when the custom command exits, and thunderbird.exe is exiting as soon as the compose window is opened.

Share this post


Link to post
Share on other sites

Yes, that sound very likely. Seems like I would need to be able to call the sendmail program directly, not via the main thunderbird exe. Problem is thats the only call method I could find in a quick glance, in the online-mozilla help. Thanks for responding!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...