Jump to content
Sign in to follow this  
silverwatersask

embedded flash / does not work

Recommended Posts

hello,

 

my setup.

 

broadwave server

------

 

windows 7 box running broadwave server.....setup to run streaming audio via the line in on the sound card.

ip = 192.168.1.103

firewall open port 88

router port tcp 88 forwarded to 192.168.1.103

(still getting setup error BUT it works with media player)

 

client

------

 

windows vista

192.168.1.104

 

 

web page server

--------------

my own web page server(full control)

linux box

192.168.1.102

 

I use a dynamic dns server My link

 

 

---------------------------------------------------------

 

test one - i use the client computer to start listening to the server.

open internet explorer to url --- http://192.168.1.103:88/broadwave.asx?src=1&rate=1

which opens windows media player and I hear the stream.....great.

 

---------------------------------------------------------

 

test two ----want to use embedded flash player.

 

create web page with the code as shown in the "connect page"

here is the code (stored on the web page server)

<html>

<head>
<meta http-equiv="Content-Type"
content="text/html; charset=iso-8859-1">
<title>Flash audio test</title>

</head>

<body>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width=30 height=20>
<param name=movie value="http://192.168.1.103:88/player_mp3_maxi.swf" />
<param name=quality value=best />
<param name=FlashVars value="width=30&showslider=0&mp3=broadwavehigh.mp3?src=1" />
<embed src="http://192.168.1.103:88/player_mp3_maxi.swf" FlashVars="width=30&showslider=0&mp3=broadwavehigh.mp3?src=1" width=30 height=20 quality=best type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer" />
</object>


<p>VHF radio</p>
</body>
</html>

 

======================================

 

I get the play button but I get no audio at all.

 

This a local network test so I leave the ip adress to the local ip for the broadwave server.

 

I have seen other references to this question in this forum but have seen no solution....is this even possible with the "free" version?

 

Any advice is appreciated.

 

Thanks

 

Brian

Share this post


Link to post
Share on other sites

hi again,

 

I solved the mystery.

 

The code that you copy from the Broadwave server "connect" examples is not quite right.

 

 

This is the code as provide by Broadwave---example:

 

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width=30 height=20>
<param name=movie value="http://192.168.1.103:88/player_mp3_maxi.swf" />
<param name=quality value=best />
<param name=FlashVars value="width=30&showslider=0&mp3=broadwavehigh.mp3?src=1" />
<embed src="http://192.168.1.103:88/player_mp3_maxi.swf" FlashVars="width=30&showslider=0&mp3=broadwavehigh.mp3?src=1" width=30 height=20 quality=best type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer" />
</object>

 

 

The correct code needs to have the full path for the 2 times that mention "...broadwavehigh.mp3..."

 

Like this

 

...http://192.168.1.103:88/broadwavehigh.mp3... (2 places)

 

So a working web page is like this

 

<html>

<head>
<meta http-equiv="Content-Type"
content="text/html; charset=iso-8859-1">
<title>Flash audio test</title>

</head>

<body>
<div>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width=30 height=20>
<param name=movie value="http://192.168.1.103:88/player_mp3_maxi.swf" />
<param name=quality value=best />
<param name=FlashVars value="width=30&showslider=0&mp3=http://192.168.1.103:88/broadwavehigh.mp3?src=1" />
<embed src="http://192.168.1.103:88/player_mp3_maxi.swf" FlashVars="width=30&showslider=0&mp3=http://192.168.1.103:88/broadwavehigh.mp3?src=1" width=30 height=20 quality=best type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer" />
</object>
</div>

<p>click to play</p>
</body>
</html>

 

 

you would need to change the IP address to that of your WAN (as provided by your ISP) if you upload to a web hosting service.

 

Brian

Share this post


Link to post
Share on other sites

Okay I'm not the brightest man in the world but I'm also not the dumbest.. For some odd reason I can't get this flash player to work on my website... I used your code that you had put on here but obviously changed the IP and what not... I need some help!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...