Jump to content
gjctech

Uplink with Asterisk 1.4

Recommended Posts

I'm currently trying to get Uplink Skype2SIP working with Asterisk 1.4. Uplink is running on WinXP Pro SP3 and Asterisk on CentOS 5. I've got Uplink registered as a SIP peer on Asterisk and I suspect that part of the jigsaw puzzle is working.

 

Whenever I try dialling out (from Asterisk to Skype), the Uplink "console" shows an incoming SIP call but says nothing about passing it to Skype and the Skype client does nothing. It's pretty much the same in the other direction. The Skype client shows an incoming Skype call, but Uplink isn't grabbing it or passing it to Asterisk and there's nothing shown on the Asterisk console.

 

In Skype Options I've allowed Uplink to have control of Skype and I've set Microphone, Speaker, and Ringing to Uplink in Audio Settings.

 

In Uplink, I've set "When SIP calls use the dialled number" and "When Skype calls dial the following number" (which I've set to "uplink" (without the quotes))

 

In Asterisk:

in sip.conf I've created a peer called uplink_skype

in extensions.conf I've created an extension "uplink" for my main ring group in the context to which uplink_skype is assigned. I've also created an outgoing extension:

exten => 1001,1,Dial(SIP/myskypeaccount@uplink_skype)

Note that "myskypeaccount" is different to the account used for the Skype client attached to Uplink.

 

It suspect that Uplink isn't talking to Skype, but I can't see what I've done wrong and so would appreciate some help!

 

Geoff

Share this post


Link to post
Share on other sites

I tried to edit my previous post to add the following, but the system said I didn't have adequate permission - so please excuse my replying to my own post.

 

I've partially resolved this. It turned out that the Uplink sound driver was muted both for playback and record. To un-mute these, I used the following procedure:

  1. Double-click the Volume system tray icon
    The Play Control panel opens
  2. From the Options menu, choose Properties
    The Properties dialog box opens
  3. From the Mixer list, choose Uplink then select the Playback radio button then click OK
    The playback properties for the Uplink driver are shown
  4. Ensure Mute All and the individual Mute checkboxes are cleared
  5. Repeat steps 2 to 4 for the Record properties

Skype now reacts to incoming and outgoing calls. However, no audio passes in either direction and Skype drops the calls after a few seconds. For outgoing calls, Skype shows a message asking me to check that my microphone is connected. I suspect that there's a codec issue. I've configured Asterisk to use GSM, G.711 uLaw, or G.711 ALaw but I don't know how to check which (if any) has been negotiated or even which codecs Uplink can use.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...