Jump to content
Sign in to follow this  
KenA

How to use Broadwave to stream audio being generated on the same PC.

Recommended Posts

In the first post about installing on Windows 7, I used Broadwave to stream an external audio source which was connected via Line In.

( http://nch.invisionzone.com/index.php?showtopic=13099 )

 

If, on the other hand, the audio content is generated on the same PC by a separate program, then here are some Windows 7 notes to help.

 

For example, I use the radio automation program ZaraRadio to run an unattended radio station, so ZaraRadio's output can be listened to by listening to the playback of the default audio device - in other words by plugging speakers into the PC's Line Out.

 

But, how do I stream that music?

 

Broadwave's Live stream is the sound source which is currently selected in the "recording control" part of Windows sound.

 

Go to Control Panel / Hardware and Sound / and click Manage Audio Devices. Click on the Recording tab.

 

Scroll down the list, and the one which is shown is the sound source which will be relayed by Broadwave Live 1.

 

The most important ones are Line In and Stereo Mix.

Line In selected will cause Broadwave to stream the audio from the Line In connector on the PC.

Stereo Mix selected will cause Broadwave to stream the audio from any audio playing on the PC, e.g. playing MP3s with Winamp, or in my case using ZaraRadio.

 

If the one you want is not shown in the list, it might be disabled. You should right-click on any of the sources and make sure that Show Disabled Devices is ticked. The list will probably be longer now.

 

Select the device you want. If it's disabled, right-click it and select Enable from the menu.

Now, right-click it again, and select Set As Default Device. Then click OK.

 

That should be it.

 

 

These instructions were written using a clean install of Windows 7, but I suspect Vista is similar. I've posted them here to help you, and also to remind me the next time I have to reinstall Windows. :lol:

Share this post


Link to post
Share on other sites

Hi Ken,

 

I have been following your tips for getting Broadwave Audio to run on Windows 7. My husband just bought this new desktop with Windows 7 on it and I was previously running Broadwave on XP.

 

My goal is to have a mic hooked up to the PC and have that streaming AND to have any music I play from my computer (iTunes, YouTube, Pandora etc.) streaming as well.

 

I have the mic in the "line in" (blue) port and my speakers in the "line out" (green)port. On the Realtek audio manager that comes up I can only make EITHER "line in" or "Stero Mix" the default device, so that confused me. I am able to speak in the mic and hear myself talking through the speakers, and any audio I play is coming through the speakers.

 

I have two streams set up on Broadwave: 1 I have set as "line in" and the other set to "speakers". Both streams show visually that the sound is coming through (I see the sound bars moving up and down with voice/music), but I am not able to get either to stream from another computer, or the computer I'm using.

 

I have the router settings configured to this new computer following the directions on the NCH site. They are set the same way as my old computer. I updated the code on the website that we stream from.

 

I am somewhat new to Broadwave in general and even newer now to Windows 7, so I'm sort of at a loss. Since you were able to to get it to work and seem to be quite knowledgable I was hoping you could help me.

 

Thank you.

Share this post


Link to post
Share on other sites

UPDATE: I was able to get the mic and the speakers to stream live on Broadwave, but enabling the "stereo mix" gives all audio a horrible reverb effect that makes it almost impossible to listen to. I have disabled all audio effects and tried everything I know how. Now I'm back to only being able to stream the mic. I was able to do this with Windows XP no problem, why not with Windows 7?

 

Hi Ken,

 

I have been following your tips for getting Broadwave Audio to run on Windows 7. My husband just bought this new desktop with Windows 7 on it and I was previously running Broadwave on XP.

 

My goal is to have a mic hooked up to the PC and have that streaming AND to have any music I play from my computer (iTunes, YouTube, Pandora etc.) streaming as well.

 

I have the mic in the "line in" (blue) port and my speakers in the "line out" (green)port. On the Realtek audio manager that comes up I can only make EITHER "line in" or "Stero Mix" the default device, so that confused me. I am able to speak in the mic and hear myself talking through the speakers, and any audio I play is coming through the speakers.

 

I have two streams set up on Broadwave: 1 I have set as "line in" and the other set to "speakers". Both streams show visually that the sound is coming through (I see the sound bars moving up and down with voice/music), but I am not able to get either to stream from another computer, or the computer I'm using.

 

I have the router settings configured to this new computer following the directions on the NCH site. They are set the same way as my old computer. I updated the code on the website that we stream from.

 

I am somewhat new to Broadwave in general and even newer now to Windows 7, so I'm sort of at a loss. Since you were able to to get it to work and seem to be quite knowledgable I was hoping you could help me.

 

Thank you.

Share this post


Link to post
Share on other sites

UPDATE: I was able to get the mic and the speakers to stream live on Broadwave, but enabling the "stereo mix" gives all audio a horrible reverb effect that makes it almost impossible to listen to. I have disabled all audio effects and tried everything I know how. Now I'm back to only being able to stream the mic. I was able to do this with Windows XP no problem, why not with Windows 7?

 

I thought maybe this was the work-around that I was looking for but I am having the same issues as ITwife. I'm getting a reverb effect when I'm using the, "line in" jack with a telephone hooked into it. I've hooked up a CD player to the mic imput. I don't seem to be getting the reverb from the CD, just when I talked into the phone it comes across and then it seems to repeat about ten seconds later. I added the CD player to the stream list. At least I can get music to play as well getting the "line in" to work as well. Before, I could get one or the other to work but not both at the same time. I'm also using Windows 7-Home Edition.

Share this post


Link to post
Share on other sites

Feedback and echo like you describe is usually the result of one source of sound such as the "mix" being also selected as an input device. Think of it like when you have a PA system and the mic is too close to the speakers, you get feedback. Well, some setting somewhere may be causing similar feedback.

 

I run Broadwave on Windows XP, but I had a look at the settings on my Win 7 laptop, and when I open the sound devices and select the Recording Devices tab, I can see a source called Rec Playback. When I select its Properties, there's a tab called Listen, and it has a checkbox "listen to this device" - which is unticked on my laptop.

 

It's difficult for me to say what might be the cause, but have a look at your config to see if there's something similar, and if listen is ticked, try un-ticking it to see if that's the cause.

 

If you cure it, please post back and let us know. Thanks.

Share this post


Link to post
Share on other sites

Feedback and echo like you describe is usually the result of one source of sound such as the "mix" being also selected as an input device. Think of it like when you have a PA system and the mic is too close to the speakers, you get feedback. Well, some setting somewhere may be causing similar feedback.

 

I run Broadwave on Windows XP, but I had a look at the settings on my Win 7 laptop, and when I open the sound devices and select the Recording Devices tab, I can see a source called Rec Playback. When I select its Properties, there's a tab called Listen, and it has a checkbox "listen to this device" - which is unticked on my laptop.

 

It's difficult for me to say what might be the cause, but have a look at your config to see if there's something similar, and if listen is ticked, try un-ticking it to see if that's the cause.

 

If you cure it, please post back and let us know. Thanks.

 

I still get a reverb trying it that way too. Here's what's happening. I plug a phone into the, "line in" jack (Blue) jack. I hook a CD player into the, "front mic" jack on the front of my tower. I call my phone number. While the CD is playing, I also talk into my cell phone which is connected to my home phone which is connected into the, "line in" jack. I say something and it comes across on the stream. About 10-12 seconds later, the same thing I said comes across on the stream again, only the quality is much less, like an echo of what I just said. On the recording tab, I have selected, "stereo mix" as the default communication device. That's the only thing that is checked. All of the inputs, the, "listen to this device" is unticked.

Share this post


Link to post
Share on other sites

The 10-12 sec delay is a typical encoding delay, so it sounds like you have a loudspeaker playing the encoded stream which is also being heard by the cell phone?

 

Also, phone lines will echo their audio, so try it without a phone line: try the CD audio into each of the inputs separately to see if the echo happens with only one, and if so, which one.

 

If there's no echo with either, try two different audio feeds, perhaps two different CD players, but not the phone line. If there's no echo, then it's due to the phone line.

 

Radio stations generally employ specialist hardware to allow phone calls to be taken on-air, and it's not as simple as just plugging the phone's audio into the mixer. I suspect the phone line is the cause of your problem.

Share this post


Link to post
Share on other sites

we are having similar problem. i think. we have two streams running (one with our mic and us talking thru it, and one with zulu running playing songs from our pc) but how do we merge the two so it becomes, esentially, one stream (meaning one link that our listeners would click to hear us talking and our music) ???? any help would be great!!!! :)

Share this post


Link to post
Share on other sites

we are having similar problem. i think. we have two streams running (one with our mic and us talking thru it, and one with zulu running playing songs from our pc) but how do we merge the two so it becomes, esentially, one stream (meaning one link that our listeners would click to hear us talking and our music) ???? any help would be great!!!! :)

 

Hi

It will depend on the capabilities of your soundcard, as to whether the mic input and wave output can be combined. If you can hear both the music and your mic through your pc's speakers or speaker output, then it will work. You'll need to select the Stereo Mix to be used by Broadwave (see original post). If you can't hear both through the speakers, then it won't be possible with your computer's soundcard.

 

Broadwave will simply stream what it's configured to stream, it's not a mixer. You would need to set that via the soundcard or use and external mixer and feed it to the PC's line-in as the input to Broadwave.

Share this post


Link to post
Share on other sites

Sounds like you need Virtual Audio Cable. Not free, but excellent. I use Zara radio too, its output is carried via VAC to standalone Stereo Tool for processing, then on to Broadwave using a second cable. To mix a mic into it you should be able to use two cables to Broadwave, (using the same output on both) and you can adjust levels by including a volume control on one (or both) of the cables. That takes up a little more CPU power but a modern PC shouldnt have too much trouble handling it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×