Jump to content

beatlesgeek

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About beatlesgeek

  • Rank
    Novice
  1. Just looked at my version and you're right---I needed to upgrade. Thank you very much for letting me know!
  2. When upgrading to the Catalina OS on Mac, the system states that VIdeopad is not compatible. Are there any plans to update the software? I use it often and would hate to give it up. Thanks!
×
×
  • Create New...