Jump to content
Sign in to follow this  
lourdesmz

Can't use WavePad, Need ID Key and cannot get it

Recommended Posts

lourdesmz    0

By mistake, I deleted my WavePad software and when I reinstalled it it doesn't let me access it the second time, even though I have input my ID Key, registration number, etc.

 

I tried to get through the WavePad services and now is stating that I do need to purchase service for help... how can this be possible if all I want is my own access to my own software... that's all?

 

I need help ASAP. I have a public charity that needs the aid of this software on a daily basis.

 

Lourdes Metz, President :(

Paranormal Awareness Society, Corp.

 

Please email me at:

 

paranormalawarenesssociety@gmail.com

Share this post


Link to post
Share on other sites
Guest nchgb   
Guest nchgb

What exactly did the error message say when you tried to put your registration information in? It is a very specific error message and tells you exactly what you need to do. Please contact registration support, they'll be able to assist you further: www.nch.com.au/support/reg.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×