Jump to content


adding black bars to NTSC video

black bar crop NTSC

  • Please log in to reply
5 replies to this topic

#1 dbaca67

dbaca67

    Novice

  • Members
  • Pip
  • 3 posts

Posted 06 January 2017 - 01:44 AM

Hello.
I just started playing with VP for editing my old DV video sources. The sources are avi files, DV type 2, NTSC.
When I take a single source file, put it in Storyboard and export the video as NTSC DV avi file, the picture horizontally shrinks and black bars are added.
The source file is recognized by VP as an NTSC file, 720x480. I have changed the preview to NTSC 640x480 as predefined in VP.
I have exported the video with output format auto-detection resulting in NTSC 640x480. I believe it somehow means 720x480 because that is how VP then recognizes the created file.
However, the result is a video with black bars on both sides. I have tried different settings but I got always the black bars.

To me, this is wrong. I just put in a single file, a clip, no effects, and I just created a new clip out of VP. The result is a modified and deformed video.

Any suggestion how to get rid of the black bars?

#2 borate

borate

    Einstein

  • Members
  • PipPipPipPipPipPipPip
  • 1,126 posts

Posted 06 January 2017 - 03:54 AM

Check out this recent thread.   And this one.

#3 dbaca67

dbaca67

    Novice

  • Members
  • Pip
  • 3 posts

Posted 06 January 2017 - 10:59 AM

I read the threads. Still, it is not clear to me.
It should be quite straightforward if there are no changes applied to video. The scenario is as follows.
I include a video file in NTSC format captured from a video camera, so the encoding is DV (DirectShow). The video file is the only clip in Storyboard. I export an NTSC video out of the project. I would expect the dimensions and quality to be the same as the original because no formatting was done. Yet, this is not the case.
The only way to get out a DV video without the bars was to set the preview to 720x480, export file to 640x480 and then say Crop when exporting. Yet, the resulting quality was bad in terms of picture.

I would assume that setting the preview to 640x480 and exporting to 640x480 should work. With those settings when I export to mp4 format, no bars. When I export to DV encoding, the bars are there.

#4 dbaca67

dbaca67

    Novice

  • Members
  • Pip
  • 3 posts

Posted 08 January 2017 - 11:38 AM

So, I have created a few tests with the conclusion that producing avi video with DV encoder under Videopad is buggy.
I have created a simple video containing a single video clip - the source is avi with NTSC DV encoding. When this video is put in Videopad in Video Files tab, it is converted from 720x480 to 640x480, which is actually correct if taking into account the fact that the source pixels are not rectangular.

First, let's start with what works - mp4 encoding.
I set preview to 640x480 and produce mp4 file with the size 640x480. The picture is good, no bars added.
Next I set preview to 720x480 and produce mp4 file with the size 720x480. The bars are added to left and right to pad the picture to 720x480.
Overall, the result is as expected.

Next, avi, DV encoding.
I set preview to 640x480 and produce avi file 640x480. Bars are added left and right, picture stretched vertically.
Further, I set the preview to 720x480 and produce avi file 720x480. Again, bars left and right, picture stretched vertically.
The both avi files are of the same size. So, I run binary file compare. The two avi files are completely identical.
I do not think they should be.

Conclusion: avi DV encoding is faulty.


#5 c_major

c_major

    Einstein

  • Admin
  • PipPipPipPipPipPipPip
  • 953 posts

Posted 09 January 2017 - 12:43 AM

Confirmed this is a bug.

Thanks for reporting this.

#6 c_major

c_major

    Einstein

  • Admin
  • PipPipPipPipPipPipPip
  • 953 posts

Posted 09 January 2017 - 06:41 AM

Before we get this issue sorted, there is a way to output correct DV clips.

First of all, DV codec output resolution is fixed to 720x480 and pixel aspect ratio is 3:2.

Use a 3:2 preview resolution (i.e. 720x480). Import the 640x480 source video (you will see the back bars) and apply a Scale effect stretch the video to fill up the preview frame and remove the back bars. Export using DV codec with output resolution of 720x480.





Also tagged with one or more of these keywords: black bar, crop, NTSC