Sign in to follow this  
Followers 0
Aresby

Exported audio quality on NARRATED audio terrible

11 posts in this topic

I don't understand this: I've created a short 30 second video which consists of some text and audio narration (created by recording my voice within VP). Sounds fine in VP but when I export it (with exactly the same settings as I always have done) it sounds distorted as though it's clipping (even if I speak really, really quietly).

 

If I record a video using OBS and import that and then export it (as above) it's fine. But narrated audio in VP always sounds awful even though it plays fine within VP.

 

Using version 4.58 in Windows.I've used the Record > Narrate often and it's always been fine up until now. Using 128kbps quality, 25fps for the video, 8192 bit rate (as always for YouTube).

 

Anybody got any ideas? (I guess it will only take you a minute to try and duplicate this).

Share this post


Link to post
Share on other sites

Where are you setting the "quality" options?

 

Have you checked the mic level input at the Windows mixer? Right-click the speaker icon (in the notification area) and click on recording devices.

 

Tested a narrated export (mp4) here and results matched those in VP preview.

Share this post


Link to post
Share on other sites

"Tested a narrated export (mp4) here and results matched those in VP preview."

 

In that case I will have to experiment further, perhaps it's a 4.58 change. Remember that I do this sort of thing several times a week (narrate, that is) and this is the only time I've had a problem.

 

I will follow your guidance and if no luck send you the project (only 30 seconds long) with my generated output to see if you can repeat it or tell me what's going on!

Share this post


Link to post
Share on other sites
I will follow your guidance and if no luck send you the project (only 30 seconds long) with my generated output to see if you can repeat it or tell me what's going on!

 

Please sent the files to me.

Share this post


Link to post
Share on other sites

Please sent the files to me.

I've uploaded the VP project (EndCardsTestNarration) and narration (.wav) files, plus the generated .mp4 output to this location: https://www.dropbox.com/sh/4owslf2e9g0tamh/AACi3ik8zF_u3RyJvpVMyQ1aa?dl=0

 

The audio when playing in VP sounds as I would expect; the generated audio in the .mp4 file sounds clipped. This only happens when using a narrated source, not a video input file, I've found. I'm generating the output at 25fps YouTube HD 1920 x 1080, custom quality of 8192 bps and audio at 128k (these settings have been used for the past 12 months).

 

Can you hear the distortion in my generated .mp4 file? Does your generated .mp4 file sound the same? I've double-checked all the microphone input level settings. Remember that I'm still recording video using the same audio settings using OBS and everything is as it always was, just fine.

Share this post


Link to post
Share on other sites

4.58. The audio level of narration was low, so the original track was replaced with a normalized copy.

 

Outputted two video files, one using the MPEG4 compressor with 8192 avg. and max. settings, 128 bit rate, 25fps YouTube HD 1920 x 1080...and the other using the H264 encoder defaults.

 

Both sounded identical, with no clipping. Here's the H264 final. Try using default audio settings.

Share this post


Link to post
Share on other sites

I've uploaded the VP project (EndCardsTestNarration) and narration (.wav) files, plus the generated .mp4 output to this location: https://www.dropbox....JvpVMyQ1aa?dl=0

 

The audio when playing in VP sounds as I would expect; the generated audio in the .mp4 file sounds clipped. This only happens when using a narrated source, not a video input file, I've found. I'm generating the output at 25fps YouTube HD 1920 x 1080, custom quality of 8192 bps and audio at 128k (these settings have been used for the past 12 months).

 

Can you hear the distortion in my generated .mp4 file? Does your generated .mp4 file sound the same? I've double-checked all the microphone input level settings. Remember that I'm still recording video using the same audio settings using OBS and everything is as it always was, just fine.

Hi Aresby, as borate said, it seems your output mp4 file has been normalized. Can you please check your videopad->Options->Media and make sure "Automatically normalize audio volume" is disabled.

Share this post


Link to post
Share on other sites

Just saw the above response about my narrated audio - I'll certainly try this but I do really want the audio on the entire video normalised (when exporting and during playback in VP), so by disabling it will this cause me issues?

 

BTW I'm not even sure if I've got that setting checked, I'll test it out on Saturday (21st Jan).

Share this post


Link to post
Share on other sites

Hi

For what it may be worth....

Yes, the sound on the utube clip is clipped. I have just done a short test with a couple of clips to see what I get as narration with previous versions of VP have been OK.. These are the stting I have used......

 

In Audio Options....Normalized audio volume is ticked.

I am using a small mike plugged into the "Microphone" socket (Pink) on the front panel of the PC

I have muted the existing sound on the clips so as to hear the narration result better.

Select Audio...Record...Narrate

 

Settings:- (Default Sound In)

Windows Record Mixer

I have a Realtek microphone option but have selected the default option.

Click red button and record the narration.

The played back file sounds perfectly clear. (Microphone about 3" away) The recording level meter stayed in the yellow zone throughout.

The played back video in VP sounded perfectly clear.

Exported the video as a Video File (To PC)

Preset to Custom

File type .mp4

Resolution 1280 x 720 U tube 720

Encoder options: Compressor H264

Quality 10 (High)

Audio average bitrate 320

 

The exported videoclip played back perfectly clearly without any clipping. The microphone level was set up via the control panel.

 

Nat

Share this post


Link to post
Share on other sites

I tested this out, using the settings suggested by Nat et al and discovered a few things.

 

1. I set Normalise Audio on (a full description of how things works - you say it replaces existing audio rather than just amplifying it? - would be useful) as I want my entire video at a fairly standard audio level when exporting (a bit like how a radio station might do it, with both compression and limiting).

 

2. I discovered my input audio source was set to the USB microphone so I changed it to Default Device and Windows Mixer and found that the USB microphone was already the default device but it was set at 78% input level.

 

3. I discovered that I had OBS set to a 10 point amplification setting because the microphone level was a bit low.

 

4. Setting the microphone level in Windows Mixer to 95% (I found 100% made it go to max too often during general speaking) and removing the OBS amplification factor I found that:

  • Narration in VP sounded just fine during playback and after video export (no discernable clipping on final mp4 video)
  • OBS did not object to the new 95% microphone level when recording raw material and indeed, went to about 95% of 0dB during recording
  • The OBS video sounded fine (a little louder than usual but no clipping)
  • On importing video into VP it sounded fine with no clipping, although the waveform indicated a higher than usual level
  • On exporting from VP into final mp4 it sound just like VP playback, no clipping

So it seems that thanks to your great suggestions I have cracked it! Not only that, I've got "better" settings because the audio going into OBS is higher requiring no boost, and the resultant video into VP seems to be handled just fine too, and I might be able to speak slightly further away from the microphone to allow a greater dynamic range (but not too great).

 

Thanks guys, let's hope it stays this way! (But an explanation of how Normalise Audio works would still be useful)

Share this post


Link to post
Share on other sites

Some OBS info, if you haven't already run across it.

 

Extract from Wavepad HELP...

To 'normalize' is to adjust the volume so that the loudest peak is equal to (or a percentage of) the maximum signal that can be used in digital audio. Usually you normalize files to 100% as the last stage in production to make it the loudest possible without distortion. Another reason to normalize is to have multiple tracks sound equally loud, or to have equal average loudness.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0