Sign in to follow this  
Followers 0
Hilfe

Video Output Message

20 posts in this topic

I am unable to export any version of my project, the error message reads "could not initialise video output", I would be grateful for any advice, thanks

Share this post


Link to post
Share on other sites

Be sure there's an entry listed in the output format box. When you say "any version" have you tried MPEG or a format other than the one you attempted earlier?

 

What version of VP? Trial or registered?

Share this post


Link to post
Share on other sites

Hi

 

What steps are doing to output your video and what version are you using and can you save it to your PC?

It may be that you have an unregistered version of VP. If so, you can save the project (.vpj) file but not export it. Normally this would show a standard "Buy now" message.

 

Nat

Share this post


Link to post
Share on other sites

This message is not used in the recent versions. Your problem could just be fixed by upgrading VideoPad.

 

Best regards.

Share this post


Link to post
Share on other sites

Thank-you very much for your responses, I really appreciate your help.

I am currently using trial version 3.89, which I assume is the lastest version as I only downloaded it this week?

I had tried multiple of the available formats without success yesterday. Thank-you for your suggestion, I tried .mpg today and it worked! I'm not sure how versatile this format is (to play on TV, PC etc) so am still keen to understand why the other formats are not working. I was unable to find the "output format box" selection. I assume .vpj can't be played on other devices.

(I had previously purchased a copy of the program but lost it when my computer hard drive crashed)

Thanks again :)

Share this post


Link to post
Share on other sites

The output format is specified under EXPORT|VIDEO|File Format. Few choices will be available in the trial version.

 

Videopad uses the VPJ file to construct the project. That file is not playable.

 

If you feel that your VP should be registered, seeing as you lost your original purchase, check out links on the page...

http://www.nchsoftware.com/videopad/support.html

Share this post


Link to post
Share on other sites

It could be your component files are messed up.

 

Please try this:

  1. Close VideoPad.
  2. Delete everything in components folder using windows explorer: C:\Program Files (x86)\NCH Software\Components
  3. Restart VideoPad and export again.

You'll need internet access when you do so. The components will be automatically downloaded from our server when you export again.

Share this post


Link to post
Share on other sites

Hello again and thank-you for your help and suggestions.

 

As kindly suggested, I deleted the Components folder and restarted the program, but found that the trial version no longer allows any export of the project (perhaps it only allowed a limited time initially?).

 

I found my original registration code but couldn't use it as it was an older version of the program. I repurchased the program, but am receiving the same error messages with any format except for .mpg. The error messages are:

"Error

ShellExecuteEx failed; code 1155.

No application is associated with the specified file for this operation.

Error

Failed to create your movie.

Could not initialize video output."

 

I don't understand why my newly paid version doesn't work for the other formats that I require to play on other media such as TV.

Any further advice would be greatly appreciated. Thank-you.

Share this post


Link to post
Share on other sites

Could you please try clear another component folder: C:\Users\[user name]\AppData\Roaming\NCH Software\Components

 

This is the component folder for latest versions.

 

Please be aware of that you might behind a firewall that blocks VideoPad from communicates to the server so the components can not be downloaded.

 

Please check if there are new files in the component folder after you see the install on demand progress dialog (when you export again).

 

 

Best regards.

Share this post


Link to post
Share on other sites

Hello, thanks for your continued help.

I deleted the contents of the Components folder (it was hidden but found it by searching %appdata%), I also allowed Videopad Video Editor program as an allowed program through my Windows Firewall. When I reopened Videopad and exported the project, the following folders appeared in the Components folder: ffmpeg19, x264enc7. When I attempt to export the project, the error message now reads:"Failed to create your movie. The specified file path appears to be locked". It still allows .mpg to be created. Thanks

Share this post


Link to post
Share on other sites

Right click on the Videopad.exe file and click RUN AS ADMINISTRATOR. Any change?

Share this post


Link to post
Share on other sites

Hi,

No change after rebooting of computer.

I searched for 'videopad.exe' and brought up the file 'vppsetup'. I ran this as administrator and it opened the program after re-accepting the licence agreement. At first I thought this finally solved the problem as it seemed to allow creation of more formats. Unfortunately I have since tried to create a .wmv file (which was working earlier) and I am getting the previous message again "Failed to create your movie. Could not initialize video output". I tried other versions such as mp4 and the video cuts off the sides of the screen so my text can't be fully read.

Any further suggestions greatly appreciated.

Share this post


Link to post
Share on other sites

If you clicked on VPPSETUP you reinstalled the program. Try right-clicking|RUN AS ADMINISTRATOR on VIDEOPAD.EXE instead, to start the already installed program.

The path should be something similar to ... c\Program Files (x86)\NCH Software\VideoPad\videopad.exe

 

Probably won't help, but won't hurt either.

 

For your export, you tried various resolutions? res.jpg

Share this post


Link to post
Share on other sites

Hello, still couldn't find a file named 'videopad.exe' but in that file path folder was a 'videopad' file that I ran as administrator too, unfortunately didn't seem to change the functionality. The same error message appeared when I changed to low resolution as above. I appreciate your continued efforts.

Share this post


Link to post
Share on other sites

Your Windows installation is configured to not display extensions, apparently, and that's why you did not see the .exe designation.

 

You might try different resolutions, not necessarily the "low" one, with an Mp4 output, to see if the images are cut off. Test the "wide screen" choices.

Share this post


Link to post
Share on other sites

It seems the error message was caused by the VideoPad components couldn't run properly.

 

To help us better diagnostic the problem, could you please do the following suggested by Borate some time ago:

 

Click START|RUN and in the search box type "dxdiag" <enter> No quotes.

Let the green bar complete, then click the SAVE ALL INFO bar and save the file to a folder that you can easily locate - perhaps the Desktop.

 

Open that folder and double-click the file. It should open in a text editor - perhaps Notepad. Click anywhere, then press <crtl-A> simultaneously, to SELECT ALL. Press <ctrl-C> to COPY.

 

In your next post, press <ctrl-V> to PASTE the file into the compose window. An attachment would be better, but that feature is not enabled in this forum. No personal information is contained in the file.

Perhaps inspection by someone reading here will give clues on solving your issue.

Share this post


Link to post
Share on other sites

Hi Hilfe

 

It's quite useful in video editing to be able to see the file extensions. This is a Windows setting.

To turn these on...(In Vista at least..)

Click the Windows start button at the bottom left of the screen and choose the Control Panel.

In the Control Panel screen look for "Folder Options" (My version of Vista is French but you will see which icon I mean)

Double click this and then the "Appearance" tab at the top of the window that opens.(The middle tab)

Scroll down the list of boxes and untick the one labelled "Hide the file extensions of known types" (or something similar)

Click the OK button and now when you open folders the files they contain will have their extensions showing.

You can reverse this at any time by putting the tick back in box.

 

Nat

Share this post


Link to post
Share on other sites

 

please do help me assemblief I have been trying to export a video on videopad editor but it says. "Failed: an install on demand component could not be installed... Link?

Share this post


Link to post
Share on other sites

Are you running the latest VP version?

 

Try the download/install once gain.

 

Be sure you're connected to the Net while installing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0