Jump to content

Debut

Discussion forum for users of Debut Video Capture Software


Debut

This is the Discussion Forum for the Debut software. If your problem is not covered by the Topics on this Forum, please start your own topic and post your question. If you can answer any other users posts please do so.

Our Technical Support team will, on a best efforts basis, review posts and answer questions. However, this forum is designed to be self-help and relies on the user community to answer posts. Please visit NCH Technical Support for help from our technicians.

Messages sent directly to NCH Staff for support will not be answered.

571 topics in this forum

  1. Not recording sound

    • 2 replies
    • 414 views
    • 1 reply
    • 230 views
    • 1 reply
    • 280 views
    • 1 reply
    • 257 views
    • 1 reply
    • 670 views
    • 1 reply
    • 378 views
    • 1 reply
    • 428 views
    • 0 replies
    • 277 views
  2. No sound, video looks great

    • 1 reply
    • 917 views
    • 2 replies
    • 435 views
    • 0 replies
    • 346 views
  3. Upgrades?

    • 1 reply
    • 281 views
  4. Skype?

    • 2 replies
    • 337 views
    • 1 reply
    • 629 views
    • 1 reply
    • 354 views
    • 0 replies
    • 284 views
    • 0 replies
    • 264 views
  5. Debut and KWorld USB interface

    • 1 reply
    • 378 views
  6. Tray Only icon.

    • 2 replies
    • 336 views
    • 3 replies
    • 560 views
    • 1 reply
    • 424 views
    • 0 replies
    • 217 views
    • 2 replies
    • 399 views
    • 3 replies
    • 936 views
    • 3 replies
    • 436 views
×